summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-18 15:20:19 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-18 15:20:19 +0000
commitce7c28a39577fede0b05995255cf25a2a4ba7a4c (patch)
tree684d64f47cc6a1f4d12b07bbb9935d32ed2c36d2
parentalpha/ia64/sparc stable wrt #333717 (diff)
downloadgentoo-2-ce7c28a39577fede0b05995255cf25a2a4ba7a4c.tar.gz
gentoo-2-ce7c28a39577fede0b05995255cf25a2a4ba7a4c.tar.bz2
gentoo-2-ce7c28a39577fede0b05995255cf25a2a4ba7a4c.zip
Respecting LDFLAGS, 337878
(Portage version: 2.2_rc83/cvs/Linux x86_64)
-rw-r--r--app-misc/countrycodes/ChangeLog10
-rw-r--r--app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild37
-rw-r--r--app-misc/countrycodes/files/1.0.5-Makefile.patch42
3 files changed, 87 insertions, 2 deletions
diff --git a/app-misc/countrycodes/ChangeLog b/app-misc/countrycodes/ChangeLog
index 56d2736908bd..a464cbac5024 100644
--- a/app-misc/countrycodes/ChangeLog
+++ b/app-misc/countrycodes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/countrycodes
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/ChangeLog,v 1.20 2009/09/23 16:00:20 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/ChangeLog,v 1.21 2010/09/18 15:20:19 jlec Exp $
+
+*countrycodes-1.0.5-r1 (18 Sep 2010)
+
+ 18 Sep 2010; Justin Lecher <jlec@gentoo.org> +files/1.0.5-Makefile.patch,
+ +countrycodes-1.0.5-r1.ebuild:
+ Respecting LDFLAGS, 337878
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> countrycodes-1.0.5.ebuild:
Remove virtual/libc
diff --git a/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild b/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..a82ec0d41645
--- /dev/null
+++ b/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/countrycodes/countrycodes-1.0.5-r1.ebuild,v 1.1 2010/09/18 15:20:19 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An ISO 3166 country code finder"
+HOMEPAGE="http://www.grigna.com/diego/linux/countrycodes/"
+SRC_URI="http://www.grigna.com/diego/linux/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${P}/src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-Makefile.patch
+ tc-export CC
+}
+
+#src_compile() {
+# emake -C src CCOPTS="${CFLAGS}" || die "emake failed"
+#}
+
+src_install() {
+ emake \
+ prefix="${D}/usr" \
+ mandir="${D}/usr/share/man/man1" install || die "make install failed"
+ dosym iso3166 /usr/bin/countrycodes || die
+ dosym iso3166.1 /usr/share/man/man1/countrycodes || die
+ dodoc ../doc/{Changelog,README} || die
+ prepman
+}
diff --git a/app-misc/countrycodes/files/1.0.5-Makefile.patch b/app-misc/countrycodes/files/1.0.5-Makefile.patch
new file mode 100644
index 000000000000..4ee47e32dfd2
--- /dev/null
+++ b/app-misc/countrycodes/files/1.0.5-Makefile.patch
@@ -0,0 +1,42 @@
+diff --git a/src/Makefile b/src/Makefile
+index 9330578..3ff7319 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -26,13 +26,13 @@ BINMODE=755
+ LOGDIRMODE=700
+
+ # Compiler to use
+-CC=gcc
++CC ?= gcc
+
+ # Compiler warnings
+-WARNINGS= -pedantic -Wall
++WARNINGS=
+
+ # Compiler flags
+-CCOPTS = -O2 -fomit-frame-pointer
++CCOPTS = ${CFLAGS}
+
+ # The makefile standards document I read says that I have to put it here...
+ SHELL = /bin/sh
+@@ -61,7 +61,7 @@ PROGRAM = iso3166
+ all: $(PROGRAM)
+
+ $(PROGRAM): $(ISO3166OBJ)
+- $(CC) $(CCOPTS) $(ISO3166OBJ) -o $@
++ $(CC) $(CCOPTS) $(LDFLAGS) $(ISO3166OBJ) -o $@
+
+ clean:
+ rm -f $(ISO3166OBJ) core defines.h $(PROGRAM)
+@@ -70,8 +70,10 @@ strip:
+ strip $(PROGRAM)
+
+ install:
+- $(INSTALL) -g root -m $(BINMODE) -o root -s ${srcdir}/$(PROGRAM) ${bindir}
++ mkdir -p ${bindir}
++ $(INSTALL) -g root -m $(BINMODE) -o root ${srcdir}/$(PROGRAM) ${bindir}
+ @echo "Installing man page..."
++ mkdir -p ${mandir}
+ @$(SEDBIN) $(SEDCMDS) ${docdir}/iso3166.1.in > ${mandir}/iso3166.1
+ @chown 0.0 ${mandir}/iso3166.1
+ @echo