summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2006-09-13 16:17:27 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2006-09-13 16:17:27 +0000
commitd0e4948198a14c24b410202cd807891d1a00fe7e (patch)
treea25d6a33e089cb400db946830f0fccfd74690d58
parentVersion bump. (diff)
downloadgentoo-2-d0e4948198a14c24b410202cd807891d1a00fe7e.tar.gz
gentoo-2-d0e4948198a14c24b410202cd807891d1a00fe7e.tar.bz2
gentoo-2-d0e4948198a14c24b410202cd807891d1a00fe7e.zip
Added patch by kevquinn to make test succeed on hardened, Bug #130831.
(Portage version: 2.1.1)
-rw-r--r--media-libs/libmpeg2/ChangeLog6
-rw-r--r--media-libs/libmpeg2/files/libmpeg2-0.4.0b-use-readelf-for-test.patch26
-rw-r--r--media-libs/libmpeg2/libmpeg2-0.4.0b.ebuild6
3 files changed, 36 insertions, 2 deletions
diff --git a/media-libs/libmpeg2/ChangeLog b/media-libs/libmpeg2/ChangeLog
index 632fde1c9407..df7872d4b670 100644
--- a/media-libs/libmpeg2/ChangeLog
+++ b/media-libs/libmpeg2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libmpeg2
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/ChangeLog,v 1.47 2006/07/09 20:27:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/ChangeLog,v 1.48 2006/09/13 16:17:27 zzam Exp $
+
+ 13 Sep 2006; Matthias Schwarzott <zzam@gentoo.org>
+ +files/libmpeg2-0.4.0b-use-readelf-for-test.patch, libmpeg2-0.4.0b.ebuild:
+ Added patch by kevquinn to make test succeed on hardened, Bug #130831.
09 Jul 2006; Diego Pettenò <flameeyes@gentoo.org> libmpeg2-0.4.0b.ebuild:
Pinpoint virtual/x11 version to less than 7.
diff --git a/media-libs/libmpeg2/files/libmpeg2-0.4.0b-use-readelf-for-test.patch b/media-libs/libmpeg2/files/libmpeg2-0.4.0b-use-readelf-for-test.patch
new file mode 100644
index 000000000000..7d091cfbb04e
--- /dev/null
+++ b/media-libs/libmpeg2/files/libmpeg2-0.4.0b-use-readelf-for-test.patch
@@ -0,0 +1,26 @@
+--- test/globals.orig 2006-04-29 19:19:59.000000000 +0200
++++ test/globals 2006-04-29 19:24:35.000000000 +0200
+@@ -14,8 +14,9 @@
+
+ error=0
+
+-bad_globals=`nm -g --defined-only $builddir/../libmpeg2/*.o |\
+- awk '{if ($3) print $3}' | grep -v '^_\?mpeg2_'`
++bad_globals=`readelf -s $builddir/../libmpeg2/*.o |\
++ awk '$5=="GLOBAL" && $6!="HIDDEN" && $7!="UND" {print $8}' |\
++ grep -v '^_\?mpeg2_'`
+
+ if test x"$bad_globals" != x""; then
+ echo BAD GLOBAL SYMBOLS:
+@@ -23,8 +24,9 @@
+ error=1
+ fi
+
+-bad_globals=`nm -g --defined-only $builddir/../libmpeg2/convert/*.o |\
+- awk '{if ($3) print $3}' | grep -v '^_\?mpeg2convert_'`
++bad_globals=`readelf -s $builddir/../libmpeg2/convert/*.o |\
++ awk '$5=="GLOBAL" && $6!="HIDDEN" && $7!="UND" {print $8}' |\
++ grep -v '^_\?mpeg2convert_'`
+
+ if test x"$bad_globals" != x""; then
+ echo BAD GLOBAL SYMBOLS:
diff --git a/media-libs/libmpeg2/libmpeg2-0.4.0b.ebuild b/media-libs/libmpeg2/libmpeg2-0.4.0b.ebuild
index 5afe1a0c7486..fc2f31d17045 100644
--- a/media-libs/libmpeg2/libmpeg2-0.4.0b.ebuild
+++ b/media-libs/libmpeg2/libmpeg2-0.4.0b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/libmpeg2-0.4.0b.ebuild,v 1.30 2006/09/04 06:39:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libmpeg2/libmpeg2-0.4.0b.ebuild,v 1.31 2006/09/13 16:17:27 zzam Exp $
inherit eutils flag-o-matic autotools libtool
@@ -43,6 +43,10 @@ src_unpack() {
configure.in \
|| die "sed configure failed"
+ # Fix problem that the test for external symbols
+ # uses nm which also displays hidden symbols. Bug #130831
+ epatch "${FILESDIR}/${P}-use-readelf-for-test.patch"
+
eautoreconf
elibtoolize
}