summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-10-12 01:17:54 +0000
committerJeroen Roovers <jer@gentoo.org>2011-10-12 01:17:54 +0000
commitd1213c44b73216db891ec888c68e7fa03522483f (patch)
treede449bb8c794cba8aca04a2b1c1138750d3eda21
parentCommit properly patched ebuild. (diff)
downloadgentoo-2-d1213c44b73216db891ec888c68e7fa03522483f.tar.gz
gentoo-2-d1213c44b73216db891ec888c68e7fa03522483f.tar.bz2
gentoo-2-d1213c44b73216db891ec888c68e7fa03522483f.zip
Bump to EAPI=4. Use mirrored dillo.png (bug #370899).
(Portage version: 2.2.0_alpha66/cvs/Linux i686)
-rw-r--r--www-client/dillo/ChangeLog5
-rw-r--r--www-client/dillo/dillo-3.0.1.ebuild16
2 files changed, 13 insertions, 8 deletions
diff --git a/www-client/dillo/ChangeLog b/www-client/dillo/ChangeLog
index c906484bba02..90f98f8d4741 100644
--- a/www-client/dillo/ChangeLog
+++ b/www-client/dillo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for www-client/dillo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.96 2011/10/12 01:06:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/ChangeLog,v 1.97 2011/10/12 01:17:54 jer Exp $
+
+ 12 Oct 2011; Jeroen Roovers <jer@gentoo.org> dillo-3.0.1.ebuild:
+ Bump to EAPI=4. Use mirrored dillo.png (bug #370899).
12 Oct 2011; Jeroen Roovers <jer@gentoo.org> dillo-3.0.1.ebuild:
Commit properly patched ebuild.
diff --git a/www-client/dillo/dillo-3.0.1.ebuild b/www-client/dillo/dillo-3.0.1.ebuild
index 8a3f7c3c1f0a..9225694f4d41 100644
--- a/www-client/dillo/dillo-3.0.1.ebuild
+++ b/www-client/dillo/dillo-3.0.1.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-3.0.1.ebuild,v 1.2 2011/10/12 01:06:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/dillo/dillo-3.0.1.ebuild,v 1.3 2011/10/12 01:17:54 jer Exp $
+
+EAPI="4"
-EAPI="2"
inherit eutils flag-o-matic multilib
DESCRIPTION="Lean FLTK2-based web browser"
HOMEPAGE="http://www.dillo.org/"
-SRC_URI="http://www.dillo.org/download/${P}.tar.bz2"
+SRC_URI="http://www.dillo.org/download/${P}.tar.bz2
+ mirror://gentoo/dillo.png"
LICENSE="GPL-3"
SLOT="0"
@@ -37,7 +39,7 @@ src_configure() {
}
src_compile() {
- emake || die "make failed"
+ default
if use doc ; then
doxygen Doxyfile || die "doxygen failed"
fi
@@ -45,16 +47,16 @@ src_compile() {
src_install() {
dodir /etc
- emake DESTDIR="${D}" install || die "install failed"
+ default
if use doc; then
- dohtml html/* || die "install documentation failed"
+ dohtml html/*
fi
dodoc AUTHORS ChangeLog README NEWS
docinto doc
dodoc doc/*.txt doc/README
- doicon "${FILESDIR}"/dillo.png
+ doicon "${DISTDIR}"/dillo.png
make_desktop_entry dillo Dillo dillo
}