summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-09-04 13:34:47 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-09-04 13:34:47 +0000
commitd1a1a2a9ffe77afd46ffeb709a690e933f31e686 (patch)
treeaf00d8f9cfe70f4c4e718eba0753609345d42c5c
parentRespect CC (bug #243974), append to CFLAGS (but not -g), append to LDFLAGS, u... (diff)
downloadgentoo-2-d1a1a2a9ffe77afd46ffeb709a690e933f31e686.tar.gz
gentoo-2-d1a1a2a9ffe77afd46ffeb709a690e933f31e686.tar.bz2
gentoo-2-d1a1a2a9ffe77afd46ffeb709a690e933f31e686.zip
removed unnecessary rev bump.
(Portage version: 2.2_rc40/cvs/Linux i686)
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog7
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7-r1.ebuild61
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild3
3 files changed, 8 insertions, 63 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index 8023a28c13fb..6806f3d62393 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.42 2009/09/04 08:55:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.43 2009/09/04 13:34:47 williamh Exp $
+
+ 04 Sep 2009; William Hubbs <williamh@gentoo.org>
+ speech-dispatcher-0.6.7.ebuild, -speech-dispatcher-0.6.7-r1.ebuild:
+ Applied glibc patch to 0.6.7 and removed unnecessary revbump. This is a
+ build-time patch, so the rev bump was not needed.
*speech-dispatcher-0.6.7-r1 (04 Sep 2009)
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7-r1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7-r1.ebuild
deleted file mode 100644
index 600d9e2baba3..000000000000
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7-r1.ebuild,v 1.1 2009/09/04 08:55:08 ssuominen Exp $
-
-inherit eutils
-
-DESCRIPTION="speech-dispatcher speech synthesis interface"
-HOMEPAGE="http://www.freebsoft.org/speechd"
-SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE="alsa flite nas pulseaudio python"
-
-RDEPEND="dev-libs/dotconf
- >=dev-libs/glib-2
- alsa? ( media-libs/alsa-lib )
- flite? ( app-accessibility/flite )
- nas? ( media-libs/nas )
- pulseaudio? ( media-sound/pulseaudio )
- python? ( dev-lang/python )
- app-accessibility/espeak"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
- sed -i -e 's/\(SUBDIRS.*\)python/\1/' src/Makefile.in || die
-}
-
-src_compile() {
- econf \
- $(use_with alsa) \
- $(use_with flite) \
- $(use_with pulseaudio pulse) \
- $(use_with nas) || die "configure failed"
- make all || die "make failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die
-
- if use python; then
- cd "${S}"/src/python
- ./setup.py install --root="${D}" --no-compile
- cd "${S}"
- fi
-
- insinto /usr/include
- doins "${S}"/src/c/api/libspeechd.h
-
- dodoc AUTHORS ChangeLog NEWS TODO
- newinitd "${FILESDIR}"/speech-dispatcher speech-dispatcher
-}
-
-pkg_postinst() {
- elog "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
-}
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
index 6f286325a12a..45027809d4e2 100644
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild,v 1.3 2009/09/04 08:55:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.7.ebuild,v 1.4 2009/09/04 13:34:47 williamh Exp $
inherit eutils
@@ -27,6 +27,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
sed -i -e 's/\(SUBDIRS.*\)python/\1/' src/Makefile.in || die
}