summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-06-03 05:55:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-06-03 05:55:58 +0000
commitd416c582e9cbfc66c3fa7d5d85e6b6f791d9274f (patch)
tree5fbcf77f21ddf4e8c8c82fcd1a9a84a295fdf4f8
parentBump (diff)
downloadgentoo-2-d416c582e9cbfc66c3fa7d5d85e6b6f791d9274f.tar.gz
gentoo-2-d416c582e9cbfc66c3fa7d5d85e6b6f791d9274f.tar.bz2
gentoo-2-d416c582e9cbfc66c3fa7d5d85e6b6f791d9274f.zip
Bump
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-python/dulwich/ChangeLog7
-rw-r--r--dev-python/dulwich/dulwich-0.9.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/dulwich/ChangeLog b/dev-python/dulwich/ChangeLog
index 3999d19dd435..43053873e131 100644
--- a/dev-python/dulwich/ChangeLog
+++ b/dev-python/dulwich/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/dulwich
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.61 2013/05/13 08:49:04 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/ChangeLog,v 1.62 2013/06/03 05:55:58 patrick Exp $
+
+*dulwich-0.9.0 (03 Jun 2013)
+
+ 03 Jun 2013; Patrick Lauer <patrick@gentoo.org> +dulwich-0.9.0.ebuild:
+ Bump
13 May 2013; Dirkjan Ochtman <djc@gentoo.org> -dulwich-0.8.5.ebuild,
-dulwich-0.8.6.ebuild:
diff --git a/dev-python/dulwich/dulwich-0.9.0.ebuild b/dev-python/dulwich/dulwich-0.9.0.ebuild
new file mode 100644
index 000000000000..6075e0a9eb2a
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.9.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/dulwich/dulwich-0.9.0.ebuild,v 1.1 2013/06/03 05:55:58 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Dulwich is a pure-Python implementation of the Git file formats and protocols."
+HOMEPAGE="http://samba.org/~jelmer/dulwich/ http://pypi.python.org/pypi/dulwich"
+SRC_URI="http://samba.org/~jelmer/dulwich/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-python/setuptools
+ test? ( virtual/python-unittest2 )"
+RDEPEND=""
+
+src_prepare() {
+ distutils_src_prepare
+ sed -e "s/test_fetch_from_dulwich(/_&/" -i dulwich/tests/compat/server_utils.py
+}
+
+distutils_src_test_pre_hook() {
+ local module
+ for module in _diff_tree _objects _pack; do
+ ln -fs "../$(ls -d build-${PYTHON_ABI}/lib.*)/dulwich/${module}.so" "dulwich/${module}.so" || die "Symlinking dulwich/${module}.so failed with $(python_get_implementation_and_version)"
+ done
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/dulwich/tests"
+ }
+ python_execute_function -q delete_tests
+}