summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAhmed Ammar <b33fc0d3@gentoo.org>2008-09-24 12:49:32 +0000
committerAhmed Ammar <b33fc0d3@gentoo.org>2008-09-24 12:49:32 +0000
commitd4197c68cf8548d36f4954fac3d425b59370dde0 (patch)
tree1d6451032f3b4032eea997aa2d74acef2011a5a4
parentRevert --without-arts, bug #235872. (diff)
downloadgentoo-2-d4197c68cf8548d36f4954fac3d425b59370dde0.tar.gz
gentoo-2-d4197c68cf8548d36f4954fac3d425b59370dde0.tar.bz2
gentoo-2-d4197c68cf8548d36f4954fac3d425b59370dde0.zip
Fixed threads support. Trivial patch for build process.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.3-rt7 i686)
-rw-r--r--dev-libs/dmalloc/ChangeLog6
-rw-r--r--dev-libs/dmalloc/dmalloc-5.5.2-r1.ebuild50
-rw-r--r--dev-libs/dmalloc/dmalloc-5.5.2-r2.ebuild17
-rw-r--r--dev-libs/dmalloc/files/dmalloc-5.5.2-threads.patch11
-rw-r--r--dev-libs/dmalloc/metadata.xml2
5 files changed, 28 insertions, 58 deletions
diff --git a/dev-libs/dmalloc/ChangeLog b/dev-libs/dmalloc/ChangeLog
index 5c64e6930704..f91667e11909 100644
--- a/dev-libs/dmalloc/ChangeLog
+++ b/dev-libs/dmalloc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/dmalloc
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/ChangeLog,v 1.40 2008/01/19 20:18:36 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/ChangeLog,v 1.41 2008/09/24 12:49:31 b33fc0d3 Exp $
+
+ 24 Sep 2008; <b33fc0d3@gentoo.org> +files/dmalloc-5.5.2-threads.patch,
+ metadata.xml, -dmalloc-5.5.2-r1.ebuild, dmalloc-5.5.2-r2.ebuild:
+ Fixed threads support. Removed older revision.
*dmalloc-5.5.2-r2 (19 Jan 2008)
diff --git a/dev-libs/dmalloc/dmalloc-5.5.2-r1.ebuild b/dev-libs/dmalloc/dmalloc-5.5.2-r1.ebuild
deleted file mode 100644
index 65339e3300ef..000000000000
--- a/dev-libs/dmalloc/dmalloc-5.5.2-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.5.2-r1.ebuild,v 1.5 2007/12/29 17:22:33 armin76 Exp $
-
-inherit autotools eutils
-
-DESCRIPTION="A Debug Malloc Library"
-HOMEPAGE="http://dmalloc.com"
-SRC_URI="http://dmalloc.com/releases/${P}.tgz"
-
-LICENSE="CCPL-Attribution-ShareAlike-3.0"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # - Build objects twice, once -fPIC for shared.
- # - Use DESTDIR.
- # - Fix SONAME and NEEDED.
- epatch "${FILESDIR}"/${P}-Makefile.in.patch
- # - Broken test, always returns false.
- epatch "${FILESDIR}"/${P}-cxx.patch
- # - Run autoconf for -cxx.patch.
- eautoconf
-}
-
-src_compile() {
- econf --enable-cxx --enable-threads --enable-shlib
- emake || die "emake failed."
- cd docs && makeinfo dmalloc.texi
-}
-
-src_test() {
- emake heavy || die "emake check failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
-
- newdoc ChangeLog.1 ChangeLog
- dodoc NEWS README docs/NOTES docs/TODO
- insinto /usr/share/doc/${PF}
- doins docs/dmalloc.pdf
- dohtml RELEASE.html docs/dmalloc.html
- doinfo docs/dmalloc.info
-}
diff --git a/dev-libs/dmalloc/dmalloc-5.5.2-r2.ebuild b/dev-libs/dmalloc/dmalloc-5.5.2-r2.ebuild
index 14385d26ef6c..f84b163de88c 100644
--- a/dev-libs/dmalloc/dmalloc-5.5.2-r2.ebuild
+++ b/dev-libs/dmalloc/dmalloc-5.5.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.5.2-r2.ebuild,v 1.1 2008/01/19 20:18:36 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.5.2-r2.ebuild,v 1.2 2008/09/24 12:49:31 b33fc0d3 Exp $
inherit autotools eutils multilib
@@ -11,7 +11,7 @@ SRC_URI="http://dmalloc.com/releases/${P}.tgz"
LICENSE="CCPL-Attribution-ShareAlike-3.0"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
-IUSE=""
+IUSE="threads"
DEPEND=""
@@ -24,22 +24,27 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-Makefile.in.patch
# - Broken test, always returns false.
epatch "${FILESDIR}"/${P}-cxx.patch
+ # - Add threads support.
+ use threads && epatch "${FILESDIR}"/${P}-threads.patch
# - Run autoconf for -cxx.patch.
eautoconf
}
src_compile() {
- econf --enable-cxx --enable-threads --enable-shlib
- emake || die "emake failed."
+ econf --enable-cxx \
+ --enable-shlib \
+ $(use_enable threads) || die "econf failed!"
+
+ emake || die "emake failed!"
cd docs && makeinfo dmalloc.texi
}
src_test() {
- emake heavy || die "emake check failed."
+ emake heavy || die "emake check failed!"
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die "emake install failed!"
newdoc ChangeLog.1 ChangeLog
dodoc NEWS README docs/NOTES docs/TODO
diff --git a/dev-libs/dmalloc/files/dmalloc-5.5.2-threads.patch b/dev-libs/dmalloc/files/dmalloc-5.5.2-threads.patch
new file mode 100644
index 000000000000..4016be0a21c0
--- /dev/null
+++ b/dev-libs/dmalloc/files/dmalloc-5.5.2-threads.patch
@@ -0,0 +1,11 @@
+--- ./dmalloc-5.5.2/settings.dist.orig 2008-09-23 09:24:56.000000000 +0200
++++ ./dmalloc-5.5.2/settings.dist 2008-09-23 09:25:27.000000000 +0200
+@@ -409,7 +409,7 @@
+ */
+
+ #ifndef LOCK_THREADS
+-#define LOCK_THREADS 0
++#define LOCK_THREADS 1
+ #endif
+
+ #if LOCK_THREADS
diff --git a/dev-libs/dmalloc/metadata.xml b/dev-libs/dmalloc/metadata.xml
index 9f3fdee2246b..6e86a06946c8 100644
--- a/dev-libs/dmalloc/metadata.xml
+++ b/dev-libs/dmalloc/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>maintainer-needed@gentoo.org</email>
+ <email>b33fc0d3@gentoo.org</email>
</maintainer>
</pkgmetadata>