summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-05 13:34:34 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-05 13:34:34 +0000
commitdc75f04d9953f5d33c94b6df00599aef08088c9a (patch)
tree0e3ae7a5758c1452e1d5d9c8d30e56e4e5a2d5f7
parentUpdated patch by David E. Narváez <david.narvaez@computer.org> wrt bug #458402. (diff)
downloadgentoo-2-dc75f04d9953f5d33c94b6df00599aef08088c9a.tar.gz
gentoo-2-dc75f04d9953f5d33c94b6df00599aef08088c9a.tar.bz2
gentoo-2-dc75f04d9953f5d33c94b6df00599aef08088c9a.zip
Introduce a new version that handles boost dependency properly; replace dependency on virtual with its own dependency (and as a build-time dependency only). Move maintainership to net-dialup since this is only used by net-dialup/wvdial.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
-rw-r--r--net-libs/wvstreams/ChangeLog14
-rw-r--r--net-libs/wvstreams/metadata.xml17
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild8
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild (renamed from net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild)67
4 files changed, 66 insertions, 40 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index 5dc5a6a0fbf7..e754eb5582b0 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-libs/wvstreams
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.150 2012/08/08 19:41:04 ranger Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.151 2013/03/05 13:34:34 flameeyes Exp $
+
+*wvstreams-4.6.1-r3 (05 Mar 2013)
+
+ 05 Mar 2013; Diego E. Pettenò <flameeyes@gentoo.org>
+ +wvstreams-4.6.1-r3.ebuild, -wvstreams-4.6.1-r1.ebuild, metadata.xml,
+ wvstreams-4.6.1-r2.ebuild:
+ Introduce a new version that handles boost dependency properly; replace
+ dependency on virtual with its own dependency (and as a build-time dependency
+ only). Move maintainership to net-dialup since this is only used by net-
+ dialup/wvdial.
08 Aug 2012; Brent Baude <ranger@gentoo.org> wvstreams-4.6.1-r2.ebuild:
Marking wvstreams-4.6.1-r2 ppc for bug 421983
diff --git a/net-libs/wvstreams/metadata.xml b/net-libs/wvstreams/metadata.xml
index 3a413e91a53d..4fd26ae6812a 100644
--- a/net-libs/wvstreams/metadata.xml
+++ b/net-libs/wvstreams/metadata.xml
@@ -1,9 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>cpp</herd>
- <longdescription>A network programming library in C++</longdescription>
- <upstream>
- <remote-id type="google-code">wvstreams</remote-id>
- </upstream>
+ <herd>net-dialup</herd>
+ <upstream>
+ <remote-id type="google-code">wvstreams</remote-id>
+ </upstream>
+ <use>
+ <flag name="boost">
+ Use <pkg>dev-libs/boost</pkg> to provide TR1-compatible
+ functional interface. This USE flag is only needed with GCC
+ earlier than version 4.1, or with other compilares not providing
+ said interface.
+ </flag>
+ </use>
</pkgmetadata>
diff --git a/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild b/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild
index 79a49060c72d..9ce49626e2d2 100644
--- a/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild,v 1.8 2012/08/08 19:41:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild,v 1.9 2013/03/05 13:34:34 flameeyes Exp $
EAPI=4
inherit autotools eutils flag-o-matic toolchain-funcs versionator
@@ -25,9 +25,9 @@ RDEPEND="sys-libs/readline
sys-libs/zlib
dbus? ( >=sys-apps/dbus-1.4.20 )
dev-libs/openssl:0
- pam? ( sys-libs/pam )
- virtual/c++-tr1-functional"
+ pam? ( sys-libs/pam )"
DEPEND="${RDEPEND}
+ || ( >=sys-devel/gcc-4.1 >=dev-libs/boost-1.34.0 )
virtual/pkgconfig
doc? ( app-doc/doxygen )"
diff --git a/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild b/net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild
index 98887a3f3b81..9d83ab2a4bc4 100644
--- a/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild,v 1.9 2012/06/06 20:33:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.6.1-r3.ebuild,v 1.1 2013/03/05 13:34:34 flameeyes Exp $
-EAPI=2
-inherit autotools eutils toolchain-funcs versionator
+EAPI=5
+inherit autotools eutils flag-o-matic toolchain-funcs versionator
DESCRIPTION="A network programming library in C++"
HOMEPAGE="http://alumnit.ca/wiki/?WvStreams"
@@ -11,8 +11,8 @@ SRC_URI="http://wvstreams.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ppc sparc x86"
-IUSE="pam doc +ssl +dbus debug"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="pam doc +ssl +dbus debug boost"
#Tests fail if openssl is not compiled with -DPURIFY. Gentoo's isn't. FAIL!
RESTRICT="test"
@@ -23,39 +23,49 @@ RESTRICT="test"
RDEPEND="sys-libs/readline
sys-libs/zlib
- dbus? ( >=sys-apps/dbus-1.2.14 )
- dev-libs/openssl
- pam? ( sys-libs/pam )
- virtual/c++-tr1-functional"
+ dbus? ( >=sys-apps/dbus-1.4.20 )
+ dev-libs/openssl:0
+ pam? ( virtual/pam )"
DEPEND="${RDEPEND}
virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-pkg_setup() {
- if has_version '>=sys-devel/gcc-4.1' && ! has_version '>=dev-libs/boost-1.34.1'
- then
- if ! version_is_at_least 4.1 "$(gcc-fullversion)"
- then
- eerror "This package requires the active gcc to be at least version 4.1"
- eerror "or >=dev-libs/boost-1.34.1 must be installed."
- die "Please activate >=sys-devel/gcc-4.1 with gcc-config."
- fi
+ doc? ( app-doc/doxygen )
+ boost? ( >=dev-libs/boost-1.34.1:= )"
+
+DOCS="ChangeLog README*"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} == "binary" ]] && return
+
+ if ! use boost && ! version_is_at_least 4.1 "$(gcc-fullversion)"; then
+ eerror "This package requires the active gcc to be at least version 4.1"
+ eerror "or USE=boost must be installed."
+ die "Please activate >=sys-devel/gcc-4.1 with gcc-config."
fi
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-parallel-make.patch \
+ epatch \
+ "${FILESDIR}"/${P}-parallel-make.patch \
"${FILESDIR}"/${P}-openssl-1.0.0.patch \
- "${FILESDIR}"/${P}-glibc212.patch
+ "${FILESDIR}"/${P}-glibc212.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
eautoreconf
- cd argp
+ pushd argp >/dev/null
eautoreconf
+ popd >/dev/null
}
src_configure() {
- export CXX="$(tc-getCXX)"
+ append-flags -fno-strict-aliasing
+ append-flags -fno-tree-dce -fno-optimize-sibling-calls #421375
+
+ tc-export CXX
+
+ use boost && export ac_cv_header_tr1_functional=no
econf \
+ --localstatedir=/var \
$(use_enable debug) \
--disable-optimization \
$(use_with dbus) \
@@ -68,7 +78,7 @@ src_configure() {
}
src_compile() {
- emake || die
+ default
if use doc; then
doxygen || die
@@ -76,12 +86,11 @@ src_compile() {
}
src_test() {
- emake test || die
+ emake test
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog README*
+ default
if use doc; then
#the list of files is too big for dohtml -r Docs/doxy-html/*