summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-01-27 10:41:17 +0000
committerMatthias Maier <tamiko@gentoo.org>2015-01-27 10:41:17 +0000
commite33a61f84b9b45fbeb070fa169ea4c46dace394a (patch)
tree9f070dccab43a33bbd593cd6e0479fa0bb684e26
parentOld. (diff)
downloadgentoo-2-e33a61f84b9b45fbeb070fa169ea4c46dace394a.tar.gz
gentoo-2-e33a61f84b9b45fbeb070fa169ea4c46dace394a.tar.bz2
gentoo-2-e33a61f84b9b45fbeb070fa169ea4c46dace394a.zip
version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BD3A97A3)
-rw-r--r--dev-python/libvirt-python/ChangeLog9
-rw-r--r--dev-python/libvirt-python/libvirt-python-1.2.12.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-python/libvirt-python/ChangeLog b/dev-python/libvirt-python/ChangeLog
index 427760cb2330..a29aadb46dc6 100644
--- a/dev-python/libvirt-python/ChangeLog
+++ b/dev-python/libvirt-python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/libvirt-python
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/ChangeLog,v 1.28 2014/12/24 15:09:19 tamiko Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/ChangeLog,v 1.29 2015/01/27 10:41:17 tamiko Exp $
+
+*libvirt-python-1.2.12 (27 Jan 2015)
+
+ 27 Jan 2015; Matthias Maier <tamiko@gentoo.org> +libvirt-python-1.2.12.ebuild:
+ version bump
24 Dec 2014; Matthias Maier <tamiko@gentoo.org> -libvirt-python-1.2.9.ebuild:
drop old
diff --git a/dev-python/libvirt-python/libvirt-python-1.2.12.ebuild b/dev-python/libvirt-python/libvirt-python-1.2.12.ebuild
new file mode 100644
index 000000000000..533af9c590c8
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-1.2.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/libvirt-python/libvirt-python-1.2.12.ebuild,v 1.1 2015/01/27 10:41:17 tamiko Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+inherit eutils distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# testsuite is currently not included in upstream tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}