summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-01-12 14:51:30 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-01-12 14:51:30 +0000
commite490cc818b42d6f3fffba727376c80a77e1df691 (patch)
tree5202b41dd448f1db6ffec90a9ffa8fe6d1d9aa93
parentVersion bump (diff)
downloadgentoo-2-e490cc818b42d6f3fffba727376c80a77e1df691.tar.gz
gentoo-2-e490cc818b42d6f3fffba727376c80a77e1df691.tar.bz2
gentoo-2-e490cc818b42d6f3fffba727376c80a77e1df691.zip
Version bump redis to 2.6.8 (bug 451378).
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
-rw-r--r--dev-db/redis/ChangeLog9
-rw-r--r--dev-db/redis/redis-2.6.8.ebuild92
2 files changed, 99 insertions, 2 deletions
diff --git a/dev-db/redis/ChangeLog b/dev-db/redis/ChangeLog
index cb26c153a5b0..693f18697e8a 100644
--- a/dev-db/redis/ChangeLog
+++ b/dev-db/redis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/redis
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.55 2012/12/26 11:15:46 djc Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/ChangeLog,v 1.56 2013/01/12 14:51:30 djc Exp $
+
+*redis-2.6.8 (12 Jan 2013)
+
+ 12 Jan 2013; Dirkjan Ochtman <djc@gentoo.org> +redis-2.6.8.ebuild:
+ Version bump to 2.6.8 (bug 451378).
*redis-2.6.7 (26 Dec 2012)
diff --git a/dev-db/redis/redis-2.6.8.ebuild b/dev-db/redis/redis-2.6.8.ebuild
new file mode 100644
index 000000000000..b91e65b21ce7
--- /dev/null
+++ b/dev-db/redis/redis-2.6.8.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/redis/redis-2.6.8.ebuild,v 1.1 2013/01/12 14:51:30 djc Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic user
+
+DESCRIPTION="A persistent caching system, key-value and data structures database."
+HOMEPAGE="http://redis.io/"
+SRC_URI="http://redis.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~x86-macos ~x86-solaris"
+IUSE="+jemalloc tcmalloc test"
+SLOT="0"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ jemalloc? ( >=dev-libs/jemalloc-3.2 )"
+DEPEND=">=sys-devel/autoconf-2.63
+ test? ( dev-lang/tcl )
+ ${RDEPEND}"
+REQUIRED_USE="tcmalloc? ( !jemalloc )
+ jemalloc? ( !tcmalloc )"
+
+S="${WORKDIR}/${PN}-${PV/_/-}"
+
+pkg_setup() {
+ enewgroup redis 75
+ enewuser redis 75 -1 /var/lib/redis redis
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}"-2.6.7-{shared,config}.patch
+ # now we will rewrite present Makefiles
+ local makefiles=""
+ for MKF in $(find -name 'Makefile' | cut -b 3-); do
+ mv "${MKF}" "${MKF}.in"
+ sed -i -e 's:$(CC):@CC@:g' \
+ -e 's:$(CFLAGS):@AM_CFLAGS@:g' \
+ -e 's: $(DEBUG)::g' \
+ -e 's:$(OBJARCH)::g' \
+ -e 's:ARCH:TARCH:g' \
+ -e '/^CCOPT=/s:$: $(LDFLAGS):g' \
+ "${MKF}.in" \
+ || die "Sed failed for ${MKF}"
+ makefiles+=" ${MKF}"
+ done
+ # autodetection of compiler and settings; generates the modified Makefiles
+ cp "${FILESDIR}"/configure.ac-2.2 configure.ac
+ sed -i -e "s:AC_CONFIG_FILES(\[Makefile\]):AC_CONFIG_FILES([${makefiles}]):g" \
+ configure.ac || die "Sed failed for configure.ac"
+ eautoconf
+}
+
+src_compile() {
+ local myconf=""
+
+ if use tcmalloc ; then
+ myconf="${myconf} USE_TCMALLOC=yes"
+ elif use jemalloc ; then
+ myconf="${myconf} JEMALLOC_SHARED=yes"
+ else
+ myconf="${myconf} MALLOC=yes"
+ fi
+
+ emake ${myconf}
+}
+
+src_install() {
+ insinto /etc/
+ doins redis.conf sentinel.conf
+ use prefix || fowners redis:redis /etc/{redis,sentinel}.conf
+ fperms 0644 /etc/{redis,sentinel}.conf
+
+ newconfd "${FILESDIR}/redis.confd" redis
+ newinitd "${FILESDIR}/redis.initd" redis
+
+ nonfatal dodoc 00-RELEASENOTES BUGS CONTRIBUTING MANIFESTO README
+
+ dobin src/redis-cli
+ dosbin src/redis-benchmark src/redis-server src/redis-check-aof src/redis-check-dump
+ fperms 0750 /usr/sbin/redis-benchmark
+ dosym /usr/sbin/redis-server /usr/sbin/redis-sentinel
+
+ if use prefix; then
+ diropts -m0750
+ else
+ diropts -m0750 -o redis -g redis
+ fi
+ keepdir /var/{log,lib}/redis
+}