summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2003-09-29 22:19:06 +0000
committerRobert Coie <rac@gentoo.org>2003-09-29 22:19:06 +0000
commite7985f90fe847c05cf47e960deb71bd72cf4e799 (patch)
treec1d359d4594e8bbe94f25937912ebd574ab42bd4
parent5.8.1-r1, change destdir handling (diff)
downloadgentoo-2-e7985f90fe847c05cf47e960deb71bd72cf4e799.tar.gz
gentoo-2-e7985f90fe847c05cf47e960deb71bd72cf4e799.tar.bz2
gentoo-2-e7985f90fe847c05cf47e960deb71bd72cf4e799.zip
5.8.1-r1, change destdir handling
-rw-r--r--dev-lang/perl/ChangeLog7
-rw-r--r--dev-lang/perl/Manifest5
-rw-r--r--dev-lang/perl/files/digest-perl-5.8.1-r11
-rw-r--r--dev-lang/perl/perl-5.8.1-r1.ebuild296
4 files changed, 305 insertions, 4 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index e65ce50cad25..562c3fe12dc2 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/perl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.37 2003/09/27 23:16:37 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.38 2003/09/29 22:19:04 rac Exp $
+
+*perl-5.8.1-r1 (29 Sep 2003)
+
+ 29 Sep 2003; <rac@gentoo.org> perl-5.8.1-r1.ebuild:
+ Change destdir handling in a couple of places
*perl-5.8.1 (27 Sep 2003)
diff --git a/dev-lang/perl/Manifest b/dev-lang/perl/Manifest
index 379a92e698a2..c23977f7d338 100644
--- a/dev-lang/perl/Manifest
+++ b/dev-lang/perl/Manifest
@@ -1,7 +1,6 @@
-MD5 7eff7397793b17d81d6681e4532152e6 perl-5.8.1-r1.ebuild~ 9750
MD5 5e2ced5e0d331faea9122a21c49957b0 perl-5.6.1-r12.ebuild 7089
MD5 d45968fa52ba2a4b1fd3b54d0be0f9a9 perl-5.8.1_rc1.ebuild 10455
-MD5 b418b08938365360cd53474ae0cacc28 perl-5.8.1-r1.ebuild 8754
+MD5 d26bc7eb5e1baa52c15368a7d80d6cc9 perl-5.8.1-r1.ebuild 8698
MD5 51da78b2203cbf4e81dafb6e24dd2e22 perl-5.8.0-r10.ebuild 14009
MD5 907c3574f85470b1f2148180f7321f20 perl-5.8.0-r9.ebuild 13534
MD5 69e9d22842c4ef144b83b1efc487949b perl-5.8.1_rc3.ebuild 10458
@@ -9,7 +8,7 @@ MD5 7eff7397793b17d81d6681e4532152e6 perl-5.8.1.ebuild 9750
MD5 220bd838139aaf17ec8f8f6cc1a37c61 perl-5.8.0-r12.ebuild 10316
MD5 33226bb561cd0f81cc4f7756c0f7f4c5 perl-5.6.1-r11.ebuild 6141
MD5 aa2447b410ec708d954d6049da67e5fa perl-5.8.1_rc2.ebuild 10458
-MD5 75020a7523c463a0ac9431926b3a55a7 ChangeLog 19017
+MD5 6d5b53cdb8bb0474218b696fde92cb60 ChangeLog 19150
MD5 31f5ae7d2343aa4819b892820b0ccaf7 perl-5.8.0-r11.ebuild 9890
MD5 0339818063f904e5a6ebe6b16b4d819f perl-5.6.1-r10.ebuild 6666
MD5 14cea63702f7654ee5ea0ab212a23004 perl-5.8.1_rc4.ebuild 10458
diff --git a/dev-lang/perl/files/digest-perl-5.8.1-r1 b/dev-lang/perl/files/digest-perl-5.8.1-r1
new file mode 100644
index 000000000000..d6b20a4562d1
--- /dev/null
+++ b/dev-lang/perl/files/digest-perl-5.8.1-r1
@@ -0,0 +1 @@
+MD5 87cf132f1fbf23e780f0b218046438a6 perl-5.8.1.tar.gz 11857808
diff --git a/dev-lang/perl/perl-5.8.1-r1.ebuild b/dev-lang/perl/perl-5.8.1-r1.ebuild
new file mode 100644
index 000000000000..9a4f974c3f4e
--- /dev/null
+++ b/dev-lang/perl/perl-5.8.1-r1.ebuild
@@ -0,0 +1,296 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.1-r1.ebuild,v 1.1 2003/09/29 22:19:04 rac Exp $
+
+inherit eutils flag-o-matic
+
+# Perl has problems compiling with -Os in your flags
+replace-flags "-Os" "-O2"
+# This flag makes compiling crash in interesting ways
+filter-flags -malign-double
+
+# The slot of this binary compat version of libperl.so
+PERLSLOT="1"
+
+SHORT_PV="`echo ${PV} | cut -d. -f1,2`"
+DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
+SAFE_VERSION="2.09"
+MY_P="perl-`echo $PV | sed 's/_rc/-RC/'`"
+S="${WORKDIR}/${MY_P}"
+SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${MY_P}.tar.gz"
+#ftp://ftp.perl.org/pub/CPAN/modules/by-module/DB_File/DB_File-${DB_FILE_VERSION}.tar.gz
+#ftp://ftp.perl.org/pub/CPAN/modules/by-module/Safe/Safe-${SAFE_VERSION}.tar.gz"
+HOMEPAGE="http://www.perl.org/"
+SLOT="0"
+LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
+LICENSE="Artistic GPL-2"
+KEYWORDS="~x86 ~amd64 ~sparc ~ppc ~alpha ~mips ~hppa ~ia64"
+IUSE="berkdb doc gdbm threads"
+
+DEPEND="sys-apps/groff
+ berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ >=sys-apps/portage-2.0.48-r4
+ =sys-devel/libperl-${SHORT_PV}*
+ !<dev-perl/ExtUtils-MakeMaker-6.05-r6
+ !<dev-perl/File-Spec-0.84-r1
+ !<dev-perl/Test-Simple-0.47-r1"
+RDEPEND="berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+pkg_setup() {
+ # I think this should rather be displayed if you *have* 'threads'
+ # in USE if it could break things ...
+ if [ -n "`use threads`" ]
+ then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ ewarn ""
+ sleep 10
+ else
+ ewarn ""
+ ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
+ ewarn "threading enabled , you must restart this emerge"
+ ewarn "with USE=threads emerge...."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ ewarn ""
+ fi
+
+ if [ ! -f /usr/lib/${LIBPERL} ]
+ then
+ # Make sure we have libperl installed ...
+ eerror "Cannot find /usr/lib/${LIBPERL}! Make sure that you"
+ eerror "have sys-libs/libperl installed properly ..."
+ die "Cannot find /usr/lib/${LIBPERL}!"
+ fi
+}
+
+src_unpack() {
+
+ unpack ${A}
+
+ # Patch perldoc to not abort when it attempts to search
+ # nonexistent directories; fixes bug #16589.
+ # <rac@gentoo.org> (28 Feb 2003)
+
+ # we are using the vendor directory now, so it should not be
+ # empty. this patch doesn't come close to applying, so leaving
+ # off for now.
+ # <rac@gentoo.org> (10 Jul 2003)
+
+ #cd ${S}; epatch ${FILESDIR}/${P}-perldoc-emptydirs.patch
+
+ # this lays the groundwork for solving the issue of what happens
+ # when people (or ebuilds) install different versiosn of modules
+ # that are in the core, by rearranging the @INC directory to look
+ # site -> vendor -> core.
+ cd ${S}; epatch ${FILESDIR}/${P}-reorder-INC.patch
+}
+
+src_compile() {
+
+ export LC_ALL="C"
+ local myconf=""
+
+ if [ "`use threads`" ]
+ then
+ einfo "using threads"
+ mythreading="-multi"
+ myconf="-Dusethreads ${myconf}"
+ myarch="${CHOST%%-*}-linux-thread"
+ else
+ myarch="${CHOST%%-*}-linux"
+ fi
+
+ if [ "`use gdbm`" ]
+ then
+ myconf="${myconf} -Di_gdbm"
+ fi
+ if [ "`use berkdb`" ]
+ then
+ myconf="${myconf} -Di_db -Di_ndbm"
+ else
+ myconf="${myconf} -Ui_db -Ui_ndbm"
+ fi
+ if [ "`use mips`" ]
+ then
+ # this is needed because gcc 3.3-compiled kernels will hang
+ # the machine trying to run this test - check with `Kumba
+ # <rac@gentoo.org> 2003.06.26
+ myconf="${myconf} -Dd_u32align"
+ fi
+ if [ "`use sparc`" ]
+ then
+ myconf="${myconf} -Ud_longdbl"
+ fi
+ if [ "`use sparc64`" ]
+ then
+ myconf="${myconf} -Ud_longdbl"
+ fi
+
+ if [ "`use alpha`" -a "${CC}" == "ccc" ]
+ then
+ ewarn "Perl will not be built with berkdb support, use gcc if you needed it..."
+ myconf="${myconf} -Ui_db -Ui_ndbm"
+ fi
+
+ [ "${ARCH}" = "hppa" ] && append-flags -fPIC
+
+ sh Configure -des \
+ -Darchname="${myarch}" \
+ -Dcc="${CC:-gcc}" \
+ -Dprefix='/usr' \
+ -Dvendorprefix='/usr' \
+ -Dsiteprefix='/usr' \
+ -Dlocincpth=' ' \
+ -Doptimize="${CFLAGS}" \
+ -Duselargefiles \
+ -Dd_dosuid \
+ -Dd_semctl_semun \
+ -Dscriptdir=/usr/bin \
+ -Dman3ext='3pm' \
+ -Dcf_by='Gentoo' \
+ -Ud_csh \
+ ${myconf} || die "Unable to configure"
+
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die "Unable to make"
+
+ emake -i test CCDLFLAGS=
+}
+
+src_install() {
+
+ export LC_ALL="C"
+
+ # Need to do this, else apps do not link to dynamic version of
+ # the library ...
+ local coredir="/usr/lib/perl5/${PV}/${myarch}${mythreading}/CORE"
+ dodir ${coredir}
+ dosym ../../../../${LIBPERL} ${coredir}/${LIBPERL}
+ dosym ../../../../${LIBPERL} ${coredir}/libperl.so.${PERLSLOT}
+ dosym ../../../../${LIBPERL} ${coredir}/libperl.so
+
+ # Fix for "stupid" modules and programs
+ dodir /usr/lib/perl5/site_perl/${PV}/${myarch}${mythreading}
+
+ make DESTDIR="${D}" \
+ INSTALLMAN1DIR="${D}/usr/share/man/man1" \
+ INSTALLMAN3DIR="${D}/usr/share/man/man3" \
+ install || die "Unable to make install"
+
+ cp -f utils/h2ph utils/h2ph_patched
+ epatch ${FILESDIR}/perl-5.8.0-RC2-special-h2ph-not-failing-on-machine_ansi_header.patch
+
+ LD_LIBRARY_PATH=. ./perl -Ilib utils/h2ph_patched \
+ -a -d ${D}/usr/lib/perl5/${PV}/${myarch}${mythreading} <<EOF
+asm/termios.h
+syscall.h
+syslimits.h
+syslog.h
+sys/ioctl.h
+sys/socket.h
+sys/time.h
+wait.h
+EOF
+
+ # This is to fix a missing c flag for backwards compat
+ for i in `find ${D}/usr/lib/perl5 -iname "Config.pm"`;do
+ sed -e "s:ccflags=':ccflags='-DPERL5 :" \
+ -e "s:cppflags=':cppflags='-DPERL5 :" \
+ ${i} > ${i}.new &&\
+ mv ${i}.new ${i} || die "Sed failed"
+ done
+
+ # A poor fix for the miniperl issues
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/lib/perl5/${PV}/ExtUtils/xsubpp
+ fperms 0444 /usr/lib/perl5/${PV}/ExtUtils/xsubpp
+ dosed 's:./miniperl:/usr/bin/perl:' /usr/bin/xsubpp
+ fperms 0755 /usr/bin/xsubpp
+
+ ./perl installman \
+ --destdir="${D}" --man1ext='1' --man3ext='3'
+
+ # This removes ${D} from Config.pm and .packlist
+ for i in `find ${D} -iname "Config.pm"` `find ${D} -iname ".packlist"`;do
+ einfo "Removing ${D} from ${i}..."
+ sed -e "s:${D}::" ${i} > ${i}.new &&\
+ mv ${i}.new ${i} || die "Sed failed"
+ done
+
+ dodoc Changes* Artistic Copying README Todo* AUTHORS
+
+ if [ -n "`use doc`" ]
+ then
+ # HTML Documentation
+ # We expect errors, warnings, and such with the following.
+
+ dodir /usr/share/doc/${PF}/html
+ ./perl installhtml \
+ --podroot='.' \
+ --podpath='lib:ext:pod:vms' \
+ --recurse \
+ --htmldir="${D}/usr/share/doc/${PF}/html" \
+ --libpods='perlfunc:perlguts:perlvar:perlrun:perlop'
+ fi
+}
+
+pkg_postinst() {
+
+ # Make sure we do not have stale/invalid libperl.so 's ...
+ if [ -f "${ROOT}usr/lib/libperl.so" -a ! -L "${ROOT}usr/lib/libperl.so" ]
+ then
+ mv -f ${ROOT}usr/lib/libperl.so ${ROOT}usr/lib/libperl.so.old
+ fi
+
+ local perllib="`readlink -f ${ROOT}usr/lib/libperl.so | sed -e 's:^.*/::'`"
+
+ # If we are installing perl, we need the /usr/lib/libperl.so symlink to
+ # point to the version of perl we are running, else builing something
+ # against libperl.so will break ...
+ if [ "${perllib}" != "${LIBPERL}" ]
+ then
+ # Delete stale symlinks
+ rm -f ${ROOT}usr/lib/libperl.so
+ rm -f ${ROOT}usr/lib/libperl.so.${PERLSLOT}
+ # Regenerate libperl.so.${PERLSLOT}
+ ln -snf ${LIBPERL} ${ROOT}usr/lib/libperl.so.${PERLSLOT}
+ # Create libperl.so (we use the *soname* versioned lib here ..)
+ ln -snf libperl.so.${PERLSLOT} ${ROOT}usr/lib/libperl.so
+ fi
+
+ if [ "${ROOT}" = "/" ]
+ then
+ ebegin "Converting C header files to the corresponding Perl format"
+ cd /usr/include; h2ph -r -l .
+ fi
+
+ eerror ""
+ eerror "If this is an upgrade to a perl 5.6.1 system,"
+ eerror "~OR~ an upgrade to a previous Gentoo release"
+ eerror "of perl 5.8.0, prior to -r8 "
+ eerror "you may need to recompile applications that"
+ eerror "were emerged against the old libperl.so"
+ eerror ""
+ eerror "${FILESDIR}/libperl_rebuilder "
+ eerror "is provided to assist with this. "
+ eerror "PLEASE DO NOT INTERRUPT THE RUNNING OF THIS SCRIPT."
+ eerror "Part of the rebuilding of applications compiled against "
+ eerror "your old libperl involves temporarily unmerging"
+ eerror "them - interruptions could leave you with unmerged"
+ eerror "packages before they can be remerged."
+ eerror ""
+ eerror "If you have run the rebuilder and a package still gives"
+ eerror "you trouble, and re-emerging it fails to correct"
+ eerror "the problem, please check http://bugs.gentoo.org/"
+ eerror "for more information or to report a bug."
+ eerror ""
+ eerror ""
+}
+
+