summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-08-13 19:37:36 +0000
committerRoy Marples <uberlord@gentoo.org>2006-08-13 19:37:36 +0000
commiteb06a23fc6b595afa898cb215a294a7e144e1596 (patch)
treeec49de685152aa217c33aa991885675e3f27dba7
parent Ensure that interface is always up as future dhcpcd's will do this (diff)
downloadgentoo-2-eb06a23fc6b595afa898cb215a294a7e144e1596.tar.gz
gentoo-2-eb06a23fc6b595afa898cb215a294a7e144e1596.tar.bz2
gentoo-2-eb06a23fc6b595afa898cb215a294a7e144e1596.zip
Bump to push out patch.
(Portage version: 2.1.1_pre4-r4)
-rw-r--r--net-misc/dhcpcd/ChangeLog9
-rw-r--r--net-misc/dhcpcd/dhcpcd-2.0.5-r1.ebuild54
-rw-r--r--net-misc/dhcpcd/dhcpcd-2.0.8-r3.ebuild55
-rw-r--r--net-misc/dhcpcd/files/digest-dhcpcd-2.0.5-r13
-rw-r--r--net-misc/dhcpcd/files/digest-dhcpcd-2.0.8-r33
5 files changed, 123 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index f40e71c1f43d..5b1dfc6d1b94 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.104 2006/08/13 19:33:47 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.105 2006/08/13 19:37:36 uberlord Exp $
+
+*dhcpcd-2.0.8-r3 (13 Aug 2006)
+*dhcpcd-2.0.5-r1 (13 Aug 2006)
+
+ 13 Aug 2006; Roy Marples <uberlord@gentoo.org> +dhcpcd-2.0.5-r1.ebuild,
+ +dhcpcd-2.0.8-r3.ebuild:
+ Bump to push out patch.
13 Aug 2006; Roy Marples <uberlord@gentoo.org>
+files/dhcpcd-2.0.0-alwaysup.patch, +files/dhcpcd-2.0.8-alwaysup.patch,
diff --git a/net-misc/dhcpcd/dhcpcd-2.0.5-r1.ebuild b/net-misc/dhcpcd/dhcpcd-2.0.5-r1.ebuild
new file mode 100644
index 000000000000..98722aac2af0
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-2.0.5-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-2.0.5-r1.ebuild,v 1.1 2006/08/13 19:37:36 uberlord Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A DHCP client only"
+HOMEPAGE="http://developer.berlios.de/projects/dhcpcd/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE="build debug static"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+pkg_setup() {
+ if use debug ; then
+ ewarn "WARNING: dhcpcd will provide good debugging output with the"
+ ewarn "debug USE flag enabled but will not actually configure the"
+ ewarn "interface or setup /etc/resolv.conf"
+ fi
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Never take the interface down
+ epatch "${FILESDIR}/${PN}-2.0.0-alwaysup.patch"
+
+ # Redefine the location of ntp.drift
+ sed -i 's:/etc/ntp\.drift:/var/lib/ntp/ntp.drift:' src/dhcpconfig.c
+}
+
+src_compile() {
+ local myconf="$(use_enable debug)"
+ use static && append-flags -static
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ into /
+ dosbin src/dhcpcd || die
+
+ if ! use build ; then
+ dodoc AUTHORS ChangeLog NEWS README
+ doman src/dhcpcd.8
+ fi
+}
diff --git a/net-misc/dhcpcd/dhcpcd-2.0.8-r3.ebuild b/net-misc/dhcpcd/dhcpcd-2.0.8-r3.ebuild
new file mode 100644
index 000000000000..3774c4021416
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-2.0.8-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-2.0.8-r3.ebuild,v 1.1 2006/08/13 19:37:36 uberlord Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A DHCP client only"
+HOMEPAGE="http://developer.berlios.de/projects/dhcpcd/"
+SRC_URI="http://download.berlios.de/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build debug static"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+pkg_setup() {
+ if use debug ; then
+ ewarn "WARNING: dhcpcd will provide good debugging output with the"
+ ewarn "debug USE flag enabled but will not actually configure the"
+ ewarn "interface or setup /etc/resolv.conf"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Never take the interface down
+ epatch "${FILESDIR}/${PN}-2.0.8-alwaysup.patch"
+
+ epatch "${FILESDIR}/${P}-loglevel.patch"
+ epatch "${FILESDIR}/${P}-no_resolve_hostname.patch"
+
+ # Redefine the location of ntp.drift
+ sed -i 's:/etc/ntp\.drift:/var/lib/ntp/ntp.drift:' src/dhcpconfig.c
+}
+
+src_compile() {
+ use static && append-flags -static
+ econf $(use_enable debug) || die
+ emake || die
+}
+
+src_install() {
+ into /
+ dosbin src/dhcpcd || die
+
+ if ! use build ; then
+ dodoc AUTHORS ChangeLog NEWS README
+ doman src/dhcpcd.8
+ fi
+}
diff --git a/net-misc/dhcpcd/files/digest-dhcpcd-2.0.5-r1 b/net-misc/dhcpcd/files/digest-dhcpcd-2.0.5-r1
new file mode 100644
index 000000000000..b6787049ce35
--- /dev/null
+++ b/net-misc/dhcpcd/files/digest-dhcpcd-2.0.5-r1
@@ -0,0 +1,3 @@
+MD5 e2e5cd9b8824c7b1d37a7c441b83515f dhcpcd-2.0.5.tar.bz2 124838
+RMD160 205632ea754c51d39827cfbdb9839368a4f17a78 dhcpcd-2.0.5.tar.bz2 124838
+SHA256 0b3acf8306f5ad1fb036703c9ede302c416d9f118950903306c647357113a411 dhcpcd-2.0.5.tar.bz2 124838
diff --git a/net-misc/dhcpcd/files/digest-dhcpcd-2.0.8-r3 b/net-misc/dhcpcd/files/digest-dhcpcd-2.0.8-r3
new file mode 100644
index 000000000000..2177e02191bf
--- /dev/null
+++ b/net-misc/dhcpcd/files/digest-dhcpcd-2.0.8-r3
@@ -0,0 +1,3 @@
+MD5 ec91c33b6d9cb46a42f9564e573fd249 dhcpcd-2.0.8.tar.bz2 125090
+RMD160 719d65e257bea28db58a0ee6a4c200da88e616d2 dhcpcd-2.0.8.tar.bz2 125090
+SHA256 bf7b09f26be60485d888f88f63688d16feeb022cd7954cfc05a912e273757db1 dhcpcd-2.0.8.tar.bz2 125090