summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-07-05 19:37:01 +0000
committerPacho Ramos <pacho@gentoo.org>2011-07-05 19:37:01 +0000
commiteb40597c5f895166108c575b43f22284b2dcc542 (patch)
treed22be00fc8ba8d3f8450481a1830161d9862dd7d
parentInherit perl after wxwidgets (#374129) broken by wxwidgets inheriting base (#... (diff)
downloadgentoo-2-eb40597c5f895166108c575b43f22284b2dcc542.tar.gz
gentoo-2-eb40597c5f895166108c575b43f22284b2dcc542.tar.bz2
gentoo-2-eb40597c5f895166108c575b43f22284b2dcc542.zip
Find python in a faster way, bug #344231, upstream bug #654044. Thanks a lot to Arfrever Frehtes Taifersar Arahesis and Ed Catmur for their help.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
-rw-r--r--app-office/planner/ChangeLog7
-rw-r--r--app-office/planner/files/planner-0.14.5-find-python.patch19
-rw-r--r--app-office/planner/planner-0.14.5.ebuild16
3 files changed, 37 insertions, 5 deletions
diff --git a/app-office/planner/ChangeLog b/app-office/planner/ChangeLog
index 3b32d2e150bc..a0ed8b6bab25 100644
--- a/app-office/planner/ChangeLog
+++ b/app-office/planner/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/planner
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/planner/ChangeLog,v 1.60 2011/07/05 13:10:54 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/ChangeLog,v 1.61 2011/07/05 19:37:01 pacho Exp $
+
+ 05 Jul 2011; Pacho Ramos <pacho@gentoo.org> planner-0.14.5.ebuild,
+ +files/planner-0.14.5-find-python.patch:
+ Find python in a faster way, bug #344231, upstream bug #654044. Thanks a lot
+ to Arfrever Frehtes Taifersar Arahesis and Ed Catmur for their help.
*planner-0.14.5 (05 Jul 2011)
diff --git a/app-office/planner/files/planner-0.14.5-find-python.patch b/app-office/planner/files/planner-0.14.5-find-python.patch
new file mode 100644
index 000000000000..9735519d77e9
--- /dev/null
+++ b/app-office/planner/files/planner-0.14.5-find-python.patch
@@ -0,0 +1,19 @@
+--- acinclude.m4.old 2011-07-05 14:33:18.000000000 +0200
++++ acinclude.m4 2011-07-05 14:34:23.000000000 +0200
+@@ -85,14 +85,8 @@
+
+ # Check for Python library path
+ AC_MSG_CHECKING([for Python library path])
+- python_path=`echo $PYTHON | sed "s,/bin.*$,,"`
+- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
+- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- break
+- fi
+- done
+- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
++ python_path=`$PYTHON -c 'import distutils.sysconfig; \
++ print(distutils.sysconfig.get_python_inc())'`
+ AC_MSG_RESULT([$python_path])
+ if test -z "$python_path" ; then
+ AC_MSG_ERROR([cannot find Python library path])
diff --git a/app-office/planner/planner-0.14.5.ebuild b/app-office/planner/planner-0.14.5.ebuild
index bc5905c5ac44..bbc386157430 100644
--- a/app-office/planner/planner-0.14.5.ebuild
+++ b/app-office/planner/planner-0.14.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/planner/planner-0.14.5.ebuild,v 1.1 2011/07/05 13:10:54 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/planner/planner-0.14.5.ebuild,v 1.2 2011/07/05 19:37:01 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -8,14 +8,14 @@ GNOME2_LA_PUNT="yes"
GNOME_TARBALL_SUFFIX="xz"
PYTHON_DEPEND="python? 2"
-inherit python gnome2
+inherit python gnome2 eutils autotools
DESCRIPTION="Project manager for Gnome"
HOMEPAGE="http://live.gnome.org/Planner/"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="alpha amd64 ppc sparc x86"
IUSE="doc eds python examples"
RDEPEND=">=dev-libs/glib-2.6:2
@@ -35,7 +35,9 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.12.0
app-text/scrollkeeper
>=dev-util/intltool-0.35.5
- doc? ( >=dev-util/gtk-doc-1.0 )"
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ dev-util/gtk-doc-am
+ gnome-base/gnome-common"
# FIXME: disable eds backend for now, it fails, upstream bug #654005
pkg_setup() {
@@ -56,6 +58,12 @@ src_prepare() {
# Fix intltoolize broken file, see upstream #577133
sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+
+ # Find python in a faster way, bug #344231, upstream bug #654044
+ epatch "${FILESDIR}/${PN}-0.14.5-find-python.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
}
src_install() {