summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott W Taylor <swtaylor@gentoo.org>2004-04-14 10:28:49 +0000
committerScott W Taylor <swtaylor@gentoo.org>2004-04-14 10:28:49 +0000
commitee03c8527dd437fe1acab9cd679f49b40d698c5f (patch)
tree2d9d3bc9b0c8e1c0684b9ac207c1d3690ea00c80
parentStable x86. (Manifest recommit) (diff)
downloadgentoo-2-ee03c8527dd437fe1acab9cd679f49b40d698c5f.tar.gz
gentoo-2-ee03c8527dd437fe1acab9cd679f49b40d698c5f.tar.bz2
gentoo-2-ee03c8527dd437fe1acab9cd679f49b40d698c5f.zip
Syntax cleanup for hardened
-rw-r--r--sys-boot/grub/ChangeLog5
-rw-r--r--sys-boot/grub/Manifest12
-rw-r--r--sys-boot/grub/grub-0.94-r1.ebuild9
3 files changed, 13 insertions, 13 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index 8ec7a7e411e4..699d7b96d484 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-boot/grub
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.11 2004/04/07 01:06:09 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.12 2004/04/14 10:28:49 swtaylor Exp $
+
+ 14 Apr 2004; Scott W Taylor <swtaylor@gentoo.org> :
+ Cleanup checks for hardened
06 Apr 2004; <solar@gentoo.org> grub-0.94-r1.ebuild:
stable on x86
diff --git a/sys-boot/grub/Manifest b/sys-boot/grub/Manifest
index c6aeb371a3d1..d175d2c1672b 100644
--- a/sys-boot/grub/Manifest
+++ b/sys-boot/grub/Manifest
@@ -1,10 +1,10 @@
-MD5 069541228235a8623016ed460fd4f6da ChangeLog 8613
+MD5 84751f5016783a2ad8173304fc63457b grub-0.94-r1.ebuild 3629
MD5 8098e19e3f056d996f517a8cbc254536 grub-0.92-r1.ebuild 2546
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 b4b8173ca6905de4a0079b2308b4b99a grub-0.94-r1.ebuild 3690
+MD5 e2774e1adf9195f7d2630e78964654a0 ChangeLog 8698
MD5 143492d67264ac30e251ffb1d62a1a67 grub-0.93.20030118.ebuild 2429
-MD5 16039704cf1e6b6f46b4413532af082c files/digest-grub-0.92-r1 133
-MD5 b302edf756d9f8996d9e1ae6d3a49768 files/digest-grub-0.93.20030118 1764
-MD5 8d898cd9d1928916596cc3f9883eac67 files/grub-0.93-gcc3.3.diff 639
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 cdd6c89d48982ecd544c0b4774755afd files/splash.xpm.gz 33856
+MD5 b302edf756d9f8996d9e1ae6d3a49768 files/digest-grub-0.93.20030118 1764
+MD5 16039704cf1e6b6f46b4413532af082c files/digest-grub-0.92-r1 133
MD5 0b52e1b3a6a9f3c9b86742580eabf28d files/digest-grub-0.94-r1 131
+MD5 8d898cd9d1928916596cc3f9883eac67 files/grub-0.93-gcc3.3.diff 639
diff --git a/sys-boot/grub/grub-0.94-r1.ebuild b/sys-boot/grub/grub-0.94-r1.ebuild
index a5cac9b44ce8..850d0da596ac 100644
--- a/sys-boot/grub/grub-0.94-r1.ebuild
+++ b/sys-boot/grub/grub-0.94-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.3 2004/04/07 01:06:09 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-0.94-r1.ebuild,v 1.4 2004/04/14 10:28:49 swtaylor Exp $
inherit mount-boot eutils flag-o-matic gcc
@@ -45,17 +45,14 @@ src_compile() {
### incompatible system.
unset CFLAGS
- filter-flags -fstack-protector
filter-ldflags -pie
append-flags -DNDEBUG
[ `gcc-major-version` -eq 3 ] && append-flags -minline-all-stringops
use static && append-ldflags -static
# http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
- if has_version 'sys-devel/hardened-gcc' && [ "$(gcc-getCC)" == "gcc" ] ; then
- # the configure script has problems with -nostdlib
- CC="${CC} -yet_exec -yno_propolice"
- fi
+ has_pie && CC="${CC} `test_flag -yet_exec``test_flag -nopie`"
+ has_ssp && CC="${CC} `test_flag -yno_propolice``test_flag -fno-stack-protector`"
autoconf || die
aclocal || die