summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-05 04:44:09 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-05 04:44:09 +0000
commitef3da43c55adfcf9e3c209544273ad8da8eb9a7e (patch)
treebb23f0f648417a8786f394f5b11e8e5824eed65b
parentAdd pdf documentation hidden as .tex in the source (diff)
downloadgentoo-2-ef3da43c55adfcf9e3c209544273ad8da8eb9a7e.tar.gz
gentoo-2-ef3da43c55adfcf9e3c209544273ad8da8eb9a7e.tar.bz2
gentoo-2-ef3da43c55adfcf9e3c209544273ad8da8eb9a7e.zip
revbump, migrate -> distutils-r1 according to guides from Bug #475636, closes said Bug
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/kiwi/ChangeLog8
-rw-r--r--dev-python/kiwi/kiwi-1.9.38-r1.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-python/kiwi/ChangeLog b/dev-python/kiwi/ChangeLog
index 2ecee51efb0e..0be2463e72cd 100644
--- a/dev-python/kiwi/ChangeLog
+++ b/dev-python/kiwi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/kiwi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.24 2013/04/16 09:24:53 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/ChangeLog,v 1.25 2013/07/05 04:44:09 idella4 Exp $
+
+*kiwi-1.9.38-r1 (05 Jul 2013)
+
+ 05 Jul 2013; Ian Delaney <idella4@gentoo.org> +kiwi-1.9.38-r1.ebuild:
+ revbump, migrate -> distutils-r1 according to guides from Bug #475636, closes
+ said Bug
*kiwi-1.9.38 (16 Apr 2013)
diff --git a/dev-python/kiwi/kiwi-1.9.38-r1.ebuild b/dev-python/kiwi/kiwi-1.9.38-r1.ebuild
new file mode 100644
index 000000000000..373f3742d8d1
--- /dev/null
+++ b/dev-python/kiwi/kiwi-1.9.38-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/kiwi/kiwi-1.9.38-r1.ebuild,v 1.1 2013/07/05 04:44:09 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1 versionator virtualx
+
+DESCRIPTION="Kiwi is a pure Python framework and set of enhanced PyGTK widgets"
+HOMEPAGE="http://www.async.com.br/projects/kiwi/
+ https://launchpad.net/kiwi
+ http://pypi.python.org/pypi/kiwi-gtk"
+MY_PN="${PN}-gtk"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND=">=dev-python/pygtk-2.24[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed -e "s:share/doc/kiwi:share/doc/${PF}:g" -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+# Just in case
+python_test() {
+ # Tarballs are missing files.
+ # https://code.launchpad.net/~floppym/kiwi/testfiles/+merge/106505
+ rm tests/{test_pyflakes.py,test_pep8.py,test_ui.py}
+
+ pushd "${BUILD_DIR}"/../ > /dev/null
+ testing() {
+ PYTHONPATH="${PYTHONPATH}":tests "${PYTHON}" tests/run_all_tests.py
+ }
+ VIRTUALX_COMMAND=virtualmake testing
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+ rmdir "${D}"usr/share/doc/${PF}/{api,howto} || die
+}