summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-02-19 08:22:44 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-02-19 08:22:44 +0000
commitf10560b721d74f7c26ef9dafaba61fd178d4c2a4 (patch)
tree635ff16c141196bd37746b208d768b27544c86e9
parentSimplify pkg_setup. (diff)
downloadgentoo-2-f10560b721d74f7c26ef9dafaba61fd178d4c2a4.tar.gz
gentoo-2-f10560b721d74f7c26ef9dafaba61fd178d4c2a4.tar.bz2
gentoo-2-f10560b721d74f7c26ef9dafaba61fd178d4c2a4.zip
Bump, only a year and a half since the last non-release-candidate release. Tons of changes since the last release candidate, 6.7.197. New hardware support: r5xx, rs6xx, r6xx; the 'ati' driver wrapper was restructured; the xinerama (multi-monitor) zaphod mode returned; initial support for RENDER acceleration on r3xx/r4xx; Xv fixes, BIOS fixes, other bug fixes. It's staying masked because EXA doesn't work for me on r2xx or r3xx.
(Portage version: 2.1.4)
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog13
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0.ebuild35
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 36bdaeaf741d..7753d1ca4218 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.58 2008/01/31 03:56:13 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.59 2008/02/19 08:22:44 dberkholz Exp $
+
+*xf86-video-ati-6.8.0 (19 Feb 2008)
+
+ 19 Feb 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +xf86-video-ati-6.8.0.ebuild:
+ Bump, only a year and a half since the last non-release-candidate release.
+ Tons of changes since the last release candidate, 6.7.197. New hardware
+ support: r5xx, rs6xx, r6xx; the 'ati' driver wrapper was restructured; the
+ xinerama (multi-monitor) zaphod mode returned; initial support for RENDER
+ acceleration on r3xx/r4xx; Xv fixes, BIOS fixes, other bug fixes. It's
+ staying masked because EXA doesn't work for me on r2xx or r3xx.
31 Jan 2008; Donnie Berkholz <dberkholz@gentoo.org>;
-files/6.7.196-fix_washed_color.patch, -xf86-video-ati-6.6.1.ebuild,
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0.ebuild
new file mode 100644
index 000000000000..df6ecd0e86e1
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.8.0.ebuild,v 1.1 2008/02/19 08:22:44 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+XDPVER=4
+
+inherit x-modular
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/glproto
+ x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}