summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-10-13 17:57:38 +0000
committerHans de Graaff <graaff@gentoo.org>2009-10-13 17:57:38 +0000
commitf23086997bbffe8f9edadce0f0134bca438164e6 (patch)
treec4e4291e6fd2b02802500330501b0d4ffad46a8b
parentia64/sh/sparc stable wrt #284776 (diff)
downloadgentoo-2-f23086997bbffe8f9edadce0f0134bca438164e6.tar.gz
gentoo-2-f23086997bbffe8f9edadce0f0134bca438164e6.tar.bz2
gentoo-2-f23086997bbffe8f9edadce0f0134bca438164e6.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
-rw-r--r--dev-ruby/rmagick/ChangeLog7
-rw-r--r--dev-ruby/rmagick/rmagick-2.12.2.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-ruby/rmagick/ChangeLog b/dev-ruby/rmagick/ChangeLog
index 59b4fe30da90..862c746c37e8 100644
--- a/dev-ruby/rmagick/ChangeLog
+++ b/dev-ruby/rmagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rmagick
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.150 2009/10/06 05:18:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/ChangeLog,v 1.151 2009/10/13 17:57:38 graaff Exp $
+
+*rmagick-2.12.2 (13 Oct 2009)
+
+ 13 Oct 2009; Hans de Graaff <graaff@gentoo.org> +rmagick-2.12.2.ebuild:
+ Version bump with improved compatibility for imagemagick 6.4.8-7
*rmagick-2.12.1 (06 Oct 2009)
diff --git a/dev-ruby/rmagick/rmagick-2.12.2.ebuild b/dev-ruby/rmagick/rmagick-2.12.2.ebuild
new file mode 100644
index 000000000000..9681cf0987d3
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-2.12.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rmagick/rmagick-2.12.2.ebuild,v 1.1 2009/10/13 17:57:38 graaff Exp $
+
+EAPI="2"
+
+inherit ruby
+
+# The gem for this package doesn't seem to play well with portage. It
+# runs a GNUish configure script, with argument passed directly from
+# the gem install command, but gem install doesn't use the same style
+# of arguments. Thus, unless you're smart enough to come up with a
+# fix, please leave this as a source package install.
+
+MY_PV=${PV//_/-}
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="http://rmagick.rubyforge.org/"
+SRC_URI="mirror://rubyforge/rmagick/RMagick-${MY_PV}.tar.bz2"
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+
+# hdri causes extensive changes in the imagemagick internals, and
+# rmagick is not ready to deal with those, see bug 184356.
+RDEPEND="virtual/ruby
+ >=media-gfx/imagemagick-6.3.5.10[-hdri]"
+DEPEND="${RDEPEND}
+ doc? ( virtual/ghostscript media-libs/libwmf )"
+
+S="${WORKDIR}/RMagick-${PV}"
+
+# Use a custom src_compile because the setup.rb included with RMagick
+# doesn't like extra parameters during the setup phase.
+src_compile() {
+ # When documentation is built many examples are also run. Not all
+ # of them may work (e.g. due to missing additional dependencies)
+ # so we allow the examples to fail.
+ if ! use doc ; then
+ RUBY_ECONF="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix=/usr "$@" \
+ ${RUBY_ECONF} ${EXTRA_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb setup || die "setup.rb setup failed"
+}
+
+# Use a custom src_install instead of the default one in ruby.eclass
+# because the one in ruby.eclass does not include setting the prefix
+# for the installation step and assumes that arguments can be given
+# also during the install phase.
+src_install() {
+ if ! use doc ; then
+ RUBY_ECONF="--disable-htmldoc --allow-example-errors"
+ fi
+
+ ${RUBY} setup.rb config --prefix="${D}/usr" \
+ --doc-dir="${D}/usr/share/doc/${P}/html" "$@" \
+ ${RUBY_ECONF} ${EXTRA_ECONF} || die "setup.rb config failed"
+ ${RUBY} setup.rb install --prefix="${D}" || die "setup.rb install failed"
+
+ cd "${S}"
+ dodoc ChangeLog README.html README-Mac-OSX.txt || die
+
+ use examples && dodoc examples/*
+}