summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-14 05:33:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-14 05:33:21 +0000
commitf2660738334af04aaf2c1d5b4a20e2f84909b0fd (patch)
tree315f07e15bfdb184eedf0cc5988090f8b0578c26
parentadd desktop entry for bug #85021; tidy (diff)
downloadgentoo-2-f2660738334af04aaf2c1d5b4a20e2f84909b0fd.tar.gz
gentoo-2-f2660738334af04aaf2c1d5b4a20e2f84909b0fd.tar.bz2
gentoo-2-f2660738334af04aaf2c1d5b4a20e2f84909b0fd.zip
add desktop entry support with patch from Josh Nichols (bug #85149)
(Portage version: 2.0.51.19)
-rw-r--r--games-action/chromium/ChangeLog8
-rw-r--r--games-action/chromium/chromium-0.9.12-r5.ebuild11
2 files changed, 13 insertions, 6 deletions
diff --git a/games-action/chromium/ChangeLog b/games-action/chromium/ChangeLog
index 915f1529fea3..9f8d462b24d9 100644
--- a/games-action/chromium/ChangeLog
+++ b/games-action/chromium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/chromium
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/ChangeLog,v 1.12 2004/12/30 04:45:22 mr_bones_ Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/ChangeLog,v 1.13 2005/03/14 05:33:21 mr_bones_ Exp $
+
+ 14 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ chromium-0.9.12-r5.ebuild:
+ add desktop entry support with patch from Josh Nichols (bug #85149)
29 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org>
files/0.9.12-gcc3-gentoo.patch, chromium-0.9.12-r5.ebuild:
diff --git a/games-action/chromium/chromium-0.9.12-r5.ebuild b/games-action/chromium/chromium-0.9.12-r5.ebuild
index d1c4c1f96981..858db85c52e8 100644
--- a/games-action/chromium/chromium-0.9.12-r5.ebuild
+++ b/games-action/chromium/chromium-0.9.12-r5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r5.ebuild,v 1.9 2004/12/30 04:45:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r5.ebuild,v 1.10 2005/03/14 05:33:21 mr_bones_ Exp $
inherit flag-o-matic eutils games
@@ -11,8 +11,8 @@ SRC_URI="http://www.reptilelabour.com/software/files/chromium/chromium-src-${PV}
LICENSE="Artistic"
SLOT="0"
-KEYWORDS="x86 ppc amd64 ~sparc"
-IUSE="qt sdl oggvorbis"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="oggvorbis qt sdl"
DEPEND="virtual/libc
|| (
@@ -30,6 +30,7 @@ S="${WORKDIR}/Chromium-0.9"
src_unpack() {
unpack ${A}
cd "${S}"
+ cp data/png/hero.png "${T}/chromium.png" || die "cp failed"
epatch "${FILESDIR}/${PV}-gcc3-gentoo.patch"
epatch "${FILESDIR}/${PV}-proper-options.patch"
has_version '=x11-libs/qt-3*' && epatch "${FILESDIR}/${PV}-qt3.patch"
@@ -74,5 +75,7 @@ src_install() {
dogamesbin bin/chromium* || die "dogamesbin failed"
dodir "${GAMES_DATADIR}/${PN}"
cp -r data "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
+ doicon "${T}/chromium.png"
+ make_desktop_entry chromium "Chromium B.S.U"
prepgamesdirs
}