summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-02-07 12:26:05 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-02-07 12:26:05 +0000
commitf37e391e708497b8e174751ace23f803c4b4de86 (patch)
treec1f956cd30e5ef5c9c1dbd0c4f33cb34cb3f59d6
parentVersion bump wrt bug 402495 by Ian Delaney <johneed@hotmail.com> (diff)
downloadgentoo-2-f37e391e708497b8e174751ace23f803c4b4de86.tar.gz
gentoo-2-f37e391e708497b8e174751ace23f803c4b4de86.tar.bz2
gentoo-2-f37e391e708497b8e174751ace23f803c4b4de86.zip
Inline one line env.d file and reuse HSQLDB_HOME.
Remove unneded call of env-update. #402339 Remove elog about env-update and source profile as it's the same for every packge. (Portage version: 2.1.10.44/cvs/Linux x86_64)
-rw-r--r--dev-db/hsqldb/ChangeLog11
-rw-r--r--dev-db/hsqldb/files/35hsqldb1
-rw-r--r--dev-db/hsqldb/hsqldb-1.8.1.2-r1.ebuild17
-rw-r--r--dev-db/hsqldb/hsqldb-1.8.1.3.ebuild17
4 files changed, 17 insertions, 29 deletions
diff --git a/dev-db/hsqldb/ChangeLog b/dev-db/hsqldb/ChangeLog
index 8bad969dba07..bffcdd8ad767 100644
--- a/dev-db/hsqldb/ChangeLog
+++ b/dev-db/hsqldb/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-db/hsqldb
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/ChangeLog,v 1.64 2011/10/19 11:02:38 fordfrog Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/ChangeLog,v 1.65 2012/02/07 12:26:05 sera Exp $
+
+ 07 Feb 2012; Ralph Sennhauser <sera@gentoo.org> -files/35hsqldb,
+ hsqldb-1.8.1.2-r1.ebuild, hsqldb-1.8.1.3.ebuild:
+ Inline one line env.d file and reuse HSQLDB_HOME.
+ Remove unneded call of env-update. #402339
+ Remove elog about env-update and source profile as it's the same for every
+ packge.
*hsqldb-1.8.1.3 (19 Oct 2011)
diff --git a/dev-db/hsqldb/files/35hsqldb b/dev-db/hsqldb/files/35hsqldb
deleted file mode 100644
index 7ea66e048230..000000000000
--- a/dev-db/hsqldb/files/35hsqldb
+++ /dev/null
@@ -1 +0,0 @@
-CONFIG_PROTECT="/var/lib/hsqldb"
diff --git a/dev-db/hsqldb/hsqldb-1.8.1.2-r1.ebuild b/dev-db/hsqldb/hsqldb-1.8.1.2-r1.ebuild
index c47f242bece6..e842964186ba 100644
--- a/dev-db/hsqldb/hsqldb-1.8.1.2-r1.ebuild
+++ b/dev-db/hsqldb/hsqldb-1.8.1.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.1.2-r1.ebuild,v 1.6 2011/10/19 01:58:38 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.1.2-r1.ebuild,v 1.7 2012/02/07 12:26:05 sera Exp $
EAPI=1
JAVA_PKG_IUSE="doc source test"
@@ -96,8 +96,8 @@ src_install() {
fi
use source && java-pkg_dosrc src/*
- # Install env file for CONFIG_PROTECT support
- doenvd "${FILESDIR}/35hsqldb" || die
+ echo "CONFIG_PROTECT=\"${HSQLDB_HOME}\"" > "${T}"/35hsqldb || die
+ doenvd "${T}"/35hsqldb || die
# Put init, configuration and authorization files in /etc
doinitd "${FILESDIR}/hsqldb" || die
@@ -168,13 +168,4 @@ pkg_postinst() {
elog "init script to your start-up scripts, this should be done like this:"
elog " \`rc-update add hsqldb default\`"
echo
-
- # Enable CONFIG_PROTECT for hsqldb
- env-update
- elog "Hsqldb stores its database files in ${HSQLDB_HOME} and this directory"
- elog "is added to the CONFIG_PROTECT list. In order to immediately activate"
- elog "these settings please do:"
- elog " \`env-update && source /etc/profile\`"
- elog "Otherwise the settings will become active next time you login"
- echo
}
diff --git a/dev-db/hsqldb/hsqldb-1.8.1.3.ebuild b/dev-db/hsqldb/hsqldb-1.8.1.3.ebuild
index f4b46f819f49..d513407b5814 100644
--- a/dev-db/hsqldb/hsqldb-1.8.1.3.ebuild
+++ b/dev-db/hsqldb/hsqldb-1.8.1.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.1.3.ebuild,v 1.1 2011/10/19 11:02:38 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/hsqldb/hsqldb-1.8.1.3.ebuild,v 1.2 2012/02/07 12:26:05 sera Exp $
EAPI=1
JAVA_PKG_IUSE="doc source test"
@@ -96,8 +96,8 @@ src_install() {
fi
use source && java-pkg_dosrc src/*
- # Install env file for CONFIG_PROTECT support
- doenvd "${FILESDIR}/35hsqldb" || die
+ echo "CONFIG_PROTECT=\"${HSQLDB_HOME}\"" > "${T}"/35hsqldb || die
+ doenvd "${T}"/35hsqldb || die
# Put init, configuration and authorization files in /etc
doinitd "${FILESDIR}/hsqldb" || die
@@ -168,13 +168,4 @@ pkg_postinst() {
elog "init script to your start-up scripts, this should be done like this:"
elog " \`rc-update add hsqldb default\`"
echo
-
- # Enable CONFIG_PROTECT for hsqldb
- env-update
- elog "Hsqldb stores its database files in ${HSQLDB_HOME} and this directory"
- elog "is added to the CONFIG_PROTECT list. In order to immediately activate"
- elog "these settings please do:"
- elog " \`env-update && source /etc/profile\`"
- elog "Otherwise the settings will become active next time you login"
- echo
}