summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-07-14 13:47:18 +0000
committerAron Griffis <agriffis@gentoo.org>2004-07-14 13:47:18 +0000
commitf3ecb0b5844ed3e31c31eba6a2d06e63762a1907 (patch)
treebec47506306a3dd6be0a2a4323daf1c3a9f3f643
parentsync IUSE (missing), trim trailing whitespace (Manifest recommit) (diff)
downloadgentoo-2-f3ecb0b5844ed3e31c31eba6a2d06e63762a1907.tar.gz
gentoo-2-f3ecb0b5844ed3e31c31eba6a2d06e63762a1907.tar.bz2
gentoo-2-f3ecb0b5844ed3e31c31eba6a2d06e63762a1907.zip
fix use invocation, sync IUSE (+f77), trim trailing whitespace
-rw-r--r--dev-lang/R/R-1.8.1.ebuild4
-rw-r--r--dev-lang/R/R-1.9.0-r1.ebuild5
-rw-r--r--dev-lang/R/R-1.9.0.ebuild4
3 files changed, 6 insertions, 7 deletions
diff --git a/dev-lang/R/R-1.8.1.ebuild b/dev-lang/R/R-1.8.1.ebuild
index 493ecbdae778..d28b1720c8a9 100644
--- a/dev-lang/R/R-1.8.1.ebuild
+++ b/dev-lang/R/R-1.8.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.8.1.ebuild,v 1.9 2004/07/11 17:47:32 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.8.1.ebuild,v 1.10 2004/07/14 13:47:18 agriffis Exp $
-IUSE="atlas X tcltk gnome"
+IUSE="X atlas f77 gnome tcltk"
DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
diff --git a/dev-lang/R/R-1.9.0-r1.ebuild b/dev-lang/R/R-1.9.0-r1.ebuild
index 6f67011d9eae..25f701287087 100644
--- a/dev-lang/R/R-1.9.0-r1.ebuild
+++ b/dev-lang/R/R-1.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.9.0-r1.ebuild,v 1.6 2004/07/11 17:47:32 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.9.0-r1.ebuild,v 1.7 2004/07/14 13:47:18 agriffis Exp $
IUSE="blas X tcltk gnome zlib bzlib pcre f2c"
@@ -42,7 +42,7 @@ KEYWORDS="~x86 ~sparc ~ppc ~amd64"
pkg_setup() {
if [ -z "$(which g77 2>/dev/null)" ]; then
einfo "Couldn't find g77 Fortran Compiler."
- if [ -z "$(use f2c)" ]; then
+ if ! use f2c; then
eerror "Trying to emerge this packet w/o fortran compiler."
eerror "Try again with USE=\"f2c\" emerge dev-lang/R."
die "No fortran compiler, no f2c."
@@ -128,4 +128,3 @@ src_install () {
fi
}
-
diff --git a/dev-lang/R/R-1.9.0.ebuild b/dev-lang/R/R-1.9.0.ebuild
index 985124eb1372..55684dcd0571 100644
--- a/dev-lang/R/R-1.9.0.ebuild
+++ b/dev-lang/R/R-1.9.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.9.0.ebuild,v 1.9 2004/07/11 17:47:32 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.9.0.ebuild,v 1.10 2004/07/14 13:47:18 agriffis Exp $
IUSE="blas X tcltk gnome f2c"
@@ -40,7 +40,7 @@ KEYWORDS="~x86 ~sparc ~ppc ~amd64"
pkg_setup() {
if [ -z "$(which g77 2>/dev/null)" ]; then
einfo "Couldn't find g77 Fortran Compiler."
- if [ -z "$(use f2c)" ]; then
+ if ! use f2c; then
eerror "Trying to emerge this packet w/o fortran compiler."
eerror "Try again with USE=\"f2c\" emerge dev-lang/R."
die "No fortran compiler, no f2c."