summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2014-10-16 14:59:06 +0000
committerJustin Bronder <jsbronder@gentoo.org>2014-10-16 14:59:06 +0000
commitf5bf5e7d4af7a805c7e405c7034c082e151222a3 (patch)
tree71a3d6b16f1318aa6e4576bd0d7becee8cf10c7d
parentMark arm64/m68k/s390/sh stable. (diff)
downloadgentoo-2-f5bf5e7d4af7a805c7e405c7034c082e151222a3.tar.gz
gentoo-2-f5bf5e7d4af7a805c7e405c7034c082e151222a3.tar.bz2
gentoo-2-f5bf5e7d4af7a805c7e405c7034c082e151222a3.zip
Properly disable fortran when requested, #525492. Thanks to Boris Bigott for providing a solution.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
-rw-r--r--sys-cluster/openmpi/ChangeLog7
-rw-r--r--sys-cluster/openmpi/openmpi-1.8.1.ebuild11
-rw-r--r--sys-cluster/openmpi/openmpi-1.8.3.ebuild11
-rw-r--r--sys-cluster/openmpi/openmpi-1.8.ebuild11
4 files changed, 15 insertions, 25 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 9856ea2cb3bb..d06298e729e5 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.126 2014/10/15 05:16:42 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.127 2014/10/16 14:59:06 jsbronder Exp $
+
+ 16 Oct 2014; Justin Bronder <jsbronder@gentoo.org> openmpi-1.8.ebuild,
+ openmpi-1.8.1.ebuild, openmpi-1.8.3.ebuild:
+ Properly disable fortran when requested, #525492. Thanks to Boris Bigott for
+ providing a solution.
*openmpi-1.8.3 (15 Oct 2014)
diff --git a/sys-cluster/openmpi/openmpi-1.8.1.ebuild b/sys-cluster/openmpi/openmpi-1.8.1.ebuild
index 2d8c0b8bd5e0..e3c8a0baf87a 100644
--- a/sys-cluster/openmpi/openmpi-1.8.1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.8.1.ebuild,v 1.1 2014/06/03 01:33:26 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.8.1.ebuild,v 1.2 2014/10/16 14:59:06 jsbronder Exp $
EAPI=5
@@ -114,14 +114,9 @@ src_configure() {
fi
if use fortran; then
- if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(--disable-mpi-f90)
- elif [[ $(tc-getFC) =~ if ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(--with-mpi-f90-size=medium)
- fi
+ myconf+=(--enable-mpi-fortran=all)
else
- myconf+=(--disable-mpi-f90 --disable-mpi-f77)
+ myconf+=(--enable-mpi-fortran=no)
fi
! use vt && myconf+=(--enable-contrib-no-build=vt)
diff --git a/sys-cluster/openmpi/openmpi-1.8.3.ebuild b/sys-cluster/openmpi/openmpi-1.8.3.ebuild
index cf7afaed6f44..4df06ee3f48f 100644
--- a/sys-cluster/openmpi/openmpi-1.8.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.8.3.ebuild,v 1.1 2014/10/15 05:16:42 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.8.3.ebuild,v 1.2 2014/10/16 14:59:06 jsbronder Exp $
EAPI=5
@@ -114,14 +114,9 @@ src_configure() {
fi
if use fortran; then
- if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(--disable-mpi-f90)
- elif [[ $(tc-getFC) =~ if ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(--with-mpi-f90-size=medium)
- fi
+ myconf+=(--enable-mpi-fortran=all)
else
- myconf+=(--disable-mpi-f90 --disable-mpi-f77)
+ myconf+=(--enable-mpi-fortran=no)
fi
! use vt && myconf+=(--enable-contrib-no-build=vt)
diff --git a/sys-cluster/openmpi/openmpi-1.8.ebuild b/sys-cluster/openmpi/openmpi-1.8.ebuild
index 1e32bda882d3..ba6042b62bf7 100644
--- a/sys-cluster/openmpi/openmpi-1.8.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.8.ebuild,v 1.2 2014/04/17 14:59:46 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.8.ebuild,v 1.3 2014/10/16 14:59:06 jsbronder Exp $
EAPI=5
@@ -113,14 +113,9 @@ src_configure() {
fi
if use fortran; then
- if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(--disable-mpi-f90)
- elif [[ $(tc-getFC) =~ if ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(--with-mpi-f90-size=medium)
- fi
+ myconf+=(--enable-mpi-fortran=all)
else
- myconf+=(--disable-mpi-f90 --disable-mpi-f77)
+ myconf+=(--enable-mpi-fortran=no)
fi
! use vt && myconf+=(--enable-contrib-no-build=vt)