summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-25 20:17:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-25 20:17:16 +0000
commitf66024eef81682a116c41db9a5e81bbc1354fa08 (patch)
treecce6098ab903601e9e6d9b5ac06842e6df97a946
parentKEYWORD shuffle (diff)
downloadgentoo-2-f66024eef81682a116c41db9a5e81bbc1354fa08.tar.gz
gentoo-2-f66024eef81682a116c41db9a5e81bbc1354fa08.tar.bz2
gentoo-2-f66024eef81682a116c41db9a5e81bbc1354fa08.zip
add arm KEYWORDS
-rw-r--r--sys-devel/bc/bc-1.06-r5.ebuild40
-rw-r--r--sys-devel/bison/bison-1.875.ebuild4
-rw-r--r--sys-devel/flex/flex-2.5.4a-r5.ebuild32
3 files changed, 35 insertions, 41 deletions
diff --git a/sys-devel/bc/bc-1.06-r5.ebuild b/sys-devel/bc/bc-1.06-r5.ebuild
index 89c50dcd1d0b..73922d940f2d 100644
--- a/sys-devel/bc/bc-1.06-r5.ebuild
+++ b/sys-devel/bc/bc-1.06-r5.ebuild
@@ -1,29 +1,27 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06-r5.ebuild,v 1.14 2004/03/02 16:58:24 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06-r5.ebuild,v 1.15 2004/04/25 20:14:48 vapier Exp $
-IUSE="readline"
-
-inherit flag-o-matic
+inherit eutils flag-o-matic
-S=${WORKDIR}/${P}
DESCRIPTION="Handy console-based calculator utility"
HOMEPAGE="http://www.gnu.org/software/bc/bc.html"
SRC_URI="mirror://gnu/bc/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="x86 ppc sparc alpha hppa mips amd64 ia64 ppc64 s390"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa mips amd64 ia64 ppc64 s390"
+IUSE="readline"
RDEPEND="readline? ( >=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2 )"
-DEPEND="$RDEPEND
+DEPEND="${RDEPEND}
>=sys-apps/portage-2.0.47-r10
sys-devel/flex"
src_unpack() {
-
- unpack ${A} ; cd ${S}
+ unpack ${A}
+ cd ${S}
epatch ${FILESDIR}/bc-1.06-info-fix.diff
epatch ${FILESDIR}/bc-1.06-readline42.diff
@@ -47,31 +45,23 @@ src_unpack() {
}
src_compile() {
-
- # -O2 causes segafults on ppc with zero backtrace :/
- use ppc && filter-flags "-O2"
-
- # -Os causes segfaults on x86
- use x86 && replace-flags "-Os" "-O2"
-
- # >= -O2 crashes bc -l and -O1 produces no output
- use amd64 && replace-flags "-O[1-9]" "-O0"
+ case ${ARCH} in
+ ppc) filter-flags -O2;;
+ x86) replace-flags -Os -O2;;
+ amd64) replace-flags -O? -O0;;
+ esac
local myconf=""
use readline && myconf="--with-readline"
-
econf ${myconf} || die
-
emake || die
}
src_install() {
-
into /usr
- dobin bc/bc dc/dc
+ dobin bc/bc dc/dc || die
doinfo doc/*.info
doman doc/*.1
- dodoc AUTHORS COPYING* FAQ NEWS README ChangeLog
+ dodoc AUTHORS FAQ NEWS README ChangeLog
}
-
diff --git a/sys-devel/bison/bison-1.875.ebuild b/sys-devel/bison/bison-1.875.ebuild
index 2718d5410fa2..c765effa24c4 100644
--- a/sys-devel/bison/bison-1.875.ebuild
+++ b/sys-devel/bison/bison-1.875.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.16 2004/04/20 20:19:19 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875.ebuild,v 1.17 2004/04/25 20:17:16 vapier Exp $
inherit gcc flag-o-matic eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86 ~ppc sparc alpha mips hppa ia64 ppc64 s390"
+KEYWORDS="x86 ~ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
IUSE="nls static"
DEPEND="sys-devel/m4
diff --git a/sys-devel/flex/flex-2.5.4a-r5.ebuild b/sys-devel/flex/flex-2.5.4a-r5.ebuild
index bcc59a33184d..2afc4089d53a 100644
--- a/sys-devel/flex/flex-2.5.4a-r5.ebuild
+++ b/sys-devel/flex/flex-2.5.4a-r5.ebuild
@@ -1,15 +1,18 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/flex-2.5.4a-r5.ebuild,v 1.17 2004/03/02 16:41:07 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/flex-2.5.4a-r5.ebuild,v 1.18 2004/04/25 20:16:43 vapier Exp $
+
+inherit eutils
S="${WORKDIR}/${P/a/}"
DESCRIPTION="GNU lexical analyser generator"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
HOMEPAGE="http://lex.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="FLEX"
SLOT="0"
-KEYWORDS="amd64 x86 ppc sparc alpha mips hppa ia64 ppc64 s390"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 ppc64 s390"
+IUSE=""
DEPEND="virtual/glibc"
RDEPEND="virtual/glibc"
@@ -19,17 +22,19 @@ src_unpack() {
cd ${S}
# Some Redhat patches to fix various problems
- patch -p1 < ${FILESDIR}/flex-2.5.4-glibc22.patch || die
- patch -p1 < ${FILESDIR}/flex-2.5.4a-gcc3.patch || die
- patch -p1 < ${FILESDIR}/flex-2.5.4a-gcc31.patch || die
- patch -p1 < ${FILESDIR}/flex-2.5.4a-skel.patch || die
+ epatch ${FILESDIR}/flex-2.5.4-glibc22.patch
+ epatch ${FILESDIR}/flex-2.5.4a-gcc3.patch
+ epatch ${FILESDIR}/flex-2.5.4a-gcc31.patch
+ epatch ${FILESDIR}/flex-2.5.4a-skel.patch
}
src_compile() {
- ./configure --prefix=/usr \
- --host=${CHOST} || die
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ || die
- if [ -z "`use static`" ]
+ if ! use static
then
emake || make || die
else
@@ -42,13 +47,12 @@ src_install() {
mandir=${D}/usr/share/man/man1 \
install || die
- if [ -z "`use build`" ]
+ if ! use build
then
- dodoc COPYING NEWS README
+ dodoc NEWS README
else
rm -rf ${D}/usr/share ${D}/usr/include ${D}/usr/lib
fi
dosym flex /usr/bin/lex
}
-