summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-04-22 01:07:15 +0000
committerAron Griffis <agriffis@gentoo.org>2002-04-22 01:07:15 +0000
commitf7ea283e63c725a8e30c5fb03870446c2ff590ae (patch)
tree64864fe2cb73600aa5f58a2f05c86c73297ec142
parentupdated package (diff)
downloadgentoo-2-f7ea283e63c725a8e30c5fb03870446c2ff590ae.tar.gz
gentoo-2-f7ea283e63c725a8e30c5fb03870446c2ff590ae.tar.bz2
gentoo-2-f7ea283e63c725a8e30c5fb03870446c2ff590ae.zip
Updated lots of ruby-gtk/gnome stuff. Modified ruby-gtk to use the
unified tarball so that all these other ebuilds can use the same tarball. This makes building easier, too, since the ruby-gtk header files are available for each ebuild (otherwise we'd have to install them).
-rw-r--r--dev-ruby/ruby-gconf/ChangeLog23
-rw-r--r--dev-ruby/ruby-gconf/files/digest-ruby-gconf-0.21
-rw-r--r--dev-ruby/ruby-gconf/ruby-gconf-0.2.ebuild23
-rw-r--r--dev-ruby/ruby-gdkimlib/ChangeLog23
-rw-r--r--dev-ruby/ruby-gdkimlib/files/digest-ruby-gdkimlib-0.271
-rw-r--r--dev-ruby/ruby-gdkimlib/ruby-gdkimlib-0.27.ebuild24
-rw-r--r--dev-ruby/ruby-gdkpixbuf/ChangeLog23
-rw-r--r--dev-ruby/ruby-gdkpixbuf/files/digest-ruby-gdkpixbuf-0.271
-rw-r--r--dev-ruby/ruby-gdkpixbuf/ruby-gdkpixbuf-0.27.ebuild23
-rw-r--r--dev-ruby/ruby-gnome/ChangeLog23
-rw-r--r--dev-ruby/ruby-gnome/files/digest-ruby-gnome-0.271
-rw-r--r--dev-ruby/ruby-gnome/ruby-gnome-0.27.ebuild25
-rw-r--r--dev-ruby/ruby-gtk/ChangeLog34
-rw-r--r--dev-ruby/ruby-gtk/files/digest-ruby-gtk-0.272
-rw-r--r--dev-ruby/ruby-gtk/ruby-gtk-0.27.ebuild11
-rw-r--r--dev-ruby/ruby-libglade/ruby-libglade-0.27.ebuild25
-rw-r--r--dev-ruby/ruby-panel-applet/ruby-panel-applet-0.27.ebuild23
17 files changed, 232 insertions, 54 deletions
diff --git a/dev-ruby/ruby-gconf/ChangeLog b/dev-ruby/ruby-gconf/ChangeLog
index 893a56930874..da27416a6e77 100644
--- a/dev-ruby/ruby-gconf/ChangeLog
+++ b/dev-ruby/ruby-gconf/ChangeLog
@@ -1,13 +1,20 @@
# ChangeLog for dev-ruby/ruby-gconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gconf/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gconf/ChangeLog,v 1.2 2002/04/22 01:07:15 agriffis Exp $
+
+*ruby-gconf-0.2 (21 Apr 2002)
+
+ 21 Apr 2002; Aron Griffis <agriffis@gentoo.org> ruby-gconf-0.2.ebuild:
+
+ Updated to version 0.2
*ruby-gconf-0.1 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/dev-ruby/ruby-gconf/files/digest-ruby-gconf-0.2 b/dev-ruby/ruby-gconf/files/digest-ruby-gconf-0.2
new file mode 100644
index 000000000000..92384e091267
--- /dev/null
+++ b/dev-ruby/ruby-gconf/files/digest-ruby-gconf-0.2
@@ -0,0 +1 @@
+MD5 d9846c9821d7bc90d69acde6db548eb3 ruby-gconf-0.2.tar.gz 20135
diff --git a/dev-ruby/ruby-gconf/ruby-gconf-0.2.ebuild b/dev-ruby/ruby-gconf/ruby-gconf-0.2.ebuild
new file mode 100644
index 000000000000..51dfbb22eda9
--- /dev/null
+++ b/dev-ruby/ruby-gconf/ruby-gconf-0.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gconf/ruby-gconf-0.2.ebuild,v 1.1 2002/04/22 01:07:15 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Ruby Gconf bindings"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/${P}.tar.gz"
+HOMEPAGE="http://ruby-gnome.sourceforge.net/"
+
+DEPEND=">=dev-lang/ruby-1.6.4-r1
+ >=x11-libs/gtk+-1.2.10-r4
+ >=gnome-base/gconf-1.0.7-r2"
+
+src_compile() {
+ ruby extconf.rb || die "ruby extconf.rb failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make install DESTDIR=${D}
+ dodoc [A-Z]*
+}
diff --git a/dev-ruby/ruby-gdkimlib/ChangeLog b/dev-ruby/ruby-gdkimlib/ChangeLog
index 8c8858332159..515eac60dc00 100644
--- a/dev-ruby/ruby-gdkimlib/ChangeLog
+++ b/dev-ruby/ruby-gdkimlib/ChangeLog
@@ -1,13 +1,20 @@
# ChangeLog for dev-ruby/ruby-gdkimlib
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gdkimlib/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gdkimlib/ChangeLog,v 1.2 2002/04/22 01:07:15 agriffis Exp $
+
+*ruby-gdkimlib-0.27 (21 Apr 2002)
+
+ 21 Apr 2002; Aron Griffis <agriffis@gentoo.org> ruby-gdkimlib-0.27.ebuild:
+
+ Updated to version 0.27
*ruby-gdkimlib-0.26 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/dev-ruby/ruby-gdkimlib/files/digest-ruby-gdkimlib-0.27 b/dev-ruby/ruby-gdkimlib/files/digest-ruby-gdkimlib-0.27
new file mode 100644
index 000000000000..a209756ceebd
--- /dev/null
+++ b/dev-ruby/ruby-gdkimlib/files/digest-ruby-gdkimlib-0.27
@@ -0,0 +1 @@
+MD5 d7663ba9ca6d3f4e91734879d7d58c4b ruby-gnome-all-0.27.tar.gz 362625
diff --git a/dev-ruby/ruby-gdkimlib/ruby-gdkimlib-0.27.ebuild b/dev-ruby/ruby-gdkimlib/ruby-gdkimlib-0.27.ebuild
new file mode 100644
index 000000000000..0f5aba1cff67
--- /dev/null
+++ b/dev-ruby/ruby-gdkimlib/ruby-gdkimlib-0.27.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gdkimlib/ruby-gdkimlib-0.27.ebuild,v 1.1 2002/04/22 01:07:15 agriffis Exp $
+
+S=${WORKDIR}/ruby-gnome-all-${PV}/gdkimlib
+DESCRIPTION="Ruby GdkImlib bindings"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/ruby-gnome-all-${PV}.tar.gz"
+HOMEPAGE="http://ruby-gnome.sourceforge.net/"
+
+DEPEND=">=dev-lang/ruby-1.6.4-r1
+ >=x11-libs/gtk+-1.2.10-r4
+ >=dev-ruby/ruby-gtk-0.27"
+
+src_compile() {
+ ruby extconf.rb || die "ruby extconf.rb failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make site-install DESTDIR=${D}
+ dodoc [A-Z]*
+ cp -dr sample ${D}/usr/share/doc/${PF}
+}
diff --git a/dev-ruby/ruby-gdkpixbuf/ChangeLog b/dev-ruby/ruby-gdkpixbuf/ChangeLog
index 43a9cda80e04..0a579dba1958 100644
--- a/dev-ruby/ruby-gdkpixbuf/ChangeLog
+++ b/dev-ruby/ruby-gdkpixbuf/ChangeLog
@@ -1,13 +1,20 @@
# ChangeLog for dev-ruby/ruby-gdkpixbuf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gdkpixbuf/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gdkpixbuf/ChangeLog,v 1.2 2002/04/22 01:07:15 agriffis Exp $
+
+*ruby-gdkpixbuf-0.27 (21 Apr 2002)
+
+ 21 Apr 2002; Aron Griffis <agriffis@gentoo.org> ruby-gdkpixbuf-0.27.ebuild:
+
+ Updated to version 0.27
*ruby-gdkpixbuf-0.26 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/dev-ruby/ruby-gdkpixbuf/files/digest-ruby-gdkpixbuf-0.27 b/dev-ruby/ruby-gdkpixbuf/files/digest-ruby-gdkpixbuf-0.27
new file mode 100644
index 000000000000..a209756ceebd
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf/files/digest-ruby-gdkpixbuf-0.27
@@ -0,0 +1 @@
+MD5 d7663ba9ca6d3f4e91734879d7d58c4b ruby-gnome-all-0.27.tar.gz 362625
diff --git a/dev-ruby/ruby-gdkpixbuf/ruby-gdkpixbuf-0.27.ebuild b/dev-ruby/ruby-gdkpixbuf/ruby-gdkpixbuf-0.27.ebuild
new file mode 100644
index 000000000000..abdde02d0a32
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf/ruby-gdkpixbuf-0.27.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gdkpixbuf/ruby-gdkpixbuf-0.27.ebuild,v 1.1 2002/04/22 01:07:15 agriffis Exp $
+
+S=${WORKDIR}/ruby-gnome-all-${PV}/gdkpixbuf
+DESCRIPTION="Ruby GdkPixbuf bindings"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/ruby-gnome-all-${PV}.tar.gz"
+HOMEPAGE="http://ruby-gnome.sourceforge.net/"
+
+DEPEND=">=dev-lang/ruby-1.6.4-r1
+ >=dev-ruby/ruby-gtk-${PV}"
+
+src_compile() {
+ ruby extconf.rb || die "ruby extconf.rb failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make site-install DESTDIR=${D}
+ dodoc [A-Z]*
+ cp -dr sample ${D}/usr/share/doc/${PF}
+}
diff --git a/dev-ruby/ruby-gnome/ChangeLog b/dev-ruby/ruby-gnome/ChangeLog
index a68bec153619..e10509892c50 100644
--- a/dev-ruby/ruby-gnome/ChangeLog
+++ b/dev-ruby/ruby-gnome/ChangeLog
@@ -1,13 +1,20 @@
# ChangeLog for dev-ruby/ruby-gnome
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gnome/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gnome/ChangeLog,v 1.2 2002/04/22 01:07:15 agriffis Exp $
+
+*ruby-gnome-0.27 (21 Apr 2002)
+
+ 21 Apr 2002; Aron Griffis <agriffis@gentoo.org> ruby-gnome-0.27.ebuild:
+
+ Updated to version 0.27
*ruby-gnome-0.26 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/dev-ruby/ruby-gnome/files/digest-ruby-gnome-0.27 b/dev-ruby/ruby-gnome/files/digest-ruby-gnome-0.27
new file mode 100644
index 000000000000..a209756ceebd
--- /dev/null
+++ b/dev-ruby/ruby-gnome/files/digest-ruby-gnome-0.27
@@ -0,0 +1 @@
+MD5 d7663ba9ca6d3f4e91734879d7d58c4b ruby-gnome-all-0.27.tar.gz 362625
diff --git a/dev-ruby/ruby-gnome/ruby-gnome-0.27.ebuild b/dev-ruby/ruby-gnome/ruby-gnome-0.27.ebuild
new file mode 100644
index 000000000000..938829d1bcaa
--- /dev/null
+++ b/dev-ruby/ruby-gnome/ruby-gnome-0.27.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gnome/ruby-gnome-0.27.ebuild,v 1.1 2002/04/22 01:07:15 agriffis Exp $
+
+S=${WORKDIR}/ruby-gnome-all-${PV}/gnome
+DESCRIPTION="Ruby Gnome bindings"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/ruby-gnome-all-${PV}.tar.gz"
+HOMEPAGE="http://ruby-gnome.sourceforge.net/"
+
+DEPEND=">=dev-lang/ruby-1.6.4-r1
+ >=gnome-base/gnome-libs-1.4.1.3
+ >=dev-ruby/ruby-gdkimlib-${PV}
+ >=dev-ruby/ruby-gtk-${PV}"
+
+src_compile() {
+ ruby extconf.rb || die "ruby extconf.rb failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make site-install DESTDIR=${D}
+ dodoc [A-Z]*
+ cp -dr sample doc ${D}/usr/share/doc/${PF}
+}
diff --git a/dev-ruby/ruby-gtk/ChangeLog b/dev-ruby/ruby-gtk/ChangeLog
index c6356a01042b..049e2a2e6c57 100644
--- a/dev-ruby/ruby-gtk/ChangeLog
+++ b/dev-ruby/ruby-gtk/ChangeLog
@@ -1,22 +1,30 @@
# ChangeLog for dev-ruby/ruby-gtk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gtk/ChangeLog,v 1.2 2002/04/14 05:15:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gtk/ChangeLog,v 1.3 2002/04/22 01:07:15 agriffis Exp $
+
+*ruby-gtk
+
+ 21 Apr 2002; Aron Griffis <agriffis@gentoo.org> ruby-gtk-0.27.ebuild:
+
+ Modified to use unified ruby-gnome-all tarball; this allows related
+ ebuilds to use the same tarball and only download once.
*ruby-gtk-0.27 (13 Apr 2002)
- 13 Apr 2002; Seemant Kulleen <seemant@gentoo.org> ruby-gtk-0.27.ebuild :
+ 13 Apr 2002; Seemant Kulleen <seemant@gentoo.org> ruby-gtk-0.27.ebuild :
- thomharp@charter.net submitted this updated ebuild in bug #1647.
- I have cleaned it up slightly to allow future updates to be more flexible.
- However, why did the ruby-gtk (ruby-gnome) people have to change
- the naming convention?
+ thomharp@charter.net submitted this updated ebuild in bug #1647. I have
+ cleaned it up slightly to allow future updates to be more flexible.
+ However, why did the ruby-gtk (ruby-gnome) people have to change the
+ naming convention?
*ruby-gtk-0.26 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/dev-ruby/ruby-gtk/files/digest-ruby-gtk-0.27 b/dev-ruby/ruby-gtk/files/digest-ruby-gtk-0.27
index 8f97b6a27784..a209756ceebd 100644
--- a/dev-ruby/ruby-gtk/files/digest-ruby-gtk-0.27
+++ b/dev-ruby/ruby-gtk/files/digest-ruby-gtk-0.27
@@ -1 +1 @@
-MD5 d45469d83c10abc6727c1854df802930 gtk-0.27.tar.gz 272592
+MD5 d7663ba9ca6d3f4e91734879d7d58c4b ruby-gnome-all-0.27.tar.gz 362625
diff --git a/dev-ruby/ruby-gtk/ruby-gtk-0.27.ebuild b/dev-ruby/ruby-gtk/ruby-gtk-0.27.ebuild
index 431c072ff536..4a804c3932c9 100644
--- a/dev-ruby/ruby-gtk/ruby-gtk-0.27.ebuild
+++ b/dev-ruby/ruby-gtk/ruby-gtk-0.27.ebuild
@@ -1,28 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Thom Harp <thomharp@charter.net>
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gtk/ruby-gtk-0.27.ebuild,v 1.1 2002/04/14 05:16:24 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gtk/ruby-gtk-0.27.ebuild,v 1.2 2002/04/22 01:07:15 agriffis Exp $
-MY_P=gtk-${PV}
-S=${WORKDIR}/${MY_P}
+S=${WORKDIR}/ruby-gnome-all-${PV}/gtk
DESCRIPTION="Ruby Gtk+ bindings"
-SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/${MY_P}.tar.gz"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/ruby-gnome-all-${PV}.tar.gz"
HOMEPAGE="http://ruby-gnome.sourceforge.net/"
DEPEND=">=dev-lang/ruby-1.6.4-r1
>=x11-libs/gtk+-1.2.10-r4"
src_compile() {
-
ruby extconf.rb || die "ruby extconf.rb failed"
emake || die "emake failed"
-
}
src_install () {
-
make install DESTDIR=${D}
dodoc [A-Z]*
cp -dr sample doc ${D}/usr/share/doc/${PF}
-
}
diff --git a/dev-ruby/ruby-libglade/ruby-libglade-0.27.ebuild b/dev-ruby/ruby-libglade/ruby-libglade-0.27.ebuild
new file mode 100644
index 000000000000..5bf3abe72427
--- /dev/null
+++ b/dev-ruby/ruby-libglade/ruby-libglade-0.27.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-libglade/ruby-libglade-0.27.ebuild,v 1.1 2002/04/22 01:07:15 agriffis Exp $
+
+S=${WORKDIR}/ruby-gnome-all-${PV}/libglade
+DESCRIPTION="Ruby libglade bindings"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/ruby-gnome-all-${PV}.tar.gz"
+HOMEPAGE="http://ruby-gnome.sourceforge.net/"
+
+DEPEND=">=dev-lang/ruby-1.6.4-r1
+ >=x11-libs/gtk+-1.2.10-r4
+ >=dev-libs/libxml-1.8.17-r2
+ >=zlib-1.1.4"
+
+src_compile() {
+ ruby extconf.rb || die "ruby extconf.rb failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make site-install DESTDIR=${D}
+ dodoc [A-Z]*
+ cp -dr sample ${D}/usr/share/doc/${PF}
+}
diff --git a/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.27.ebuild b/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.27.ebuild
new file mode 100644
index 000000000000..8f57f9f4d8cb
--- /dev/null
+++ b/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.27.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-panel-applet/ruby-panel-applet-0.27.ebuild,v 1.1 2002/04/22 01:07:15 agriffis Exp $
+
+S=${WORKDIR}/ruby-gnome-all-${PV}/panel-applet
+DESCRIPTION="Ruby Gnome Panel bindings"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/ruby-gnome-all-${PV}.tar.gz"
+HOMEPAGE="http://ruby-gnome.sourceforge.net/"
+
+DEPEND=">=dev-lang/ruby-1.6.4-r1
+ >=dev-ruby/ruby-gnome-${PV}"
+
+src_compile() {
+ ruby extconf.rb || die "ruby extconf.rb failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make site-install DESTDIR=${D}
+ dodoc [A-Z]*
+ cp -dr sample ${D}/usr/share/doc/${PF}
+}