summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-03-15 05:58:10 +0000
committerMichał Górny <mgorny@gentoo.org>2015-03-15 05:58:10 +0000
commitf87a8756329e84b8231cdb99c201ab2c94e1ca58 (patch)
treec29fe0e8c1a1e20c8661441954945b152547ae6b
parentAdjust description (diff)
downloadgentoo-2-f87a8756329e84b8231cdb99c201ab2c94e1ca58.tar.gz
gentoo-2-f87a8756329e84b8231cdb99c201ab2c94e1ca58.tar.bz2
gentoo-2-f87a8756329e84b8231cdb99c201ab2c94e1ca58.zip
Version bump with some fixes.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
-rw-r--r--xfce-base/xfwm4/ChangeLog7
-rw-r--r--xfce-base/xfwm4/xfwm4-4.12.1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/xfce-base/xfwm4/ChangeLog b/xfce-base/xfwm4/ChangeLog
index dcc6f8c7451f..0a6f4e74345a 100644
--- a/xfce-base/xfwm4/ChangeLog
+++ b/xfce-base/xfwm4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfwm4
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.230 2015/03/08 15:06:39 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/ChangeLog,v 1.231 2015/03/15 05:58:10 mgorny Exp $
+
+*xfwm4-4.12.1 (15 Mar 2015)
+
+ 15 Mar 2015; Michał Górny <mgorny@gentoo.org> +xfwm4-4.12.1.ebuild:
+ Version bump with some fixes.
*xfwm4-4.12.0 (08 Mar 2015)
diff --git a/xfce-base/xfwm4/xfwm4-4.12.1.ebuild b/xfce-base/xfwm4/xfwm4-4.12.1.ebuild
new file mode 100644
index 000000000000..009eb70ccc40
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.12.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfwm4/xfwm4-4.12.1.ebuild,v 1.1 2015/03/15 05:58:10 mgorny Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug dri startup-notification +xcomposite"
+
+RDEPEND=">=dev-libs/glib-2.20
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/pango
+ >=x11-libs/libwnck-2.30:1
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/xfconf-4.10
+ dri? ( >=x11-libs/libdrm-2.4 )
+ startup-notification? ( x11-libs/startup-notification )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable dri libdrm)
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xcomposite compositor)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+}