summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-06-09 20:45:55 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-06-09 20:45:55 +0000
commitf9dd1113b198a9806020570958fe3a365d98000b (patch)
tree9786fee9591bdffaeb144d406b19808b8cde9bcd
parentOld. (diff)
downloadgentoo-2-f9dd1113b198a9806020570958fe3a365d98000b.tar.gz
gentoo-2-f9dd1113b198a9806020570958fe3a365d98000b.tar.bz2
gentoo-2-f9dd1113b198a9806020570958fe3a365d98000b.zip
Remove all -W flags and most -f flags, bug #512314
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
-rw-r--r--net-libs/cyassl/ChangeLog10
-rw-r--r--net-libs/cyassl/cyassl-2.9.4-r1.ebuild159
-rw-r--r--net-libs/cyassl/cyassl-3.0.0-r1.ebuild (renamed from net-libs/cyassl/cyassl-3.0.0.ebuild)11
-rw-r--r--net-libs/cyassl/files/cyassl-2.9.4-remove-hardened-flags.patch72
4 files changed, 246 insertions, 6 deletions
diff --git a/net-libs/cyassl/ChangeLog b/net-libs/cyassl/ChangeLog
index b276699e9e28..83516a66fba1 100644
--- a/net-libs/cyassl/ChangeLog
+++ b/net-libs/cyassl/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/cyassl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.53 2014/06/08 14:18:58 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.54 2014/06/09 20:45:54 blueness Exp $
+
+*cyassl-3.0.0-r1 (09 Jun 2014)
+*cyassl-2.9.4-r1 (09 Jun 2014)
+
+ 09 Jun 2014; Anthony G. Basile <blueness@gentoo.org> +cyassl-2.9.4-r1.ebuild,
+ +cyassl-3.0.0-r1.ebuild, +files/cyassl-2.9.4-remove-hardened-flags.patch,
+ -cyassl-3.0.0.ebuild:
+ Remove all -W flags and most -f flags, bug #512314
08 Jun 2014; Anthony G. Basile <blueness@gentoo.org> cyassl-2.9.4.ebuild,
cyassl-3.0.0.ebuild:
diff --git a/net-libs/cyassl/cyassl-2.9.4-r1.ebuild b/net-libs/cyassl/cyassl-2.9.4-r1.ebuild
new file mode 100644
index 000000000000..23c2bd4aa391
--- /dev/null
+++ b/net-libs/cyassl/cyassl-2.9.4-r1.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/cyassl-2.9.4-r1.ebuild,v 1.1 2014/06/09 20:45:54 blueness Exp $
+
+EAPI="5"
+
+inherit autotools eutils
+
+DESCRIPTION="Lightweight SSL/TLS library targeted at embedded and RTOS environments"
+HOMEPAGE="http://www.yassl.com/yaSSL/Home.html"
+SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86"
+
+CACHE_SIZE="small big huge"
+CRYPTO_OPTS="aes-gcm aes-ccm aes-ni blake2 camellia dsa ecc hc128 hkdf md2 md4 nullcipher psk leanpsk pkcs7 rabbit ripemd scep sha512 supportedcurves"
+CERT_OPTS="ocsp crl crl-monitor savesession savecert sessioncerts testcert"
+EXTRAS="atomicuser pkcallbacks sep maxfragment truncatedhmac tlsx"
+DEBUG="debug errorstrings memory test"
+
+#Note: sniffer is broken at the configure.ac level. Its not too important and we'll disable it for this release.
+#IUSE="-dtls examples extra fortress ipv6 httpd mcapi pwdbased sni sniffer static-libs threads zlib ${CACHE_SIZE} ${CRYPTO_OPTS} ${CERT_OPTS} ${EXTRAS} ${DEBUG}"
+IUSE="-dtls examples extra fortress ipv6 httpd mcapi pwdbased sni static-libs threads zlib ${CACHE_SIZE} ${CRYPTO_OPTS} ${CERT_OPTS} ${EXTRAS} ${DEBUG}"
+
+#You can only pick one cach size
+#sha512 is broken on x86
+#Testing freezes with dtls
+REQUIRED_USE="
+ leanpsk? ( psk )
+ fortress? ( extra sha512 )
+ pwdbased? ( extra )
+ test? ( !dtls )"
+
+# Re-add sniffer? ( net-libs/libpcap ) to DEPEND when its fixed
+DEPEND="app-arch/unzip
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+# More trouble ahead, bug #512312
+RESTRICT="test"
+
+src_prepare() {
+ # More trouble ahead, bug #512312
+ #epatch "${FILESDIR}"/${PN}-2.0.8-disable-testsuit-ifnothreads.patch
+ epatch "${FILESDIR}"/${PN}-2.9.4-remove-hardened-flags.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+
+ if use debug; then
+ myconf+=( --enable-debug )
+ fi
+
+ if use x86; then
+ #not pie friendly, sorry x86, no fast math for you :(
+ myconf+=( --disable-keygen --disable-fastmath --disable-fasthugemath --disable-bump )
+ else
+ myconf+=( --enable-keygen --enable-fastmath --enable-fasthugemath --enable-bump )
+ fi
+
+ #Bug #454300
+ export C_EXTRA_FLAGS=${CFLAGS}
+
+ econf \
+ $(usex threads --disable-singlethreaded --enable-singlethreaded) \
+ \
+ --disable-silent-rules \
+ --enable-certgen \
+ --disable-stacksize \
+ --disable-ntru \
+ --enable-filesystem \
+ --enable-inline \
+ --disable-oldtls \
+ --disable-valgrind \
+ --enable-asn \
+ --enable-md5 \
+ --enable-arc4 \
+ --enable-des3 \
+ --enable-aes \
+ --enable-sha \
+ --enable-rsa \
+ --enable-dh \
+ --enable-coding \
+ \
+ $(use_enable small smallcache) \
+ $(use_enable big bigcache) \
+ $(use_enable huge hugecache) \
+ \
+ $(use_enable aes-gcm aesgcm) \
+ $(use_enable aes-ccm aesccm) \
+ $(use_enable aes-ni aesni) \
+ $(use_enable blake2) \
+ $(use_enable camellia) \
+ $(use_enable dsa) \
+ $(use_enable ecc) \
+ $(use_enable hc128) \
+ $(use_enable hkdf) \
+ $(use_enable md2) \
+ $(use_enable md4) \
+ $(use_enable nullcipher) \
+ $(use_enable psk) \
+ $(use_enable leanpsk) \
+ $(use_enable pkcs7) \
+ $(use_enable rabbit) \
+ $(use_enable ripemd) \
+ $(use_enable scep) \
+ $(use_enable sha512) \
+ $(use_enable supportedcurves) \
+ \
+ $(use_enable ocsp) \
+ $(use_enable crl) \
+ $(use_enable crl-monitor) \
+ $(use_enable savesession) \
+ $(use_enable savecert) \
+ $(use_enable sessioncerts) \
+ $(use_enable testcert) \
+ \
+ $(use_enable atomicuser) \
+ $(use_enable pkcallbacks) \
+ $(use_enable sep) \
+ $(use_enable maxfragment) \
+ $(use_enable truncatedhmac) \
+ $(use_enable tlsx) \
+ \
+ $(use_enable errorstrings) \
+ $(use_enable memory) \
+ \
+ $(use_enable dtls) \
+ $(use_enable examples) \
+ $(use_enable extra opensslextra) \
+ $(use_enable fortress) \
+ $(use_enable ipv6) \
+ $(use_enable httpd webserver) \
+ $(use_enable mcapi) \
+ $(use_enable pwdbased) \
+ $(use_enable sni) \
+ $(use_enable static-libs static) \
+ $(use_with zlib libz) \
+ "${myconf[@]}"
+
+# Re-add $(use_enable sniffer) when its fixed
+}
+
+src_test() {
+ "${S}"/tests/unit
+ "${S}"/ctaocrypt/benchmark/benchmark
+}
+
+src_install() {
+ default
+
+ mv "${D}"/usr/share/doc/"${PN}"/* \
+ "${D}"/usr/share/doc/"${P}"/
+ rmdir "${D}"/usr/share/doc/"${PN}"/
+}
diff --git a/net-libs/cyassl/cyassl-3.0.0.ebuild b/net-libs/cyassl/cyassl-3.0.0-r1.ebuild
index 8e6ba2125ba2..2e964a6de611 100644
--- a/net-libs/cyassl/cyassl-3.0.0.ebuild
+++ b/net-libs/cyassl/cyassl-3.0.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/cyassl-3.0.0.ebuild,v 1.3 2014/06/08 14:18:58 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/cyassl-3.0.0-r1.ebuild,v 1.1 2014/06/09 20:45:54 blueness Exp $
EAPI="5"
-inherit eutils
+inherit autotools eutils
DESCRIPTION="Lightweight SSL/TLS library targeted at embedded and RTOS environments"
HOMEPAGE="http://www.yassl.com/yaSSL/Home.html"
@@ -41,9 +41,10 @@ DEPEND="app-arch/unzip
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}"
-#src_prepare() {
-# epatch "${FILESDIR}"/${PN}-2.0.8-disable-testsuit-ifnothreads.patch
-#}
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.9.4-remove-hardened-flags.patch
+ eautoreconf
+}
src_configure() {
local myconf=()
diff --git a/net-libs/cyassl/files/cyassl-2.9.4-remove-hardened-flags.patch b/net-libs/cyassl/files/cyassl-2.9.4-remove-hardened-flags.patch
new file mode 100644
index 000000000000..1144d7057c64
--- /dev/null
+++ b/net-libs/cyassl/files/cyassl-2.9.4-remove-hardened-flags.patch
@@ -0,0 +1,72 @@
+diff -Naur cyassl-2.9.4.orig/configure.ac cyassl-2.9.4/configure.ac
+--- cyassl-2.9.4.orig/configure.ac 2014-04-09 13:23:26.000000000 -0400
++++ cyassl-2.9.4/configure.ac 2014-06-09 13:38:59.988657720 -0400
+@@ -13,7 +13,7 @@
+ AC_CANONICAL_HOST
+ AC_CANONICAL_BUILD
+
+-AM_INIT_AUTOMAKE([1.11 -Wall -Werror -Wno-portability foreign tar-ustar subdir-objects no-define color-tests])
++AM_INIT_AUTOMAKE([1.11 foreign tar-ustar subdir-objects no-define color-tests])
+ AC_PREREQ([2.63])
+
+ AC_ARG_PROGRAM
+@@ -1586,7 +1586,6 @@
+ # OPTIMIZE FLAGS
+ if test "$GCC" = "yes"
+ then
+- AM_CFLAGS="$AM_CFLAGS -Wall -Wno-unused"
+ if test "$ax_enable_debug" = "no"
+ then
+ if test "$ENABLED_FASTMATH" = "yes"
+@@ -1603,7 +1602,7 @@
+ fi
+
+ LIB_SOCKET_NSL
+-AX_HARDEN_CC_COMPILER_FLAGS
++dnl AX_HARDEN_CC_COMPILER_FLAGS
+
+ # link to ws2_32 if on mingw
+ case $host_os in
+@@ -1612,8 +1611,8 @@
+ esac
+
+ # add user C_EXTRA_FLAGS back
+-CFLAGS="$CFLAGS $USER_C_EXTRA_FLAGS"
+-OPTION_FLAGS="$USER_C_EXTRA_FLAGS $AM_CFLAGS"
++CFLAGS="-fwrapv $CFLAGS"
++OPTION_FLAGS="$AM_CFLAGS"
+
+ CREATE_HEX_VERSION
+ AC_SUBST([AM_CPPFLAGS])
+diff -Naur cyassl-2.9.4.orig/m4/ax_debug.m4 cyassl-2.9.4/m4/ax_debug.m4
+--- cyassl-2.9.4.orig/m4/ax_debug.m4 2014-03-27 13:44:24.000000000 -0400
++++ cyassl-2.9.4/m4/ax_debug.m4 2014-06-09 13:34:14.291644716 -0400
+@@ -43,19 +43,21 @@
+ # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+ # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+-#serial 6
++#serial 6.1
+
+ AC_DEFUN([AX_DEBUG],
+ [AC_PREREQ([2.63])dnl
+ AC_ARG_ENABLE([debug],
+ [AS_HELP_STRING([--enable-debug],
+ [Add debug code/turns off optimizations (yes|no) @<:@default=no@:>@])],
+- [ax_enable_debug=yes
+- AC_DEFINE([DEBUG],[1],[Define to 1 to enable debugging code.])],
+- [ax_enable_debug=no
+- AC_SUBST([MCHECK])
+- AC_DEFINE([DEBUG],[0],[Define to 1 to enable debugging code.])])
++ [ax_enable_debug=$enableval],
++ [ax_enable_debug=no])
++
++ AS_IF([test "x$ax_enable_debug" = xyes],
++ [AC_DEFINE([DEBUG],[1],[Define to 1 to enable debugging code.])],
++ [AC_SUBST([MCHECK])
++ AC_DEFINE([DEBUG],[0],[Define to 1 to enable debugging code.])])
+
+ AC_MSG_CHECKING([for debug])
+ AC_MSG_RESULT([$ax_enable_debug])
+- AM_CONDITIONAL([DEBUG],[test "x${ax_enable_debug}" = "xyes"])])
++ AM_CONDITIONAL([DEBUG],[test "x${ax_enable_debug}" = xyes])])