summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-10-19 11:57:28 +0000
committerMark Wright <gienah@gentoo.org>2013-10-19 11:57:28 +0000
commitfd4a3851474a9ec03bd352759ff3a33fc092ddb3 (patch)
tree8acd7f2293aac3f7ea6763437c5d251dbc870c44
parentAdd atomic-primops (diff)
downloadgentoo-2-fd4a3851474a9ec03bd352759ff3a33fc092ddb3.tar.gz
gentoo-2-fd4a3851474a9ec03bd352759ff3a33fc092ddb3.tar.bz2
gentoo-2-fd4a3851474a9ec03bd352759ff3a33fc092ddb3.zip
Add bits-atomic
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
-rw-r--r--dev-haskell/bits-atomic/ChangeLog9
-rw-r--r--dev-haskell/bits-atomic/bits-atomic-0.1.3.ebuild24
-rw-r--r--dev-haskell/bits-atomic/metadata.xml41
3 files changed, 74 insertions, 0 deletions
diff --git a/dev-haskell/bits-atomic/ChangeLog b/dev-haskell/bits-atomic/ChangeLog
new file mode 100644
index 000000000000..badefc654da6
--- /dev/null
+++ b/dev-haskell/bits-atomic/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/bits-atomic
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bits-atomic/ChangeLog,v 1.1 2013/10/19 11:57:28 gienah Exp $
+
+*bits-atomic-0.1.3 (19 Oct 2013)
+
+ 19 Oct 2013; Mark Wright <gienah@gentoo.org> +bits-atomic-0.1.3.ebuild,
+ +metadata.xml:
+ Add bits-atomic
diff --git a/dev-haskell/bits-atomic/bits-atomic-0.1.3.ebuild b/dev-haskell/bits-atomic/bits-atomic-0.1.3.ebuild
new file mode 100644
index 000000000000..a095a386ec7d
--- /dev/null
+++ b/dev-haskell/bits-atomic/bits-atomic-0.1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bits-atomic/bits-atomic-0.1.3.ebuild,v 1.1 2013/10/19 11:57:28 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Atomic bit operations on memory locations
+for low-level synchronization"
+HOMEPAGE="http://hackage.haskell.org/package/bits-atomic"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/bits-atomic/metadata.xml b/dev-haskell/bits-atomic/metadata.xml
new file mode 100644
index 000000000000..4c4e2e2f0dc2
--- /dev/null
+++ b/dev-haskell/bits-atomic/metadata.xml
@@ -0,0 +1,41 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Atomic operations including CAS (compare-and-swap), fetch &amp; add and variants
+ suitable for low-level shared-memory synchronization.
+
+ The implementation is using GCC&#39;s builtin atomic operations (available in GCC &gt;=
+ 4) in C wrappers called through the FFI. See these links for background:
+
+ * GCC manual: &lt;http://gcc.gnu.org/onlinedocs/gcc/Atomic-Builtins.html&gt;
+
+ * GCC wiki: &lt;http://gcc.gnu.org/wiki/Atomic&gt;
+
+ /Portability/: This package is primarily developed on a Linux system, but
+ should work wherever GCC &gt;= 4 is available. It has been confirmed as working
+ on OSX. On Windows, it should work with Cygwin but currently fails for
+ vanilla Haskell-Platform 2010.1.0.0 as it still packages GCC 3.x. An
+ installer for updated versions of GCC is available at
+ &lt;http://www.mingw.org/&gt; and should make this package work in connection with
+ Haskell-Platform. Feedback on compatibility would be appreciated.
+
+ /Testing:/ The following commands can be used to compile and run the test suite:
+
+ &gt; cabal unpack bits-atomic &amp;&amp; cd bits-atomic-* # if not yet locally available
+ &gt; cabal configure -ftest
+ &gt; cabal build
+ &gt; cabal test
+
+ /Recent changes/:
+
+ * 0.1.3: Documentation updates, especially on portability. No functional
+ changes.
+
+ * 0.1.2: Avoid using System.FilePath in Setup.hs to fix build failure on hackage
+ </longdescription>
+</pkgmetadata>