summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2015-01-03 13:16:41 +0000
committerAlfredo Tupone <tupone@gentoo.org>2015-01-03 13:16:41 +0000
commitff8867d1cb89189f676e7191d78ab14f2f342fb9 (patch)
tree9109bd47924b17c0a7e4b24fcad47495e055e8f7
parentAdd PYTHON_REQ_USE and DEPEND as necessary for waf. (diff)
downloadgentoo-2-ff8867d1cb89189f676e7191d78ab14f2f342fb9.tar.gz
gentoo-2-ff8867d1cb89189f676e7191d78ab14f2f342fb9.tar.bz2
gentoo-2-ff8867d1cb89189f676e7191d78ab14f2f342fb9.zip
EAPI 4
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
-rw-r--r--games-arcade/amphetamine/ChangeLog7
-rw-r--r--games-arcade/amphetamine/amphetamine-0.8.10.ebuild13
2 files changed, 12 insertions, 8 deletions
diff --git a/games-arcade/amphetamine/ChangeLog b/games-arcade/amphetamine/ChangeLog
index 6c1f9ec91e37..f1cf2a899e15 100644
--- a/games-arcade/amphetamine/ChangeLog
+++ b/games-arcade/amphetamine/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/amphetamine
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/amphetamine/ChangeLog,v 1.10 2014/05/15 16:26:37 ulm Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/amphetamine/ChangeLog,v 1.11 2015/01/03 13:16:41 tupone Exp $
+
+ 03 Jan 2015; Tupone Alfredo <tupone@gentoo.org> amphetamine-0.8.10.ebuild:
+ EAPI 4
15 May 2014; Ulrich Müller <ulm@gentoo.org> amphetamine-0.8.10.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
diff --git a/games-arcade/amphetamine/amphetamine-0.8.10.ebuild b/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
index 2726bd6c11f1..3701384e4f73 100644
--- a/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
+++ b/games-arcade/amphetamine/amphetamine-0.8.10.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/amphetamine/amphetamine-0.8.10.ebuild,v 1.11 2014/05/15 16:26:37 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/amphetamine/amphetamine-0.8.10.ebuild,v 1.12 2015/01/03 13:16:41 tupone Exp $
-EAPI=2
+EAPI=4
inherit eutils games
DESCRIPTION="a cool Jump'n Run game offering some unique visual effects"
@@ -17,6 +17,7 @@ IUSE=""
DEPEND="media-libs/libsdl[sound,video]
x11-libs/libXpm"
+RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-build.patch
@@ -24,13 +25,13 @@ PATCHES=(
)
src_compile() {
- emake INSTALL_DIR="${GAMES_DATADIR}"/${PN} || die
+ emake INSTALL_DIR="${GAMES_DATADIR}"/${PN}
}
src_install() {
- newgamesbin amph ${PN} || die "newgamesbin failed"
+ newgamesbin amph ${PN}
insinto "${GAMES_DATADIR}"/${PN}
- doins -r ../amph/* || die "doins failed"
+ doins -r ../amph/*
newicon amph.xpm ${PN}.xpm
make_desktop_entry ${PN} Amphetamine ${PN}
dodoc BUGS ChangeLog NEWS README