summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2011-03-24 14:13:17 +0000
committerWilliam Hubbs <williamh@gentoo.org>2011-03-24 14:13:17 +0000
commit07402d4331fa42de93136d0206cd1f62ccc91c9d (patch)
tree9721b8434f7ae32a2c7b6fc74c74b82e3edeb152 /app-accessibility/brltty
parentversion bump (diff)
downloadgentoo-2-07402d4331fa42de93136d0206cd1f62ccc91c9d.tar.gz
gentoo-2-07402d4331fa42de93136d0206cd1f62ccc91c9d.tar.bz2
gentoo-2-07402d4331fa42de93136d0206cd1f62ccc91c9d.zip
fix ocaml install failure, bug #344425.
(Portage version: 2.2.0_alpha28/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/brltty')
-rw-r--r--app-accessibility/brltty/ChangeLog8
-rw-r--r--app-accessibility/brltty/brltty-4.2.ebuild7
-rw-r--r--app-accessibility/brltty/files/brltty-4.2-fix-ocaml-install.patch21
3 files changed, 31 insertions, 5 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index 0f523721872b..b8831f0f1664 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-accessibility/brltty
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.107 2010/10/05 17:19:34 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.108 2011/03/24 14:13:17 williamh Exp $
+
+ 24 Mar 2011; William Hubbs <williamh@gentoo.org> brltty-4.2.ebuild,
+ +files/brltty-4.2-fix-ocaml-install.patch:
+ Fix ocaml bindings install failure, bug #344425.
05 Oct 2010; Samuli Suominen <ssuominen@gentoo.org> brltty-4.2.ebuild,
+files/brltty-4.2-glibc-212.patch:
diff --git a/app-accessibility/brltty/brltty-4.2.ebuild b/app-accessibility/brltty/brltty-4.2.ebuild
index f405484fe84c..152d2abf363e 100644
--- a/app-accessibility/brltty/brltty-4.2.ebuild
+++ b/app-accessibility/brltty/brltty-4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-4.2.ebuild,v 1.2 2010/10/05 17:19:34 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-4.2.ebuild,v 1.3 2011/03/24 14:13:17 williamh Exp $
EAPI="2"
FINDLIB_USE="ocaml"
@@ -34,6 +34,7 @@ RDEPEND="java? ( >=virtual/jre-1.4 )
src_prepare() {
epatch "${FILESDIR}"/${P}-glibc-212.patch
+ epatch "${FILESDIR}"/${P}-fix-ocaml-install.patch
java-pkg-opt-2_src_prepare
}
@@ -90,7 +91,7 @@ src_install() {
findlib_src_preinst
fi
- emake install || die
+ emake OCAML_LDCONF= install || die
if use java; then
# make install puts the _java.so there, and no it's not $(get_libdir)
diff --git a/app-accessibility/brltty/files/brltty-4.2-fix-ocaml-install.patch b/app-accessibility/brltty/files/brltty-4.2-fix-ocaml-install.patch
new file mode 100644
index 000000000000..24d7b012d03a
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-4.2-fix-ocaml-install.patch
@@ -0,0 +1,21 @@
+Index: Bindings/Caml/Makefile.in
+===================================================================
+--- Bindings/Caml/Makefile.in (revision 5474)
++++ Bindings/Caml/Makefile.in (working copy)
+@@ -31,6 +31,7 @@
+ OCAMLFIND = @OCAMLFIND@
+ OCAML_INSTALL_TARGET = @OCAML_INSTALL_TARGET@
+ OCAML_UNINSTALL_TARGET = @OCAML_UNINSTALL_TARGET@
++OCAML_LDCONF = -ldconf "$(OCAML_DESTDIR)/ld.conf"
+
+ OCAML_LIB = $(API_NAME)
+ OCAML_BCLIB = $(OCAML_LIB).cma
+@@ -102,7 +103,7 @@
+ install-with-findlib:
+ $(INSTALL_DIRECTORY) $(OCAML_DESTDIR)
+ $(OCAMLFIND) remove -destdir "$(OCAML_DESTDIR)" $(OCAML_LIB)
+- $(OCAMLFIND) install -destdir "$(OCAML_DESTDIR)" -ldconf "$(OCAML_DESTDIR)/ld.conf" $(OCAML_LIB) $(OCAML_FILES)
++ $(OCAMLFIND) install -destdir "$(OCAML_DESTDIR)" $(OCAML_LDCONF) $(OCAML_LIB) $(OCAML_FILES)
+
+ uninstall: $(OCAML_UNINSTALL_TARGET)
+