summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2011-02-23 23:20:28 +0000
committerWilliam Hubbs <williamh@gentoo.org>2011-02-23 23:20:28 +0000
commitf6601775e4c309ab4adcd267a694476e8edd6af0 (patch)
tree6219c5b6ba4359c299438dd2505ebcd9eb3c5cf1 /app-accessibility/edbrowse
parentStable on amd64 wrt bug #353436 (diff)
downloadgentoo-2-f6601775e4c309ab4adcd267a694476e8edd6af0.tar.gz
gentoo-2-f6601775e4c309ab4adcd267a694476e8edd6af0.tar.bz2
gentoo-2-f6601775e4c309ab4adcd267a694476e8edd6af0.zip
This is the initial commit for edbrowse, a line editor, web browser and email client that uses the "ed" user interface.
I would like to thank Chris Brannon <chris@the-brannons.com> for the submission. This closes #350183. (Portage version: 2.2.0_alpha25/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/edbrowse')
-rw-r--r--app-accessibility/edbrowse/ChangeLog16
-rw-r--r--app-accessibility/edbrowse/edbrowse-3.4.6.ebuild56
-rw-r--r--app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch44
-rw-r--r--app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-off-by-one.patch13
-rw-r--r--app-accessibility/edbrowse/metadata.xml12
5 files changed, 141 insertions, 0 deletions
diff --git a/app-accessibility/edbrowse/ChangeLog b/app-accessibility/edbrowse/ChangeLog
new file mode 100644
index 000000000000..a4ada54e5621
--- /dev/null
+++ b/app-accessibility/edbrowse/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for app-accessibility/edbrowse
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/ChangeLog,v 1.1 2011/02/23 23:20:28 williamh Exp $
+
+*edbrowse-3.4.6 (23 Feb 2011)
+
+ 23 Feb 2011; William Hubbs <williamh@gentoo.org> +edbrowse-3.4.6.ebuild,
+ +files/edbrowse-3.4.6-fix-makefile.patch,
+ +files/edbrowse-3.4.6-fix-off-by-one.patch, +metadata.xml:
+ Initial commit for edbrowse, a line editor, web browser and email
+ client using the ed user interface.
+ This was added to app-accessibility due to it mostly being used by blind
+ users.
+ Thanks to Chris Brannon <chris@the-brannons.com> for the submission.
+ This closes #350183.
+
diff --git a/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild b/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild
new file mode 100644
index 000000000000..88eb3b1af278
--- /dev/null
+++ b/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/edbrowse/edbrowse-3.4.6.ebuild,v 1.1 2011/02/23 23:20:28 williamh Exp $
+
+EAPI="4"
+inherit eutils
+
+DESCRIPTION="editor, browser, and mail client using the /bin/ed interface"
+HOMEPAGE="http://edbrowse.sourceforge.net/"
+SRC_URI="http://www.eklhad.net/${PN}/${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="linguas_fr odbc"
+COMMON_DEPEND=">=dev-lang/spidermonkey-1.7.0
+ >=sys-libs/readline-6.0
+ >=net-misc/curl-7.17.0
+ >=dev-libs/libpcre-7.8
+ >=dev-libs/openssl-0.9.8j
+ odbc? ( dev-db/unixODBC )"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip"
+RDEPEND="${COMMON_DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fix-makefile.patch
+ epatch "${FILESDIR}"/${P}-fix-off-by-one.patch
+}
+
+src_compile() {
+ emake prefix=/usr
+ if use odbc; then
+ # Top-level makefile doesn't have this target.
+ cd src
+ emake prefix=/usr edbrowseodbc
+ cd ..
+ fi
+}
+
+src_install() {
+ cd src
+ emake prefix=/usr DESTDIR="${D}" install
+ if use odbc; then
+ dobin edbrowseodbc
+ fi
+ cd ..
+ dodoc CHANGES README todo
+ cd doc
+ dobin setup.ebrc
+ dohtml usersguide.html philosophy.html
+ dodoc sample.ebrc
+ if use linguas_fr; then
+ dohtml usersguide_fr.html philosophy_fr.html
+ dodoc sample_fr.ebrc
+ fi
+}
diff --git a/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch b/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch
new file mode 100644
index 000000000000..4e573474beb4
--- /dev/null
+++ b/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-makefile.patch
@@ -0,0 +1,44 @@
+diff -Naur edbrowse-3.4.6/src/makefile edbrowse-3.4.6-new/src/makefile
+--- edbrowse-3.4.6/src/makefile 2011-01-20 10:38:24.000000000 +0000
++++ edbrowse-3.4.6-new/src/makefile 2011-01-26 13:50:10.000000000 +0000
+@@ -23,12 +23,15 @@
+ STRIP=-s
+ endif
+
+-CFLAGS = -I/usr/local/js/src -I/usr/local/js/src/Linux_All_DBG.OBJ -DXP_UNIX -DX86_LINUX $(DEBUGFLAGS)
++JSFLAGS = -I/usr/include/js -DXP_UNIX
++
++%.o: %.c
++ $(CC) $(CFLAGS) $(JSFLAGS) -c -o $@ $<
+
+ # If the smjs library is already installed by your linux distribution,
+ # e.g. Debian, use the following flags.
+ #
+-#CFLAGS = -I/usr/include/js -DXP_UNIX -DX86_LINUX $(DEBUGFLAGS)
++#CFLAGS = -I/usr/include/smjs -DXP_UNIX -DX86_LINUX $(DEBUGFLAGS)
+
+ # Normal load flags
+ LFLAGS = $(STRIP)
+@@ -59,11 +62,11 @@
+ $(EBOBJS) : eb.h eb.p messages.h tcp.h
+
+ edbrowse: $(EBOBJS) tcp.o dbstubs.o
+- cc $(LFLAGS) -o edbrowse $(EBOBJS) tcp.o dbstubs.o $(LIBS)
++ $(CC) $(LDFLAGS) -o edbrowse $(EBOBJS) tcp.o dbstubs.o $(LIBS)
+
+ # You probably need to be root to do this.
+ install:
+- install -Dm755 edbrowse $(bindir)/edbrowse
++ install -Dm755 edbrowse $(DESTDIR)$(bindir)/edbrowse
+
+ # If you had to build the javascript library yourself,
+ # link it into /usr/lib.
+@@ -87,7 +90,7 @@
+
+ # odbc access
+ edbrowseodbc: $(EBOBJS) tcp.o dbops.o dbodbc.o
+- cc $(LFLAGS) -o edbrowseodbc $(EBOBJS) tcp.o dbops.o dbodbc.o $(LIBS) -lodbc
++ $(CC) $(LDFLAGS) -o edbrowseodbc $(EBOBJS) tcp.o dbops.o dbodbc.o $(LIBS) -lodbc
+
+ # Build function prototypes.
+ # mkproto is my program, not a general unix utility.
diff --git a/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-off-by-one.patch b/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-off-by-one.patch
new file mode 100644
index 000000000000..324d43d231ba
--- /dev/null
+++ b/app-accessibility/edbrowse/files/edbrowse-3.4.6-fix-off-by-one.patch
@@ -0,0 +1,13 @@
+diff --git a/src/buffers.c b/src/buffers.c
+index fe0d50a..4a37d58 100644
+--- a/src/buffers.c
++++ b/src/buffers.c
+@@ -2590,7 +2590,7 @@ substituteText(const char *line)
+ replaceLine[replaceLineLen] = '\n';
+ if(!linecount) {
+ /* normal substitute */
+- char newnum[LNWIDTH];
++ char newnum[LNWIDTH+1];
+ textLines[textLinesCount] = allocMem(replaceLineLen + 1);
+ memcpy(textLines[textLinesCount], replaceLine,
+ replaceLineLen + 1);
diff --git a/app-accessibility/edbrowse/metadata.xml b/app-accessibility/edbrowse/metadata.xml
new file mode 100644
index 000000000000..c169e3e65062
--- /dev/null
+++ b/app-accessibility/edbrowse/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>williamh@gentoo.org</email>
+</maintainer>
+<longdescription>
+ edbrowse is a line editor, web browser and email client using the /bin/ed
+ user interface.
+</longdescription>
+</pkgmetadata>