summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-12-17 23:34:13 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-12-17 23:34:13 +0000
commit8e20c25c402222c9c2598afd64aa9eaa28e26bf6 (patch)
tree441331c84c43cd3786fd1170449f85c1e9950f37 /app-accessibility/orca
parentVersion bump. Trash and memory usage fixes. (diff)
downloadgentoo-2-8e20c25c402222c9c2598afd64aa9eaa28e26bf6.tar.gz
gentoo-2-8e20c25c402222c9c2598afd64aa9eaa28e26bf6.tar.bz2
gentoo-2-8e20c25c402222c9c2598afd64aa9eaa28e26bf6.zip
Version bump. Bug fixes and translation updates.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/ChangeLog7
-rw-r--r--app-accessibility/orca/orca-2.28.2.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/app-accessibility/orca/ChangeLog b/app-accessibility/orca/ChangeLog
index 97afa745ffc5..5ee2d056e133 100644
--- a/app-accessibility/orca/ChangeLog
+++ b/app-accessibility/orca/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/orca
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.72 2009/12/03 17:26:08 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.73 2009/12/17 23:34:13 eva Exp $
+
+*orca-2.28.2 (17 Dec 2009)
+
+ 17 Dec 2009; Gilles Dartiguelongue <eva@gentoo.org> +orca-2.28.2.ebuild:
+ Version bump. Bug fixes and translation updates.
03 Dec 2009; Brent Baude <ranger@gentoo.org> orca-2.26.3.ebuild:
Marking orca-2.26.3 ppc64 stable for bug 281427
diff --git a/app-accessibility/orca/orca-2.28.2.ebuild b/app-accessibility/orca/orca-2.28.2.ebuild
new file mode 100644
index 000000000000..eb5e49d0b1fa
--- /dev/null
+++ b/app-accessibility/orca/orca-2.28.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/orca-2.28.2.ebuild,v 1.1 2009/12/17 23:34:13 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2 python
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="http://www.gnome.org/projects/orca/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+RDEPEND=">=dev-libs/glib-2.10
+ >=gnome-extra/at-spi-1.24
+ >=gnome-base/orbit-2
+ >=dev-python/pyorbit-2.24
+ >=gnome-base/libbonobo-2.24
+ >=dev-python/libbonobo-python-2.24
+
+ >=dev-lang/python-2.4
+ dev-python/pygobject
+ dev-python/pycairo
+ >=dev-python/dbus-python-0.83
+ >=dev-python/pygtk-2.12
+
+ >=dev-python/libwnck-python-2.24
+ >=dev-python/gconf-python-2.24
+ >=dev-python/libgnome-python-2.14
+
+ >=app-accessibility/gnome-speech-0.3.10
+ >=app-accessibility/gnome-mag-0.12.5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed 2 failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize $(python_get_sitedir)/orca
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/orca
+}