summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-06-29 13:39:56 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-06-29 13:39:56 +0000
commit3593a0fc649fa2218ff46f96c69f6b40699ded85 (patch)
treea368308f15dcd73930b57db79a4bdeb48de20791 /app-accessibility
parentAdded use-flag shutdown_rewrite to use the new shutdown code of vdr-1.5 and n... (diff)
downloadgentoo-2-3593a0fc649fa2218ff46f96c69f6b40699ded85.tar.gz
gentoo-2-3593a0fc649fa2218ff46f96c69f6b40699ded85.tar.bz2
gentoo-2-3593a0fc649fa2218ff46f96c69f6b40699ded85.zip
Version and snapshot bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speakup/ChangeLog8
-rw-r--r--app-accessibility/speakup/speakup-3.0.3_p20080629.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/app-accessibility/speakup/ChangeLog b/app-accessibility/speakup/ChangeLog
index 48c1eaa426ee..25036f51d7d7 100644
--- a/app-accessibility/speakup/ChangeLog
+++ b/app-accessibility/speakup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/speakup
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.5 2008/05/21 13:52:36 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.6 2008/06/29 13:39:56 williamh Exp $
+
+*speakup-3.0.3_p20080629 (29 Jun 2008)
+
+ 29 Jun 2008; William Hubbs <williamh@gentoo.org>
+ +speakup-3.0.3_p20080629.ebuild:
+ Snapshot and version bump.
*speakup-3.0.2_p20080520 (21 May 2008)
diff --git a/app-accessibility/speakup/speakup-3.0.3_p20080629.ebuild b/app-accessibility/speakup/speakup-3.0.3_p20080629.ebuild
new file mode 100644
index 000000000000..bfc9edbef871
--- /dev/null
+++ b/app-accessibility/speakup/speakup-3.0.3_p20080629.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/speakup-3.0.3_p20080629.ebuild,v 1.1 2008/06/29 13:39:56 williamh Exp $
+
+inherit linux-mod
+
+DESCRIPTION="The speakup linux kernel based screen reader."
+HOMEPAGE="http://linux-speakup.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-3.0.3"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ case ${KV_FULL} in
+ 2.6.2[56]-gentoo*) ;;
+ *) die "Speakup requires gentoo-sources-2.6.25-*"
+ ;;
+ esac
+
+ MODULE_NAMES="speakup(${PN}:\"${S}\"/src)
+ speakup_acntpc(${PN}:\"${S}\"/src)
+ speakup_acntsa(${PN}:\"${S}\"/src)
+ speakup_apollo(${PN}:\"${S}\"/src)
+ speakup_audptr(${PN}:\"${S}\"/src)
+ speakup_bns(${PN}:\"${S}\"/src)
+ speakup_decext(${PN}:\"${S}\"/src)
+ speakup_decpc(${PN}:\"${S}\"/src)
+ speakup_dectlk(${PN}:\"${S}\"/src)
+ speakup_dtlk(${PN}:\"${S}\"/src)
+ speakup_dummy(${PN}:\"${S}\"/src)
+ speakup_keypc(${PN}:\"${S}\"/src)
+ speakup_ltlk(${PN}:\"${S}\"/src)
+ speakup_soft(${PN}:\"${S}\"/src)
+ speakup_spkout(${PN}:\"${S}\"/src)
+ speakup_txprt(${PN}:\"${S}\"/src)"
+ BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+ BUILD_TARGETS="clean all"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc Bugs.txt README To-Do doc/DefaultKeyAssignments doc/spkguide.txt
+ docinto contrib
+ dodoc contrib/*
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ elog "You must set up the speech synthesizer driver to be loaded"
+ elog "automatically in order for your system to start speaking"
+ elog "when it is booted."
+ if has_version "<sys-apps/baselayout-2"; then
+ elog "this is done via /etc/modules.autoload.d/kernel-2.6"
+ else
+ elog "This is done via /etc/conf.d/modules."
+ fi
+}