summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-02 20:51:34 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-02 20:51:34 +0000
commit6f261bbea925209154b6740ae61ff7bd78afa735 (patch)
treebb46818d0c1f7a47de2cb081e1735df1bb23c52a /app-accessibility
parentamd64 stable wrt bug #229993 (diff)
downloadgentoo-2-6f261bbea925209154b6740ae61ff7bd78afa735.tar.gz
gentoo-2-6f261bbea925209154b6740ae61ff7bd78afa735.tar.bz2
gentoo-2-6f261bbea925209154b6740ae61ff7bd78afa735.zip
bump to 2.22.3. Bug fixes and translation updates.
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/orca/ChangeLog7
-rw-r--r--app-accessibility/orca/orca-2.22.3.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/app-accessibility/orca/ChangeLog b/app-accessibility/orca/ChangeLog
index f79b04c174a8..6fba13ace72e 100644
--- a/app-accessibility/orca/ChangeLog
+++ b/app-accessibility/orca/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/orca
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.40 2008/05/29 15:26:57 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/ChangeLog,v 1.41 2008/07/02 20:51:34 eva Exp $
+
+*orca-2.22.3 (02 Jul 2008)
+
+ 02 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org> +orca-2.22.3.ebuild:
+ bump to 2.22.3. Bug fixes and translation updates.
29 May 2008; Ali Polatel <hawking@gentoo.org> orca-2.22.1.ebuild,
orca-2.22.2.ebuild:
diff --git a/app-accessibility/orca/orca-2.22.3.ebuild b/app-accessibility/orca/orca-2.22.3.ebuild
new file mode 100644
index 000000000000..070e5abf902d
--- /dev/null
+++ b/app-accessibility/orca/orca-2.22.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/orca/orca-2.22.3.ebuild,v 1.1 2008/07/02 20:51:34 eva Exp $
+
+inherit gnome2 python
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="http://www.gnome.org/projects/orca/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# liblouis is not in portage yet
+# it is used to provide contracted braille support
+RDEPEND=">=dev-libs/glib-2.10
+ >=gnome-base/orbit-2
+ >=gnome-extra/at-spi-1.7.6
+ >=gnome-base/libbonobo-2.14
+ >=dev-lang/python-2.4
+ >=dev-python/gnome-python-2.14
+ >=dev-python/pyorbit-2.14
+ >=app-accessibility/gnome-speech-0.3.10
+ >=app-accessibility/gnome-mag-0.12.5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-liblouis"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/orca
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/orca
+}