summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2010-01-11 08:15:28 +0000
committerBenedikt Boehm <hollow@gentoo.org>2010-01-11 08:15:28 +0000
commitb11919955eeebec8db585ef0a258453e1450a9b3 (patch)
treef1a783054aeb939f3a5d72c445c1b5cf36bd54a5 /app-admin/apachetop/apachetop-0.12.6-r1.ebuild
parentcleanup (diff)
downloadgentoo-2-b11919955eeebec8db585ef0a258453e1450a9b3.tar.gz
gentoo-2-b11919955eeebec8db585ef0a258453e1450a9b3.tar.bz2
gentoo-2-b11919955eeebec8db585ef0a258453e1450a9b3.zip
fix buffer overflow wrt #287332
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'app-admin/apachetop/apachetop-0.12.6-r1.ebuild')
-rw-r--r--app-admin/apachetop/apachetop-0.12.6-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/apachetop/apachetop-0.12.6-r1.ebuild b/app-admin/apachetop/apachetop-0.12.6-r1.ebuild
new file mode 100644
index 000000000000..3a05a87863b9
--- /dev/null
+++ b/app-admin/apachetop/apachetop-0.12.6-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apachetop/apachetop-0.12.6-r1.ebuild,v 1.1 2010/01/11 08:15:27 hollow Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="A realtime Apache log analyzer"
+HOMEPAGE="http://www.webta.org/projects/apachetop"
+SRC_URI="http://www.webta.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="fam pcre adns"
+
+DEPEND="fam? ( virtual/fam )
+ pcre? ( dev-libs/libpcre )
+ adns? ( net-libs/adns )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc41.patch
+ epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-maxpathlen.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-logfile=/var/log/apache2/access_log \
+ $(use_with fam) \
+ $(use_with pcre) \
+ $(use_with adns)
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}