summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-07 20:19:29 +0000
committerJustin Lecher <jlec@gentoo.org>2012-11-07 20:19:29 +0000
commit3d27dbd84bdeb8ef3707a50ddc68e4ccab28042b (patch)
tree76d0a5e2e9ead5a74e7617328dd5814cc06de221 /app-admin/augeas
parentSlot gstreamer dependencies in preparation for gstreamer-1.0. (diff)
downloadgentoo-2-3d27dbd84bdeb8ef3707a50ddc68e4ccab28042b.tar.gz
gentoo-2-3d27dbd84bdeb8ef3707a50ddc68e4ccab28042b.tar.bz2
gentoo-2-3d27dbd84bdeb8ef3707a50ddc68e4ccab28042b.zip
app-admin/augeas: Import two patches for tests (hopefully fixing #421907), pkgconfig file fix from upstream; add fix for glibc-2.16 gets drop, #428312
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'app-admin/augeas')
-rw-r--r--app-admin/augeas/ChangeLog12
-rw-r--r--app-admin/augeas/augeas-0.10.0-r1.ebuild49
-rw-r--r--app-admin/augeas/files/augeas-0.10.0-gets.patch15
-rw-r--r--app-admin/augeas/files/augeas-0.10.0-libxml2-pkgconfig.patch24
-rw-r--r--app-admin/augeas/files/augeas-0.10.0-test.patch56
-rw-r--r--app-admin/augeas/files/augeas-0.10.0-test2.patch49
-rw-r--r--app-admin/augeas/metadata.xml9
7 files changed, 208 insertions, 6 deletions
diff --git a/app-admin/augeas/ChangeLog b/app-admin/augeas/ChangeLog
index 9c0c45480154..e39c3c17917d 100644
--- a/app-admin/augeas/ChangeLog
+++ b/app-admin/augeas/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-admin/augeas
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.38 2012/08/26 17:04:16 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.39 2012/11/07 20:19:28 jlec Exp $
+
+*augeas-0.10.0-r1 (07 Nov 2012)
+
+ 07 Nov 2012; Justin Lecher <jlec@gentoo.org> +augeas-0.10.0-r1.ebuild,
+ +files/augeas-0.10.0-gets.patch,
+ +files/augeas-0.10.0-libxml2-pkgconfig.patch,
+ +files/augeas-0.10.0-test.patch, +files/augeas-0.10.0-test2.patch,
+ metadata.xml:
+ Import two patches for tests (hopefully fixing #421907), pkgconfig file fix
+ from upstream; add fix for glibc-2.16 gets drop, #428312
26 Aug 2012; Raúl Porcel <armin76@gentoo.org> augeas-0.10.0.ebuild:
alpha/sparc stable wrt #418483
diff --git a/app-admin/augeas/augeas-0.10.0-r1.ebuild b/app-admin/augeas/augeas-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..2073381a776c
--- /dev/null
+++ b/app-admin/augeas/augeas-0.10.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/augeas-0.10.0-r1.ebuild,v 1.1 2012/11/07 20:19:28 jlec Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://augeas.net/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gets.patch
+ "${FILESDIR}"/${P}-test.patch
+ "${FILESDIR}"/${P}-test2.patch
+ "${FILESDIR}"/${P}-libxml2-pkgconfig.patch
+ )
+
+src_prepare() {
+ if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Languages.txt
+ fi
+ if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Topics.txt
+ fi
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # Needs to implemented
+ local myeconfargs=( --without-selinux )
+ autotools-utils_src_configure
+}
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
diff --git a/app-admin/augeas/files/augeas-0.10.0-gets.patch b/app-admin/augeas/files/augeas-0.10.0-gets.patch
new file mode 100644
index 000000000000..5f754955be6c
--- /dev/null
+++ b/app-admin/augeas/files/augeas-0.10.0-gets.patch
@@ -0,0 +1,15 @@
+ gnulib/lib/stdio.in.h | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/gnulib/lib/stdio.in.h b/gnulib/lib/stdio.in.h
+index 9091497..fa7e3fb 100644
+--- a/gnulib/lib/stdio.in.h
++++ b/gnulib/lib/stdio.in.h
+@@ -162,7 +162,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not always POSIX compliant - "
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ #undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
diff --git a/app-admin/augeas/files/augeas-0.10.0-libxml2-pkgconfig.patch b/app-admin/augeas/files/augeas-0.10.0-libxml2-pkgconfig.patch
new file mode 100644
index 000000000000..aaa418670154
--- /dev/null
+++ b/app-admin/augeas/files/augeas-0.10.0-libxml2-pkgconfig.patch
@@ -0,0 +1,24 @@
+From b41deef293841da50a236023bad486ea3f57e4dc Mon Sep 17 00:00:00 2001
+From: "Richard W.M. Jones" <rjones@redhat.com>
+Date: Sat, 3 Dec 2011 14:21:50 +0000
+Subject: [PATCH] pkg-config: Augeas requires libxml2.
+
+---
+ augeas.pc.in | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/augeas.pc.in b/augeas.pc.in
+index c97847d..9e166db 100644
+--- a/augeas.pc.in
++++ b/augeas.pc.in
+@@ -6,6 +6,6 @@ includedir=@includedir@
+ Name: augeas
+ Version: @VERSION@
+ Description: Augeas configuration editing library
+-Requires:
++Requires.private: libxml-2.0
+ Libs: -L${libdir} -laugeas @LIBS@
+ Cflags: -I${includedir}
+--
+1.7.6
+
diff --git a/app-admin/augeas/files/augeas-0.10.0-test.patch b/app-admin/augeas/files/augeas-0.10.0-test.patch
new file mode 100644
index 000000000000..e2630014f29a
--- /dev/null
+++ b/app-admin/augeas/files/augeas-0.10.0-test.patch
@@ -0,0 +1,56 @@
+From 075f8d35497fb36d9193e5364c055049c66fa5eb Mon Sep 17 00:00:00 2001
+From: Lubomir Rintel <lubo.rintel@gooddata.com>
+Date: Mon, 9 Jan 2012 18:52:11 +0100
+Subject: [PATCH 1/2] Allow JSON number literals to be followed by whitespace
+
+Add a test case.
+
+Fixes https://fedorahosted.org/augeas/ticket/247
+---
+ AUTHORS | 1 +
+ lenses/json.aug | 2 +-
+ lenses/tests/test_json.aug | 3 +++
+ 3 files changed, 5 insertions(+), 1 deletions(-)
+
+diff --git a/AUTHORS b/AUTHORS
+index df63f95..e7870f2 100644
+--- a/AUTHORS
++++ b/AUTHORS
+@@ -44,6 +44,7 @@ Contributions by:
+ Bill Pemberton <wfp5p@virginia.edu>
+ Alan Pevec <apevec@redhat.com>
+ Robin Lee Powell <rlpowell@digitalkingdom.org>
++ Lubomir Rintel <lubo.rintel@gooddata.com>
+ Roman Rakus <rrakus@redhat.com>
+ Satoru SATOH <satoru.satoh@gmail.com>
+ Nicolas Valcárcel Scerpella <nvalcarcel@ubuntu.com>
+diff --git a/lenses/json.aug b/lenses/json.aug
+index c22ad90..6ceab09 100644
+--- a/lenses/json.aug
++++ b/lenses/json.aug
+@@ -29,7 +29,7 @@ let str_store =
+ let q = del "\"" "\"" in
+ q . store /[^"]*/ . q . ws (* " Emacs, relax *)
+
+-let number = [ label "number" . store /-?[0-9]+(\.[0-9]+)?([eE][+-]?[0-9]+)?/ ]
++let number = [ label "number" . store /-?[0-9]+(\.[0-9]+)?([eE][+-]?[0-9]+)?/ . ws ]
+ let str = [ label "string" . str_store ]
+
+ let const (r:regexp) = [ label "const" . store r . ws ]
+diff --git a/lenses/tests/test_json.aug b/lenses/tests/test_json.aug
+index 0bcd25d..d8b7fa8 100644
+--- a/lenses/tests/test_json.aug
++++ b/lenses/tests/test_json.aug
+@@ -8,6 +8,9 @@ test lns get "true" = { "const" = "true" }
+
+ test lns get "3.141" = { "number" = "3.141" }
+
++test lns get "{ \"key\" : 666 }" =
++ { "dict" { "entry" = "key" { "number" = "666" } } }
++
+ test lns get "[true, 0, \"yo\"]" =
+ { "array" { "const" = "true" } { "number" = "0" } { "string" = "yo" } }
+
+--
+1.7.7.5
+
diff --git a/app-admin/augeas/files/augeas-0.10.0-test2.patch b/app-admin/augeas/files/augeas-0.10.0-test2.patch
new file mode 100644
index 000000000000..743ccfdce1fc
--- /dev/null
+++ b/app-admin/augeas/files/augeas-0.10.0-test2.patch
@@ -0,0 +1,49 @@
+From 100a7b38222a63c6435a72b4974b55f39a28989e Mon Sep 17 00:00:00 2001
+From: Lubomir Rintel <lubo.rintel@gooddata.com>
+Date: Mon, 9 Jan 2012 19:24:41 +0100
+Subject: [PATCH 2/2] Correctly parse empty object and arrays in JSON
+
+Add a test case.
+Fix from David Lutterkort <lutter@redhat.com>.
+
+https://fedorahosted.org/augeas/ticket/248
+---
+ lenses/json.aug | 4 ++--
+ lenses/tests/test_json.aug | 5 +++++
+ 2 files changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/lenses/json.aug b/lenses/json.aug
+index 6ceab09..2645806 100644
+--- a/lenses/json.aug
++++ b/lenses/json.aug
+@@ -37,9 +37,9 @@ let const (r:regexp) = [ label "const" . store r . ws ]
+ let value0 = str | number | const /true|false|null/
+
+ let fix_value (value:lens) =
+- let array = [ label "array" . lbrack . Build.opt_list value comma . rbrack ] in
++ let array = [ label "array" . lbrack . (Build.opt_list value comma)? . rbrack ] in
+ let pair = [ label "entry" . str_store . colon . value ] in
+- let obj = [ label "dict" . lbrace . Build.opt_list pair comma . rbrace ] in
++ let obj = [ label "dict" . lbrace . (Build.opt_list pair comma)? . rbrace ] in
+ (str | number | obj | array | const /true|false|null/)
+
+ (* Typecheck finitely deep nesting *)
+diff --git a/lenses/tests/test_json.aug b/lenses/tests/test_json.aug
+index d8b7fa8..aec7d4c 100644
+--- a/lenses/tests/test_json.aug
++++ b/lenses/tests/test_json.aug
+@@ -30,6 +30,11 @@ test lns get "{ \"0\": true, \"1\":false }" =
+ test lns get "{\"menu\": \"entry one\"}" =
+ { "dict" { "entry" = "menu" { "string" = "entry one" } } }
+
++test lns get "[ ]" =
++ { "array" }
++
++test lns get "{}" =
++ { "dict" }
+
+ let s = "{\"menu\": {
+ \"id\": \"file\",
+--
+1.7.7.5
+
diff --git a/app-admin/augeas/metadata.xml b/app-admin/augeas/metadata.xml
index d8f155f4c90a..5f0f899580a7 100644
--- a/app-admin/augeas/metadata.xml
+++ b/app-admin/augeas/metadata.xml
@@ -1,10 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
-<email>matsuu@gentoo.org</email>
-</maintainer>
-<longdescription lang="en">
+ <maintainer>
+ <email>matsuu@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
A library for programmatically editing configuration files. Augeas parses
configuration files into a tree structure, which it exposes through its
public API. Changes made through the API are written back to the initially
@@ -15,4 +15,3 @@ details. It is controlled by ``lens'' definitions that describe the file
format and the transformation into a tree.
</longdescription>
</pkgmetadata>
-