summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-01-08 02:19:12 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-01-08 02:19:12 +0000
commit58434377ff6dec748d68afe806147e5cbec0e8b8 (patch)
tree1097b37a1ff1402daeaea27ea13aa9f087ece57a /app-admin/bcfg2
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-58434377ff6dec748d68afe806147e5cbec0e8b8.tar.gz
gentoo-2-58434377ff6dec748d68afe806147e5cbec0e8b8.tar.bz2
gentoo-2-58434377ff6dec748d68afe806147e5cbec0e8b8.zip
Version bump, bug 252146
(Portage version: 2.2_rc20/cvs/Linux 2.6.27.10 x86_64)
Diffstat (limited to 'app-admin/bcfg2')
-rw-r--r--app-admin/bcfg2/ChangeLog9
-rw-r--r--app-admin/bcfg2/bcfg2-0.9.6.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/app-admin/bcfg2/ChangeLog b/app-admin/bcfg2/ChangeLog
index c45adb83d69a..c6785942a050 100644
--- a/app-admin/bcfg2/ChangeLog
+++ b/app-admin/bcfg2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/bcfg2
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bcfg2/ChangeLog,v 1.3 2008/09/08 18:33:02 darkside Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bcfg2/ChangeLog,v 1.4 2009/01/08 02:19:12 darkside Exp $
+
+*bcfg2-0.9.6 (08 Jan 2009)
+
+ 08 Jan 2009; Jeremy Olexa <darkside@gentoo.org> +bcfg2-0.9.6.ebuild:
+ Version bump, bug 252146
*bcfg2-0.9.6_pre2 (08 Sep 2008)
diff --git a/app-admin/bcfg2/bcfg2-0.9.6.ebuild b/app-admin/bcfg2/bcfg2-0.9.6.ebuild
new file mode 100644
index 000000000000..610e1f2056ca
--- /dev/null
+++ b/app-admin/bcfg2/bcfg2-0.9.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bcfg2/bcfg2-0.9.6.ebuild,v 1.1 2009/01/08 02:19:12 darkside Exp $
+
+EAPI=2
+
+inherit distutils
+
+DESCRIPTION="Bcfg2 is a configuration management tool."
+HOMEPAGE="http://trac.mcs.anl.gov/projects/bcfg2"
+
+# handle the "pre" case
+MY_P="${P/_/}"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="server"
+
+DEPEND=">=dev-lang/python-2.5"
+
+RDEPEND="app-portage/gentoolkit
+ dev-python/lxml
+ server? (
+ dev-python/pyopenssl
+ || ( app-admin/gamini[python] app-admin/fam ) )"
+
+src_install() {
+ distutils_src_install --record=PY_SERVER_LIBS --install-scripts /usr/sbin
+
+ # Remove files only necessary for a server installation
+ if ! use server; then
+ rm -rf "${D}"/usr/sbin/bcfg2-*
+ rm -rf "${D}"/usr/share/bcfg2
+ rm -rf "${D}"/usr/share/man/man8
+ fi
+
+ # Install a server init.d script
+ if use server; then
+ newinitd "${FILESDIR}"/bcfg2-server.rc bcfg2-server
+ fi
+
+ insinto /etc
+ doins "${S}"/examples/bcfg2.conf
+}
+
+pkg_postinst () {
+ depscan.sh
+ use server && einfo "If this is a new installation, you probably need to run: "
+ use server && einfo " bcfg2-admin init"
+}
+
+pkg_postrm () {
+ depscan.sh
+}