summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2006-10-14 18:15:15 +0000
committerChristian Birchinger <joker@gentoo.org>2006-10-14 18:15:15 +0000
commit883e109bd41b905cb4f4d24e91e04f2081049371 (patch)
treeea994065b9ed06cf4ae6e8d5da0c8ea0aed84427 /app-admin/ccze
parentMark 1.8.12 stable on ia64. #150926 (diff)
downloadgentoo-2-883e109bd41b905cb4f4d24e91e04f2081049371.tar.gz
gentoo-2-883e109bd41b905cb4f4d24e91e04f2081049371.tar.bz2
gentoo-2-883e109bd41b905cb4f4d24e91e04f2081049371.zip
Added a patch from drizzt@gentoo.org which fixes build on FreeBSD. Droped useless virtual/libc dependency.
(Portage version: 2.1.1)
Diffstat (limited to 'app-admin/ccze')
-rw-r--r--app-admin/ccze/ChangeLog9
-rw-r--r--app-admin/ccze/ccze-0.2.1-r1.ebuild39
-rw-r--r--app-admin/ccze/files/ccze-fbsd.patch25
-rw-r--r--app-admin/ccze/files/digest-ccze-0.2.12
-rw-r--r--app-admin/ccze/files/digest-ccze-0.2.1-r13
5 files changed, 77 insertions, 1 deletions
diff --git a/app-admin/ccze/ChangeLog b/app-admin/ccze/ChangeLog
index 465ed8e55648..e6018511aeda 100644
--- a/app-admin/ccze/ChangeLog
+++ b/app-admin/ccze/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/ccze
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/ccze/ChangeLog,v 1.9 2006/03/11 23:34:05 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ccze/ChangeLog,v 1.10 2006/10/14 18:15:15 joker Exp $
+
+*ccze-0.2.1-r1 (14 Oct 2006)
+
+ 14 Oct 2006; Christian Birchinger <joker@gentoo.org>
+ +files/ccze-fbsd.patch, +ccze-0.2.1-r1.ebuild:
+ Added a patch from drizzt@gentoo.org which fixes build on FreeBSD. Droped
+ useless virtual/libc dependency
11 Mar 2006; Christian Birchinger <joker@gentoo.org> ccze-0.2.1.ebuild:
Added a build fix for gcc4
diff --git a/app-admin/ccze/ccze-0.2.1-r1.ebuild b/app-admin/ccze/ccze-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..473014639d87
--- /dev/null
+++ b/app-admin/ccze/ccze-0.2.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ccze/ccze-0.2.1-r1.ebuild,v 1.1 2006/10/14 18:15:15 joker Exp $
+
+inherit fixheadtails autotools eutils
+
+DESCRIPTION="A flexible and fast logfile colorizer"
+HOMEPAGE="http://bonehunter.rulez.org/software/ccze/"
+SRC_URI="ftp://bonehunter.rulez.org/pub/ccze/stable/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE=""
+
+DEPEND="sys-libs/ncurses
+ dev-libs/libpcre"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}"/ccze-fbsd.patch || die "epatch ccze-fbsd.patch failed"
+
+ # GCC 4.x fixes
+ sed -e 's/-Wswitch -Wmulticharacter/-Wswitch/' \
+ -i src/Makefile.in
+ sed -e '/AC_CHECK_TYPE(error_t, int)/d' \
+ -i configure.ac
+
+ eautoreconf
+
+ ht_fix_file Rules.mk.in
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog ChangeLog-0.1 NEWS THANKS README FAQ
+}
diff --git a/app-admin/ccze/files/ccze-fbsd.patch b/app-admin/ccze/files/ccze-fbsd.patch
new file mode 100644
index 000000000000..d1f684ac26c4
--- /dev/null
+++ b/app-admin/ccze/files/ccze-fbsd.patch
@@ -0,0 +1,25 @@
+--- src/ccze-compat.h.old 2006-10-13 12:50:16 +0200
++++ src/ccze-compat.h 2006-10-13 12:49:21 +0200
+@@ -29,6 +29,11 @@
+ #include <stddef.h>
+ #include <stdio.h>
+
++# ifndef __error_t_defined
++typedef int error_t;
++# define __error_t_defined 1
++# endif
++
+ #ifndef HAVE_STRNDUP
+ char *strndup (const char *s, size_t size);
+ #endif
+--- src/ccze-compat.c.old 2006-10-13 12:51:35 +0200
++++ src/ccze-compat.c 2006-10-13 12:51:44 +0200
+@@ -275,7 +275,7 @@
+ char **valuep)
+ {
+ int i = getsubopt (optionp, tokens, valuep);
+-#if HAVE_SUBOPTARg
++#if HAVE_SUBOPTARG
+ if (!*valuep && suboptarg)
+ *valuep = strdup (suboptarg);
+ #endif
diff --git a/app-admin/ccze/files/digest-ccze-0.2.1 b/app-admin/ccze/files/digest-ccze-0.2.1
index 4a0f2b0ff1f3..6bfb802e7ad1 100644
--- a/app-admin/ccze/files/digest-ccze-0.2.1
+++ b/app-admin/ccze/files/digest-ccze-0.2.1
@@ -1 +1,3 @@
MD5 221966bce7c5f011eca38157241a0432 ccze-0.2.1.tar.gz 139795
+RMD160 22d89140ea0518c6a33c07464620a2a1fb212b94 ccze-0.2.1.tar.gz 139795
+SHA256 8263a11183fd356a033b6572958d5a6bb56bfd2dba801ed0bff276cfae528aa3 ccze-0.2.1.tar.gz 139795
diff --git a/app-admin/ccze/files/digest-ccze-0.2.1-r1 b/app-admin/ccze/files/digest-ccze-0.2.1-r1
new file mode 100644
index 000000000000..6bfb802e7ad1
--- /dev/null
+++ b/app-admin/ccze/files/digest-ccze-0.2.1-r1
@@ -0,0 +1,3 @@
+MD5 221966bce7c5f011eca38157241a0432 ccze-0.2.1.tar.gz 139795
+RMD160 22d89140ea0518c6a33c07464620a2a1fb212b94 ccze-0.2.1.tar.gz 139795
+SHA256 8263a11183fd356a033b6572958d5a6bb56bfd2dba801ed0bff276cfae528aa3 ccze-0.2.1.tar.gz 139795