summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-04-10 15:00:31 +0000
committerChristoph Mende <angelos@gentoo.org>2011-04-10 15:00:31 +0000
commit0b3c15242c27f94fc06198d56a6b5dafdc9483a2 (patch)
tree4245fd4a6009c51c95b98a5c63f84ebd158f13e3 /app-admin/chroot_safe/chroot_safe-1.4.ebuild
parentFix changes in gcc-4.6 (diff)
downloadgentoo-2-0b3c15242c27f94fc06198d56a6b5dafdc9483a2.tar.gz
gentoo-2-0b3c15242c27f94fc06198d56a6b5dafdc9483a2.tar.bz2
gentoo-2-0b3c15242c27f94fc06198d56a6b5dafdc9483a2.zip
Bump to EAPI4, respect LDFLAGS, CXX, cleanup
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/chroot_safe/chroot_safe-1.4.ebuild')
-rw-r--r--app-admin/chroot_safe/chroot_safe-1.4.ebuild31
1 files changed, 18 insertions, 13 deletions
diff --git a/app-admin/chroot_safe/chroot_safe-1.4.ebuild b/app-admin/chroot_safe/chroot_safe-1.4.ebuild
index c44c6d40b9b5..bc9f0bd3be6d 100644
--- a/app-admin/chroot_safe/chroot_safe-1.4.ebuild
+++ b/app-admin/chroot_safe/chroot_safe-1.4.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chroot_safe/chroot_safe-1.4.ebuild,v 1.3 2007/01/04 22:46:37 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chroot_safe/chroot_safe-1.4.ebuild,v 1.4 2011/04/10 15:00:31 angelos Exp $
+EAPI=4
inherit eutils
-DESCRIPTION="chroot_safe is a tool to chroot any dynamically linked application in a safe and sane manner."
+DESCRIPTION="a tool to chroot any dynamically linked application in a safe and sane manner"
HOMEPAGE="http://chrootsafe.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN//_}/${P}.tgz"
@@ -13,19 +14,23 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+}
+
src_compile() {
- econf \
- --libexecdir="/usr/$(get_libdir)" \
- --sbindir="/usr/sbin" \
- || die "econf failed"
- emake CPPFLAGS="${CXXFLAGS}" || die "emake failed"
+ emake CPPFLAGS="${CXXFLAGS}" CXX="$(tc-getCXX)"
}
src_install() {
- dolib.so chroot_safe.so || die "dolib.so failed"
- dosbin chroot_safe || die "dosbin failed"
- dosed "s:/chroot_safe::" /usr/sbin/chroot_safe \
- || die "dosed chroot_safe failed"
- doman chroot_safe.1 || die "doman failed"
+ dolib.so chroot_safe.so
+ dosbin chroot_safe
+ sed -i -e "s:/chroot_safe::" "${ED}"/usr/sbin/chroot_safe \
+ || die "sed chroot_safe failed"
+ doman chroot_safe.1
dodoc CHANGES.txt
}