summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-07-19 20:33:10 +0000
committerAlex Alexander <wired@gentoo.org>2009-07-19 20:33:10 +0000
commitf3c3cc0414cb16f31a0cce9777406b1e48229775 (patch)
tree661cced75ca9738532fca610b9310a1fba0d2a67 /app-admin/conky
parentVersion bump, timeout issues fixed, offline messages sending support (and bet... (diff)
downloadgentoo-2-f3c3cc0414cb16f31a0cce9777406b1e48229775.tar.gz
gentoo-2-f3c3cc0414cb16f31a0cce9777406b1e48229775.tar.bz2
gentoo-2-f3c3cc0414cb16f31a0cce9777406b1e48229775.zip
conky patch that fixes bug #278343
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/ChangeLog8
-rw-r--r--app-admin/conky/conky-1.7.1.1-r1.ebuild119
-rw-r--r--app-admin/conky/files/conky-1.7.1.1-comment.patch11
3 files changed, 137 insertions, 1 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index f61a5bb82ae4..3e1c9e522f6d 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.114 2009/07/14 20:39:42 billie Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.115 2009/07/19 20:33:10 wired Exp $
+
+*conky-1.7.1.1-r1 (19 Jul 2009)
+
+ 19 Jul 2009; Alex Alexander <wired@gentoo.org> +conky-1.7.1.1-r1.ebuild,
+ +files/conky-1.7.1.1-comment.patch:
+ added patch that fixes \# in TEXT. bug #278343
14 Jul 2009; Pielmeier Daniel <billie@gentoo.org> metadata.xml:
Document the ipv6 use flag.
diff --git a/app-admin/conky/conky-1.7.1.1-r1.ebuild b/app-admin/conky/conky-1.7.1.1-r1.ebuild
new file mode 100644
index 000000000000..ebeba9802970
--- /dev/null
+++ b/app-admin/conky/conky-1.7.1.1-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.7.1.1-r1.ebuild,v 1.1 2009/07/19 20:33:10 wired Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="An advanced, highly configurable system monitor for X"
+HOMEPAGE="http://conky.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3 BSD LGPL-2.1 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa apcupsd audacious bmpx debug hddtemp imlib lua math moc mpd nano-syntax nvidia openmp +portmon rss thinkpad truetype vim-syntax wifi X"
+
+DEPEND_COMMON="
+ X? (
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ truetype? ( x11-libs/libXft >=media-libs/freetype-2 )
+ imlib? ( media-libs/imlib2 )
+ nvidia? ( media-video/nvidia-settings )
+ )
+ alsa? ( media-libs/alsa-lib )
+ audacious? ( >=media-sound/audacious-1.5 )
+ bmpx? ( media-sound/bmpx >=sys-apps/dbus-0.35 )
+ portmon? ( dev-libs/glib )
+ lua? ( >=dev-lang/lua-5.1 )
+ openmp? ( >=sys-devel/gcc-4.3[openmp] )
+ rss? ( dev-libs/libxml2 net-misc/curl dev-libs/glib )
+ wifi? ( net-wireless/wireless-tools )
+ "
+RDEPEND="
+ ${DEPEND_COMMON}
+ apcupsd? ( sys-power/apcupsd )
+ hddtemp? ( app-admin/hddtemp )
+ moc? ( media-sound/moc )
+ nano-syntax? ( app-editors/nano )
+ vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ "
+DEPEND="
+ ${DEPEND_COMMON}
+ dev-util/pkgconfig
+ "
+
+src_prepare() {
+ cp "${FILESDIR}"/conky_no_x11.conf data/
+ epatch "${FILESDIR}"/"${P}"-comment.patch
+}
+
+src_configure() {
+ local myconf
+ if use X; then
+ myconf="--enable-x11 --enable-double-buffer --enable-xdamage"
+ myconf="${myconf} --enable-own-window $(use_enable truetype xft)"
+ else
+ myconf="--disable-x11 --disable-own-window"
+ fi
+
+ econf \
+ ${myconf} \
+ $(use_enable alsa) \
+ $(use_enable apcupsd) \
+ $(use_enable audacious) \
+ $(use_enable bmpx) \
+ $(use_enable debug) \
+ $(use_enable hddtemp) \
+ $(use_enable imlib imlib2) \
+ $(use_enable lua) \
+ $(use_enable thinkpad ibm) \
+ $(use_enable math) \
+ $(use_enable moc) \
+ $(use_enable mpd) \
+ $(use_enable nvidia) \
+ $(use_enable openmp) \
+ $(use_enable rss) \
+ $(use_enable wifi wlan) \
+ $(use_enable portmon)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog AUTHORS TODO || die "dodoc failed"
+ dohtml doc/docs.html doc/config_settings.html doc/variables.html \
+ || die "dohtml failed"
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${S}"/extras/vim/ftdetect/conkyrc.vim || die "doins failed"
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}"/extras/vim/syntax/conkyrc.vim|| die "doins failed"
+ fi
+
+ if use nano-syntax; then
+ insinto /usr/share/nano/
+ doins "${S}"/extras/nano/conky.nanorc|| die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "You can find a sample configuration file at"
+ elog "${ROOT%/}/etc/conky/conky.conf. To customize, copy"
+ elog "it to ~/.conkyrc and edit it to your liking."
+ elog
+ elog "For more info on Conky's new features please look at"
+ elog "the Changelog in ${ROOT%/}/usr/share/doc/${PF}"
+ elog "There are also pretty html docs available"
+ elog "on Conky's site or in ${ROOT%/}/usr/share/doc/${PF}/html"
+ elog
+ elog "Also see http://www.gentoo.org/doc/en/conky-howto.xml"
+ elog
+ elog "Vim syntax highlighting for conkyrc now enabled with"
+ elog "USE=vim-syntax, for Nano with USE=nano-syntax"
+ elog
+}
diff --git a/app-admin/conky/files/conky-1.7.1.1-comment.patch b/app-admin/conky/files/conky-1.7.1.1-comment.patch
new file mode 100644
index 000000000000..ef206cac06f8
--- /dev/null
+++ b/app-admin/conky/files/conky-1.7.1.1-comment.patch
@@ -0,0 +1,11 @@
+--- src/conky.c.old 2009-07-19 22:27:18.514288448 +0300
++++ src/conky.c 2009-07-19 23:12:27.905568398 +0300
+@@ -3264,6 +3264,8 @@
+ append_object(retval, obj);
+ }
+ }
++ } else if (*p == '\\' && *(p+1) == '#') {
++ strfold(p, 1);
+ } else if (*p == '#') {
+ remove_comment(p);
+ }