summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2007-09-01 05:08:49 +0000
committerJoshua Nichols <nichoj@gentoo.org>2007-09-01 05:08:49 +0000
commitd05f2bb06ac91df34f72b94748ad7cf836a4d613 (patch)
tree097127dfc3886a7b485e2fe697bb63c264b71186 /app-admin/eselect-rails/eselect-rails-0.10.ebuild
parentLink in libpthread with all binaries for now #190523 by Sergey D. (diff)
downloadgentoo-2-d05f2bb06ac91df34f72b94748ad7cf836a4d613.tar.gz
gentoo-2-d05f2bb06ac91df34f72b94748ad7cf836a4d613.tar.bz2
gentoo-2-d05f2bb06ac91df34f72b94748ad7cf836a4d613.zip
Initial version, to support rails 1.1.6-r2 and 1.2.3-r1.
(Portage version: 2.1.3.7)
Diffstat (limited to 'app-admin/eselect-rails/eselect-rails-0.10.ebuild')
-rw-r--r--app-admin/eselect-rails/eselect-rails-0.10.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/eselect-rails/eselect-rails-0.10.ebuild b/app-admin/eselect-rails/eselect-rails-0.10.ebuild
new file mode 100644
index 000000000000..b36162ee36a3
--- /dev/null
+++ b/app-admin/eselect-rails/eselect-rails-0.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-rails/eselect-rails-0.10.ebuild,v 1.1 2007/09/01 05:08:49 nichoj Exp $
+
+DESCRIPTION="Manages Ruby on Rails symlinks"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# Block versions of rails that install /usr/bin/rails
+# rails PDEPENDS on this package, so upgrade paths should be sane without
+# blockers. See: http://planet.gentoo.org/developers/zmedico/2007/08/19/using_blockers_to_adjust_merge_order
+RDEPEND=">=app-admin/eselect-1.0.10
+ !<dev-ruby/rails-1.1.6-r2
+ !~dev-ruby/rails-1.2.0
+ !~dev-ruby/rails-1.2.1
+ !~dev-ruby/rails-1.2.2
+ !=dev-ruby/rails-1.2.3
+"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins *.eselect || die "doins failed"
+}