summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-04-18 08:27:51 +0000
committerUlrich Müller <ulm@gentoo.org>2009-04-18 08:27:51 +0000
commitf36a4bd1ced47e55f8f3b45bf5973db3f38c0145 (patch)
treeb6ebecb6c9f20001fe1145f98b781d693784fb13 /app-admin/eselect/eselect-9999.ebuild
parentMask live ebuild for app-admin/eselect. (diff)
downloadgentoo-2-f36a4bd1ced47e55f8f3b45bf5973db3f38c0145.tar.gz
gentoo-2-f36a4bd1ced47e55f8f3b45bf5973db3f38c0145.tar.bz2
gentoo-2-f36a4bd1ced47e55f8f3b45bf5973db3f38c0145.zip
Version bump, fixes bugs 172636, 198461, 203114, 204937, 218557, 219864,
232874, 240402, 248470, 248487, 260464, and 264734. Add live ebuild. (Portage version: 2.2_rc30/cvs/Linux i686)
Diffstat (limited to 'app-admin/eselect/eselect-9999.ebuild')
-rw-r--r--app-admin/eselect/eselect-9999.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-admin/eselect/eselect-9999.ebuild b/app-admin/eselect/eselect-9999.ebuild
new file mode 100644
index 000000000000..f55ce5768881
--- /dev/null
+++ b/app-admin/eselect/eselect-9999.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect/eselect-9999.ebuild,v 1.1 2009/04/18 08:27:51 ulm Exp $
+
+ESVN_REPO_URI="svn://anonsvn.gentoo.org/eselect/trunk"
+ESVN_BOOTSTRAP="autogen.bash"
+
+inherit subversion
+
+DESCRIPTION="Modular -config replacement utility"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc bash-completion"
+
+DEPEND="sys-apps/sed
+ doc? ( dev-python/docutils )
+ || (
+ sys-apps/coreutils
+ sys-freebsd/freebsd-bin
+ app-admin/realpath
+ )"
+RDEPEND="sys-apps/sed
+ sys-apps/file
+ sys-libs/ncurses"
+
+# Commented out: only few users of eselect will edit its source
+#PDEPEND="emacs? ( app-emacs/gentoo-syntax )
+# vim-syntax? ( app-vim/eselect-syntax )"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc ; then
+ make html || die "failed to build html"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
+ use doc && dohtml *.html doc/*
+
+ # we don't use bash-completion.eclass since eselect
+ # is listed in RDEPEND.
+ if use bash-completion ; then
+ insinto /usr/share/bash-completion
+ newins misc/${PN}.bashcomp ${PN} || die
+ fi
+}
+
+pkg_postinst() {
+ if use bash-completion ; then
+ elog "In case you have not yet enabled command-line completion"
+ elog "for eselect, you can run:"
+ elog
+ elog " eselect bashcomp enable eselect"
+ elog
+ elog "to install locally, or"
+ elog
+ elog " eselect bashcomp enable --global eselect"
+ elog
+ elog "to install system-wide."
+ fi
+}