summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2009-07-03 19:24:30 +0000
committerMichael Januszewski <spock@gentoo.org>2009-07-03 19:24:30 +0000
commit7f357315f06e18e491ffa440fd241dba1c89f48d (patch)
treeca4f465f8ad729fa6013de313fbebc68357b4435 /app-admin/hddtemp
parentDo not perform any binary checks as this package uses upstream binaries (bug ... (diff)
downloadgentoo-2-7f357315f06e18e491ffa440fd241dba1c89f48d.tar.gz
gentoo-2-7f357315f06e18e491ffa440fd241dba1c89f48d.tar.bz2
gentoo-2-7f357315f06e18e491ffa440fd241dba1c89f48d.zip
Revision bump. Introduces the network-cron USE flag, like usbutils and pciutils (bug #274415).
(Portage version: 2.1.6.13/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'app-admin/hddtemp')
-rw-r--r--app-admin/hddtemp/ChangeLog11
-rwxr-xr-xapp-admin/hddtemp/files/update-hddtemp.db26
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild84
-rw-r--r--app-admin/hddtemp/metadata.xml5
4 files changed, 124 insertions, 2 deletions
diff --git a/app-admin/hddtemp/ChangeLog b/app-admin/hddtemp/ChangeLog
index dcbfb4d69d3c..0d0bd0bbf0a1 100644
--- a/app-admin/hddtemp/ChangeLog
+++ b/app-admin/hddtemp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/hddtemp
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.74 2009/04/08 23:11:06 spock Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.75 2009/07/03 19:24:29 spock Exp $
+
+*hddtemp-0.3_beta15-r4 (03 Jul 2009)
+
+ 03 Jul 2009; Michał Januszewski <spock@gentoo.org>
+ +hddtemp-0.3_beta15-r4.ebuild, +files/update-hddtemp.db, metadata.xml:
+ Revision bump. Introduces the network-cron USE flag, like usbutils and
+ pciutils (bug #274415).
08 Apr 2009; Michał Januszewski <spock@gentoo.org> -files/hddtemp.db,
hddtemp-0.3_beta15-r3.ebuild:
diff --git a/app-admin/hddtemp/files/update-hddtemp.db b/app-admin/hddtemp/files/update-hddtemp.db
new file mode 100755
index 000000000000..ecaeb5122d06
--- /dev/null
+++ b/app-admin/hddtemp/files/update-hddtemp.db
@@ -0,0 +1,26 @@
+#!/bin/bash
+
+update_db() {
+ local src=$1
+ local dst=$2
+
+ while read line ; do
+ if [[ -z $(echo "${line}" | sed -re 's/(^#.*|^\w*$)//') ]]; then
+ echo "${line}" >> "${dst}"
+ fi
+
+ id=$(echo "${line}" | grep -o '"[^"]*"')
+
+ grep "${id}" "${dst}" 2>&1 >/dev/null || echo "${line}" >> "${dst}"
+ done < "${src}"
+}
+
+die() {
+ echo "$*"
+ exit 1
+}
+
+cd /usr/share/hddtemp
+wget http://www.guzu.net/linux/hddtemp.db -O hddtemp.db -q || die "Failed to download new hddtemp.db file"
+update_db "hddgentoo.db" "hddtemp.db"
+
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
new file mode 100644
index 000000000000..8b9f0d285783
--- /dev/null
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild,v 1.1 2009/07/03 19:24:29 spock Exp $
+
+inherit eutils autotools
+
+MY_P=${P/_beta/-beta}
+DBV=20080531
+
+DESCRIPTION="A simple utility to read the temperature of SMART capable hard drives"
+HOMEPAGE="http://www.guzu.net/linux/hddtemp.php"
+SRC_URI="http://www.guzu.net/files/${MY_P}.tar.bz2 mirror://gentoo/hddtemp-${DBV}.db.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="network-cron nls"
+
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-satacmds.patch
+ epatch "${FILESDIR}"/${P}-byteswap.patch
+ epatch "${FILESDIR}"/${P}-execinfo.patch
+ epatch "${FILESDIR}"/${P}-nls.patch
+ epatch "${FILESDIR}"/${P}-iconv.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ myconf="--with-db-path=/usr/share/hddtemp/hddtemp.db"
+ # disabling nls breaks compiling
+ use nls || myconf="--disable-nls ${myconf}"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README TODO ChangeLog
+
+ insinto /usr/share/hddtemp
+ newins "${WORKDIR}/hddtemp-${DBV}.db" hddtemp.db
+ doins "${FILESDIR}"/hddgentoo.db
+
+ update_db "${D}/usr/share/hddtemp/hddgentoo.db" "${D}/usr/share/hddtemp/hddtemp.db"
+ newconfd "${FILESDIR}"/hddtemp-conf.d hddtemp
+ newinitd "${FILESDIR}"/hddtemp-init hddtemp
+
+ dosbin "${FILESDIR}"/update-hddtemp.db
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ echo -e "#!/bin/sh\n/usr/sbin/update-hddtemp.db" > "${T}"/hddtemp.cron
+ newexe "${T}"/hddtemp.cron update-hddtemp.db \
+ || die "Failed to install update cronjob"
+ fi
+}
+
+pkg_postinst() {
+ einfo "In order to update your hddtemp database, run:"
+ einfo " update-hddtemp.db"
+}
+
+update_db() {
+ local src=$1
+ local dst=$2
+
+ while read line ; do
+ if [[ -z $(echo "${line}" | sed -re 's/(^#.*|^\w*$)//') ]]; then
+ echo "${line}" >> "${dst}"
+ fi
+
+ id=$(echo "${line}" | grep -o '"[^"]*"')
+
+ grep "${id}" "${dst}" 2>&1 >/dev/null || echo "${line}" >> "${dst}"
+ done < "${src}"
+}
diff --git a/app-admin/hddtemp/metadata.xml b/app-admin/hddtemp/metadata.xml
index 36ec4f2b53d8..6a1c835a40fa 100644
--- a/app-admin/hddtemp/metadata.xml
+++ b/app-admin/hddtemp/metadata.xml
@@ -5,4 +5,9 @@
<maintainer>
<email>spock@gentoo.org</email>
</maintainer>
+<use>
+ <flag name='network-cron'>
+ Monthly cronjob to update hddtemp.db.
+ </flag>
+</use>
</pkgmetadata>