summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-04-27 11:11:29 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-04-27 11:11:29 +0000
commitbf5d26cf71c5c54198196e6e93817e7567a43f1f (patch)
tree82c79e86263b77a1b332dd27662c15057d622ea8 /app-admin/hddtemp
parentAdd mask for Gnome 3.12. (diff)
downloadgentoo-2-bf5d26cf71c5c54198196e6e93817e7567a43f1f.tar.gz
gentoo-2-bf5d26cf71c5c54198196e6e93817e7567a43f1f.tar.bz2
gentoo-2-bf5d26cf71c5c54198196e6e93817e7567a43f1f.zip
Merged r7 and r24 database update approach into a single ebuild.
Bumped to EAPI 5, btw. (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'app-admin/hddtemp')
-rw-r--r--app-admin/hddtemp/ChangeLog10
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild107
2 files changed, 116 insertions, 1 deletions
diff --git a/app-admin/hddtemp/ChangeLog b/app-admin/hddtemp/ChangeLog
index 8bf00bf3b330..a10ef8209cfa 100644
--- a/app-admin/hddtemp/ChangeLog
+++ b/app-admin/hddtemp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/hddtemp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.153 2014/04/27 11:00:47 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.154 2014/04/27 11:11:29 aidecoe Exp $
+
+*hddtemp-0.3_beta15-r25 (27 Apr 2014)
+
+ 27 Apr 2014; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ +hddtemp-0.3_beta15-r25.ebuild:
+ Merged r7 and r24 database update approach into a single ebuild.
+
+ Bumped to EAPI 5, btw.
27 Apr 2014; Amadeusz Żołnowski <aidecoe@gentoo.org>
-hddtemp-0.3_beta15-r3.ebuild, -hddtemp-0.3_beta15-r5.ebuild,
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild
new file mode 100644
index 000000000000..d9191a9ac16d
--- /dev/null
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r25.ebuild,v 1.1 2014/04/27 11:11:29 aidecoe Exp $
+
+EAPI=5
+
+inherit eutils autotools systemd
+
+MY_P=${P/_beta/-beta}
+DBV=20080531
+
+DESCRIPTION="A simple utility to read the temperature of SMART capable hard drives"
+HOMEPAGE="http://savannah.nongnu.org/projects/hddtemp/"
+SRC_URI="http://download.savannah.gnu.org/releases/hddtemp/${MY_P}.tar.bz2 mirror://gentoo/hddtemp-${DBV}.db.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="network-cron nls"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=(README TODO ChangeLog)
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-satacmds.patch
+ epatch "${FILESDIR}"/${P}-byteswap.patch
+ epatch "${FILESDIR}"/${P}-execinfo.patch
+ epatch "${FILESDIR}"/${P}-nls.patch
+ epatch "${FILESDIR}"/${P}-iconv.patch
+ epatch "${FILESDIR}"/${P}-dontwake.patch
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ myconf="--with-db-path=/usr/share/hddtemp/hddtemp.db"
+ # disabling nls breaks compiling
+ use nls || myconf="--disable-nls ${myconf}"
+ econf ${myconf}
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/hddtemp
+ newins "${WORKDIR}/hddtemp-${DBV}.db" hddtemp.db
+ doins "${FILESDIR}"/hddgentoo.db
+
+ update_db "${D}/usr/share/hddtemp/hddgentoo.db" "${D}/usr/share/hddtemp/hddtemp.db"
+ newconfd "${FILESDIR}"/hddtemp-conf.d hddtemp
+ newinitd "${FILESDIR}"/hddtemp-init hddtemp
+ systemd_newunit "${FILESDIR}"/hddtemp.service-r1 "${PN}.service"
+ systemd_install_serviced "${FILESDIR}"/hddtemp.service.conf
+
+ if use network-cron; then
+ dosbin "${FILESDIR}"/update-hddtemp.db
+ exeinto /etc/cron.monthly
+ echo -e "#!/bin/sh\n/usr/sbin/update-hddtemp.db" > "${T}"/hddtemp.cron
+ newexe "${T}"/hddtemp.cron update-hddtemp.db
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to update your hddtemp database, run:"
+ if use network-cron; then
+ elog " update-hddtemp.db"
+ else
+ elog " emerge --config =${CATEGORY}/${PF}"
+ fi
+ elog ""
+ elog "If your hard drive is not recognized by hddtemp, please consider"
+ elog "submitting your HDD info for inclusion into the Gentoo hddtemp"
+ elog "database by filing a bug at https://bugs.gentoo.org/"
+ echo
+ ewarn "If hddtemp complains but finds your HDD temperature sensor, use the"
+ ewarn "--quiet option to suppress the warning."
+}
+
+update_db() {
+ local src=$1
+ local dst=$2
+
+ while read line ; do
+ if [[ -z $(echo "${line}" | sed -re 's/(^#.*|^\w*$)//') ]]; then
+ echo "${line}" >> "${dst}"
+ fi
+
+ id=$(echo "${line}" | grep -o '"[^"]*"')
+
+ grep "${id}" "${dst}" 2>&1 >/dev/null || echo "${line}" >> "${dst}"
+ done < "${src}"
+}
+
+pkg_config() {
+ cd "${ROOT}"/usr/share/hddtemp || die
+
+ einfo "Trying to download the latest hddtemp.db file"
+ wget http://www.guzu.net/linux/hddtemp.db -O hddtemp.db \
+ || die "failed to download hddtemp.db"
+
+ update_db "hddgentoo.db" "hddtemp.db"
+}