summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-03-16 19:21:54 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-03-16 19:21:54 +0000
commit1a5324c08a37bd34064b6956f05639344abe96f5 (patch)
treecd70d775a2e7f914e3a1b0d5250d8d19f29c629b /app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild
parentMinor edit (Manifest recommit) (diff)
downloadgentoo-2-1a5324c08a37bd34064b6956f05639344abe96f5.tar.gz
gentoo-2-1a5324c08a37bd34064b6956f05639344abe96f5.tar.bz2
gentoo-2-1a5324c08a37bd34064b6956f05639344abe96f5.zip
switch to using rpm.eclass, which fixes bug #32872 by JF Burdet <jean-francois.burdet@adm.unige.ch>. Also, fixed up MY_P to make this more resilient to version bumps upstream. I have no idea what bug #22015 is all about though. Additionally, the install is a bit changed, no need to explicitly install stuff when a cp -a will do.
Diffstat (limited to 'app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild')
-rw-r--r--app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild43
1 files changed, 15 insertions, 28 deletions
diff --git a/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild b/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild
index 422f7e32efaf..59b116466d8c 100644
--- a/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild
+++ b/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild
@@ -1,44 +1,39 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild,v 1.6 2004/03/12 10:45:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hpasm/hpasm-6.30.0.12-r1.ebuild,v 1.7 2004/03/16 19:21:54 seemant Exp $
+inherit rpm
+
+MY_P=${P%.*}-${PV##*.}
+S=${WORKDIR}
DESCRIPTION="hp Server Management Drivers and Agents"
HOMEPAGE="http://h18000.www1.hp.com/products/servers/linux/documentation.html"
-SRC_URI="ftp://ftp.compaq.com/pub/products/servers/supportsoftware/linux/RedHat/hpasm-6.30.0-12.Redhat8_0.i386.rpm"
+SRC_URI="ftp://ftp.compaq.com/pub/products/servers/supportsoftware/linux/RedHat/${MY_P}.Redhat8_0.i386.rpm"
LICENSE="hp-value"
SLOT="0"
KEYWORDS="x86"
RDEPEND="snmp? ( net-analyzer/net-snmp )"
+
DEPEND="${RDEPEND}
virtual/linux-sources
net-mail/mailx
app-arch/rpm2targz"
-S=${WORKDIR}
-
src_unpack() {
- rpm2targz ${DISTDIR}/hpasm-6.30.0-12.Redhat8_0.i386.rpm || die
- tar zxf ${S}/hpasm-6.30.0-12.Redhat8_0.i386.tar.gz || die
- rm ${S}/opt/compaq/hpasm/addon/libcpqci.so || die
- rm ${S}/opt/compaq/hpasm/addon/libcpqci.so.1 || die
+ rpm_src_unpack
+ cd ${S}
+ find ./ -type l | xargs rm -f
}
src_install() {
- HPASM_HOME="/opt/compaq"
-
- dodir ${HPASM_HOME}
+
+ cp -a ${WORKDIR}/* ${D}
- cp -Rdp opt/compaq/* ${D}${HPASM_HOME}
+ dosym libcpqci.so.1.0 /opt/compaq/hpasm/addon/libcpqci.so.1
+ dosym libcpqci.so.1.0 /opt/compaq/hpasm/addon/libcpqci.so
- into /
- dosbin sbin/bootcfg
-
- dosym /opt/compaq/hpasm/addon/libcpqci.so.1.0 /opt/compaq/hpasm/addon/libcpqci.so.1
- dosym /opt/compaq/hpasm/addon/libcpqci.so.1.0 /opt/compaq/hpasm/addon/libcpqci.so
-
- dodir /usr/share/pixmaps
dosym /opt/compaq/cpqhealth/cpqasm/hplogo.xbm /usr/share/pixmaps/hplogo.xbm
dosym /opt/compaq/cpqhealth/cpqasm/m_blue.gif /usr/share/pixmaps/m_blue.gif
dosym /opt/compaq/cpqhealth/cpqasm/m_fail.gif /usr/share/pixmaps/m_fail.gif
@@ -65,15 +60,7 @@ src_install() {
dosym /usr/lib/libssl.so.0.9.6 /usr/lib/libssl.so.2
fi
- dodir /var/spool/compaq
-
- exeinto /etc/init.d
- doexe etc/init.d/hpasm
-
- doman usr/share/man/man4/cpqhealth.4.gz usr/share/man/man4/hpasm.4.gz \
- usr/share/man/man8/cpqimlview.8.gz usr/share/man/man8/hplog.8.gz \
- usr/share/man/man8/hpuid.8.gz
-
+ keepdir /var/spool/compaq
}
pkg_postinst() {