summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-09-11 12:55:30 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-09-11 12:55:30 +0000
commit82179ace29854896b53774c6df0fb15269795521 (patch)
tree5d3b0e52d032aa2f7b3214181ecade529d9e703f /app-admin/keepass
parentaddressing some concerns from bug# 414803 (diff)
downloadgentoo-2-82179ace29854896b53774c6df0fb15269795521.tar.gz
gentoo-2-82179ace29854896b53774c6df0fb15269795521.tar.bz2
gentoo-2-82179ace29854896b53774c6df0fb15269795521.zip
Version bump by Alessandro Di Federico <ale@clearmind.me>.
(Portage version: 2.1.11.14/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/keepass')
-rw-r--r--app-admin/keepass/ChangeLog8
-rw-r--r--app-admin/keepass/files/keepass-2.20-xsl-path-detection.patch45
-rw-r--r--app-admin/keepass/keepass-2.20.ebuild99
3 files changed, 151 insertions, 1 deletions
diff --git a/app-admin/keepass/ChangeLog b/app-admin/keepass/ChangeLog
index 24cdd79dc85e..6dc69c91826d 100644
--- a/app-admin/keepass/ChangeLog
+++ b/app-admin/keepass/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/keepass
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepass/ChangeLog,v 1.1 2012/08/04 14:21:04 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepass/ChangeLog,v 1.2 2012/09/11 12:55:30 kensington Exp $
+
+*keepass-2.20 (11 Sep 2012)
+
+ 11 Sep 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/keepass-2.20-xsl-path-detection.patch, +keepass-2.20.ebuild:
+ Version bump by Alessandro Di Federico <ale@clearmind.me>.
*keepass-2.19 (04 Aug 2012)
diff --git a/app-admin/keepass/files/keepass-2.20-xsl-path-detection.patch b/app-admin/keepass/files/keepass-2.20-xsl-path-detection.patch
new file mode 100644
index 000000000000..d3805feb0d98
--- /dev/null
+++ b/app-admin/keepass/files/keepass-2.20-xsl-path-detection.patch
@@ -0,0 +1,45 @@
+KeePass looks for some resources (XSL files) in the executable directory,
+however under UNIX system this not a good idea, so we look into the
+CommonApplicationData SpecialFolder, which usually maps to "/usr/share/".
+So the final search path should be "/usr/share/KeePass/XSL/".
+
+diff --git a/KeePass/Forms/AboutForm.cs b/KeePass/Forms/AboutForm.cs
+index 8a04c87..6083c00 100644
+--- a/KeePass/Forms/AboutForm.cs
++++ b/KeePass/Forms/AboutForm.cs
+@@ -31,9 +31,11 @@ using KeePass.UI;
+ using KeePass.Resources;
+ using KeePass.Util;
+ using KeePass.DataExchange;
++using KeePass.Native;
+
+ using KeePassLib;
+ using KeePassLib.Utility;
++using KeePassLib.Native;
+
+ namespace KeePass.Forms
+ {
+@@ -92,8 +94,21 @@ namespace KeePass.Forms
+ m_lvComponents.Items.Add(lvi);
+
+ lvi = new ListViewItem(KPRes.XslStylesheetsKdbx);
+- string strPath = WinUtil.GetExecutable();
+- strPath = UrlUtil.GetFileDirectory(strPath, true, false);
++
++ string strPath;
++ if (NativeLib.IsUnix())
++ {
++ strPath = Environment.GetFolderPath(Environment.SpecialFolder.CommonApplicationData);
++ strPath = UrlUtil.EnsureTerminatingSeparator(strPath, false);
++ strPath += PwDefs.ShortProductName.ToLower();
++ strPath = UrlUtil.EnsureTerminatingSeparator(strPath, false);
++ }
++ else
++ {
++ strPath = WinUtil.GetExecutable();
++ strPath = UrlUtil.GetFileDirectory(strPath, true, false);
++ }
++
+ strPath += AppDefs.XslFilesDir;
+ strPath = UrlUtil.EnsureTerminatingSeparator(strPath, false);
+ bool bInstalled = File.Exists(strPath + AppDefs.XslFileHtmlLite);
diff --git a/app-admin/keepass/keepass-2.20.ebuild b/app-admin/keepass/keepass-2.20.ebuild
new file mode 100644
index 000000000000..d959b786e7e7
--- /dev/null
+++ b/app-admin/keepass/keepass-2.20.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepass/keepass-2.20.ebuild,v 1.1 2012/09/11 12:55:30 kensington Exp $
+
+EAPI=4
+
+inherit eutils fdo-mime gnome2-utils mono multilib
+
+MY_PN="KeePass"
+DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
+HOMEPAGE="http://keepass.info/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aot"
+
+COMMON_DEPEND=">=dev-lang/mono-2.10.5"
+RDEPEND="${COMMON_DEPEND}
+ dev-dotnet/libgdiplus[cairo]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ # Remove Windows-specific things
+ pushd Build || die
+ . PrepMonoDev.sh || die
+ popd || die
+
+ # KeePass looks for some XSL files in the same folder as the executable,
+ # we prefer to have it in /usr/share/KeePass
+ epatch "${FILESDIR}/${PN}-2.20-xsl-path-detection.patch"
+}
+
+src_compile() {
+ # Build with Release target
+ xbuild /target:KeePass /property:Configuration=Release || die
+
+ # Run Ahead Of Time compiler on the binary
+ if use aot; then
+ mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
+ fi
+}
+
+src_install() {
+ # Wrapper script to launch mono
+ make_wrapper ${PN} "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
+
+ # Some XSL files
+ insinto /usr/share/${PN}/XSL
+ doins Ext/XSL/*
+
+ insinto /usr/$(get_libdir)/${PN}/
+ exeinto /usr/$(get_libdir)/${PN}/
+ doins Ext/KeePass.exe.config
+ # Default configuration, simply says to use user-specific configuration
+ doins Ext/KeePass.config.xml
+
+ # The actual executable
+ doexe Build/KeePass/Release/KeePass.exe
+
+ # Copy the AOT compilation result
+ if use aot; then
+ doexe Build/KeePass/Release/KeePass.exe.so
+ fi
+
+ # Prepare the icons
+ newicon -s 256 Ext/Icons/Finals/plockb.png "${PN}.png"
+ newicon -s 256 -t gnome -c mimetypes Ext/Icons/Finals/plockb.png "application-x-${PN}2.png"
+
+ # Create a desktop entry and associate it with the KeePass mime type
+ make_desktop_entry ${PN} ${MY_PN} ${PN} "System;Security" "MimeType=application/x-keepass2;"
+
+ # MIME descriptor for .kdbx files
+ insinto /usr/share/mime/packages/
+ doins "${FILESDIR}/${PN}.xml"
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+
+ elog "Optional dependencies:"
+ elog " x11-misc/xdotool (enables autotype)"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}