summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-03-31 11:20:08 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-03-31 11:20:08 +0000
commitecb73bcdd1ec2951aa78dffbc75c47df01a54d8d (patch)
tree293016beb51fdf8cf9428fbbe771cd15de96b019 /app-admin/lcap/lcap-0.0.6.ebuild
parentMoved x86 to stable. (diff)
downloadgentoo-2-ecb73bcdd1ec2951aa78dffbc75c47df01a54d8d.tar.gz
gentoo-2-ecb73bcdd1ec2951aa78dffbc75c47df01a54d8d.tar.bz2
gentoo-2-ecb73bcdd1ec2951aa78dffbc75c47df01a54d8d.zip
initial import
Diffstat (limited to 'app-admin/lcap/lcap-0.0.6.ebuild')
-rw-r--r--app-admin/lcap/lcap-0.0.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/lcap/lcap-0.0.6.ebuild b/app-admin/lcap/lcap-0.0.6.ebuild
new file mode 100644
index 000000000000..6d8e109a2faf
--- /dev/null
+++ b/app-admin/lcap/lcap-0.0.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/lcap/lcap-0.0.6.ebuild,v 1.1 2003/03/31 11:20:08 phosphan Exp $
+
+DESCRIPTION="kernel capability remover"
+
+# The normal homepage of the program was not reachable by the time
+# this ebuild was written
+HOMEPAGE="http://packages.debian.org/unstable/admin/lcap.html"
+
+# same for the sources
+SRC_URI="http://ftp.debian.org/debian/pool/main/l/lcap/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~x86"
+
+IUSE="lids"
+
+DEPEND="virtual/os-headers
+ virtual/glibc"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use lids || (sed < Makefile > Makefile.tmp -e "s:LIDS =:#\0:" && \
+ mv Makefile.tmp Makefile)
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ exeinto /usr/sbin
+ doexe lcap
+ doman lcap.8
+ dodoc README
+}