summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-12-04 22:36:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-12-04 22:36:49 +0000
commit7fe8a4e080659cb264719f330550f5ec7fb2749b (patch)
treea4ddc21007ec95f8c88f776f391fc1645363d8af /app-admin/localepurge/localepurge-0.5.4-r1.ebuild
parentadd patch for test phase (diff)
downloadgentoo-2-7fe8a4e080659cb264719f330550f5ec7fb2749b.tar.gz
gentoo-2-7fe8a4e080659cb264719f330550f5ec7fb2749b.tar.bz2
gentoo-2-7fe8a4e080659cb264719f330550f5ec7fb2749b.zip
Revbump. Fixes bug #164544 and #445910
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'app-admin/localepurge/localepurge-0.5.4-r1.ebuild')
-rw-r--r--app-admin/localepurge/localepurge-0.5.4-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/localepurge/localepurge-0.5.4-r1.ebuild b/app-admin/localepurge/localepurge-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..e696a1b531c4
--- /dev/null
+++ b/app-admin/localepurge/localepurge-0.5.4-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/localepurge/localepurge-0.5.4-r1.ebuild,v 1.1 2012/12/04 22:36:49 hwoarang Exp $
+
+EAPI=4
+
+inherit eutils prefix
+
+DESCRIPTION="Script to recover diskspace wasted for unneeded locale files and localized man pages."
+HOMEPAGE="http://gentoo.org
+http://git.overlays.gentoo.org/gitweb/?p=proj/localepurge.git;a=summary"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tbz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ # 164544
+ epatch "${FILESDIR}"/${P}-directorysum.patch
+ # 445910
+ epatch "${FILESDIR}"/${P}-parentdir.patch
+ eprefixify ${PN}
+}
+
+src_install() {
+ insinto /var/cache/${PN}
+ doins defaultlist
+ dosym defaultlist /var/cache/${PN}/localelist
+ insinto /etc
+ doins locale.nopurge
+ dobin ${PN}
+ doman ${PN}.8
+}