summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2013-10-26 16:27:42 +0000
committerJosé María Alonso <nimiux@gentoo.org>2013-10-26 16:27:42 +0000
commit44a446918979d3d6c16c6db4f9eaeb395fa6bac1 (patch)
treed322bce5e5ec5a95aba16de3948cd29a7f94bfe5 /app-admin/logrotate/logrotate-3.8.7.ebuild
parentapp-misc/colordiff: Add missing dep on perl, #489474 (diff)
downloadgentoo-2-44a446918979d3d6c16c6db4f9eaeb395fa6bac1.tar.gz
gentoo-2-44a446918979d3d6c16c6db4f9eaeb395fa6bac1.tar.bz2
gentoo-2-44a446918979d3d6c16c6db4f9eaeb395fa6bac1.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key D628E536)
Diffstat (limited to 'app-admin/logrotate/logrotate-3.8.7.ebuild')
-rw-r--r--app-admin/logrotate/logrotate-3.8.7.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/logrotate/logrotate-3.8.7.ebuild b/app-admin/logrotate/logrotate-3.8.7.ebuild
new file mode 100644
index 000000000000..f5105ce28280
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.8.7.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.8.7.ebuild,v 1.1 2013/10/26 16:27:42 nimiux Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="https://fedorahosted.org/logrotate/"
+SRC_URI="https://fedorahosted.org/releases/l/o/logrotate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="acl selinux"
+
+RDEPEND="
+ >=dev-libs/popt-1.5
+ selinux? (
+ sys-libs/libselinux
+ sec-policy/selinux-logrotate
+ )
+ acl? ( virtual/acl )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-datehack.patch \
+ "${FILESDIR}"/${P}-ignore-hidden.patch \
+ "${FILESDIR}"/${P}-fbsd.patch \
+ "${FILESDIR}"/${P}-noasprintf.patch \
+ "${FILESDIR}"/${P}-atomic-create.patch
+}
+
+src_compile() {
+ local myconf
+ myconf="CC=$(tc-getCC)"
+ use selinux && myconf="${myconf} WITH_SELINUX=yes"
+ use acl && myconf="${myconf} WITH_ACL=yes"
+ emake ${myconf} RPM_OPT_FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ insinto /usr
+ dosbin logrotate
+ doman logrotate.8
+ dodoc CHANGES examples/logrotate*
+
+ exeinto /etc/cron.daily
+ newexe "${S}"/examples/logrotate.cron "${PN}"
+
+ insinto /etc
+ doins "${FILESDIR}"/logrotate.conf
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "If you wish to have logrotate e-mail you updates, please"
+ elog "emerge virtual/mailx and configure logrotate in"
+ elog "/etc/logrotate.conf appropriately"
+ elog
+ elog "Additionally, /etc/logrotate.conf may need to be modified"
+ elog "for your particular needs. See man logrotate for details."
+ fi
+}