summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-06-11 06:09:34 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-06-11 06:09:34 +0000
commit3c8580d26ed6801b68accd91cdf332a1acab6482 (patch)
tree95370ac83751c8739f001ef01ef53d4f42f2a109 /app-admin/lsat/lsat-0.9.2.ebuild
parentgenerated hardenednosspnopie spec files regardless of ssp/pie capabilities (diff)
downloadgentoo-2-3c8580d26ed6801b68accd91cdf332a1acab6482.tar.gz
gentoo-2-3c8580d26ed6801b68accd91cdf332a1acab6482.tar.bz2
gentoo-2-3c8580d26ed6801b68accd91cdf332a1acab6482.zip
Verison bumped. Fixed runtime error. Bug 92231.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-admin/lsat/lsat-0.9.2.ebuild')
-rw-r--r--app-admin/lsat/lsat-0.9.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/lsat/lsat-0.9.2.ebuild b/app-admin/lsat/lsat-0.9.2.ebuild
new file mode 100644
index 000000000000..6de95ec38d00
--- /dev/null
+++ b/app-admin/lsat/lsat-0.9.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/lsat/lsat-0.9.2.ebuild,v 1.1 2005/06/11 06:09:34 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="The Linux Security Auditing Tool"
+HOMEPAGE="http://usat.sourceforge.net/"
+SRC_URI="http://usat.sourceforge.net/code/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+RDEPEND="virtual/libc
+ dev-libs/popt"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf || die
+ emake CFLAGS="${CFLAGS}" SLIBS="-lpopt" all manpage || die
+}
+
+src_install() {
+ dobin lsat || die
+ doman lsat.1
+ dodoc INSTALL README* *.txt
+ dohtml modules.html changelog/changelog.html
+}