summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-12-11 21:21:24 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-12-11 21:21:24 +0000
commitfcb28fbf435da7b7e7c51d92457a3458c1c9be2d (patch)
treea59e36c71ca773d05dee0e668776826cd208bf8c /app-admin/mcollective
parentVersion bump, drop old (#493826 by Marko Samiric) (diff)
downloadgentoo-2-fcb28fbf435da7b7e7c51d92457a3458c1c9be2d.tar.gz
gentoo-2-fcb28fbf435da7b7e7c51d92457a3458c1c9be2d.tar.bz2
gentoo-2-fcb28fbf435da7b7e7c51d92457a3458c1c9be2d.zip
version bump of mcollective 2.3.2
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-admin/mcollective')
-rw-r--r--app-admin/mcollective/ChangeLog8
-rw-r--r--app-admin/mcollective/mcollective-2.3.2.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/app-admin/mcollective/ChangeLog b/app-admin/mcollective/ChangeLog
index 442e6e72afbe..481eb8ad5d2b 100644
--- a/app-admin/mcollective/ChangeLog
+++ b/app-admin/mcollective/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/mcollective
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.18 2013/12/08 21:30:08 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/ChangeLog,v 1.19 2013/12/11 21:21:24 prometheanfire Exp $
+
+*mcollective-2.3.2 (11 Dec 2013)
+
+ 11 Dec 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +mcollective-2.3.2.ebuild:
+ version bump of mcollective 2.3.2
08 Dec 2013; Matthew Thode <prometheanfire@gentoo.org>
mcollective-2.2.4.ebuild:
diff --git a/app-admin/mcollective/mcollective-2.3.2.ebuild b/app-admin/mcollective/mcollective-2.3.2.ebuild
new file mode 100644
index 000000000000..ef57ffb880a4
--- /dev/null
+++ b/app-admin/mcollective/mcollective-2.3.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mcollective/mcollective-2.3.2.ebuild,v 1.1 2013/12/11 21:21:24 prometheanfire Exp $
+
+EAPI="4"
+
+#upstream is adding ruby20 support soonish, keep an eye out
+USE_RUBY="ruby19"
+
+inherit ruby-ng
+
+DESCRIPTION="Framework to build server orchestration or parallel job execution
+systems"
+HOMEPAGE="http://marionette-collective.org/"
+SRC_URI="http://puppetlabs.com/downloads/mcollective/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +client"
+
+DEPEND=""
+RDEPEND="dev-ruby/stomp"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+each_ruby_install() {
+ doruby -r lib/*
+ insinto /usr/share/mcollective
+ doins -r plugins
+ use client && dosbin bin/mc-* bin/mco
+ dosbin bin/mcollectived
+ if use doc ; then
+ dohtml -r doc/*
+ insinto /usr/share/doc/${P}/ext
+ doins -r ext/*
+ fi
+ newinitd "${FILESDIR}"/mcollectived.initd mcollectived
+ insinto /etc/mcollective
+ cd etc
+ for cfg in *.dist ; do
+ newins "${cfg}" "${cfg%%.dist}"
+ sed -i -e "s:^libdir.*:libdir = /usr/share/mcollective/plugins:" \
+ "${D}"/etc/mcollective/${cfg%%.dist} || die "sed failed"
+ done
+ insinto /etc/mcollective/plugin.d
+}
+
+pkg_postinst() {
+ einfo "Mcollective requires a stomp server installed and functioning before"
+ einfo "you can use it. The recommended server to use is ActiveMQ [1] but"
+ einfo "any other stomp compatible server should work."
+ einfo
+ einfo "It is recommended you read the \'getting started\' guide [2] if this"
+ einfo "is a new installation"
+ einfo
+ einfo "[1] http://activemq.apache.org/"
+ einfo "[2] http://code.google.com/p/mcollective/wiki/GettingStarted"
+}