summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2007-03-28 14:22:10 +0000
committerMasatomo Nakano <nakano@gentoo.org>2007-03-28 14:22:10 +0000
commit4b7858658a7bbef5c6e74183aa17a3970318e5d9 (patch)
treea43a5622065c63c86a4376fd0271bc5b71d00ccd /app-admin/puppet
parentBump with xulrunner support for Gnome 2.18.0 (diff)
downloadgentoo-2-4b7858658a7bbef5c6e74183aa17a3970318e5d9.tar.gz
gentoo-2-4b7858658a7bbef5c6e74183aa17a3970318e5d9.tar.bz2
gentoo-2-4b7858658a7bbef5c6e74183aa17a3970318e5d9.zip
version bump
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/ChangeLog7
-rw-r--r--app-admin/puppet/files/digest-puppet-0.22.33
-rw-r--r--app-admin/puppet/puppet-0.22.3.ebuild63
3 files changed, 72 insertions, 1 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index ec6c38512e7f..db11240237b3 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.2 2007/03/20 13:02:55 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.3 2007/03/28 14:22:10 nakano Exp $
+
+*puppet-0.22.3 (28 Mar 2007)
+
+ 28 Mar 2007; Masatomo Nakano <nakano@gentoo.org> +puppet-0.22.3.ebuild:
+ Version bump.
*puppet-0.22.2 (20 Mar 2007)
diff --git a/app-admin/puppet/files/digest-puppet-0.22.3 b/app-admin/puppet/files/digest-puppet-0.22.3
new file mode 100644
index 000000000000..29c5f58dcea0
--- /dev/null
+++ b/app-admin/puppet/files/digest-puppet-0.22.3
@@ -0,0 +1,3 @@
+MD5 da40886077c500c0bac980e7b755b836 puppet-0.22.3.tgz 629126
+RMD160 fd695d55d83bbfdac52073557d1b67ae9ea547e3 puppet-0.22.3.tgz 629126
+SHA256 39ecaca8466f5402e84cb2ce392def6d5d903fa33201de0d2e4816288d860e8a puppet-0.22.3.tgz 629126
diff --git a/app-admin/puppet/puppet-0.22.3.ebuild b/app-admin/puppet/puppet-0.22.3.ebuild
new file mode 100644
index 000000000000..969c224c34d1
--- /dev/null
+++ b/app-admin/puppet/puppet-0.22.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.22.3.ebuild,v 1.1 2007/03/28 14:22:10 nakano Exp $
+
+inherit eutils ruby
+
+DESCRIPTION="A system automation and configuration management software"
+LICENSE="GPL-2"
+HOMEPAGE="http://reductivelabs.com/projects/puppet/index.html"
+SRC_URI="http://reductivelabs.com/downloads/${PN}/${P}.tgz"
+RDEPEND=">=dev-ruby/facter-1.3.5 >=app-portage/eix-0.7.9"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86 ~amd64"
+
+USE_RUBY="ruby18"
+
+pkg_setup() {
+ built_with_use virtual/ruby ipv6 || \
+ die "Ruby must be built with ipv6 support, otherwise puppet will not be able to run"
+
+ enewgroup puppet || die "Problem creating group puppet"
+ enewuser puppet -1 -1 /var/lib/puppet puppet || die "Problem creating user puppet"
+}
+
+src_compile() {
+ DESTDIR=${D} ruby_econf || die
+ DESTDIR=${D} ruby_emake "$@" || die
+}
+
+src_install() {
+ DESTDIR=${D} ruby_einstall "$@" || die
+ DESTDIR=${D} erubydoc
+
+ # Installation of init scripts and configuration
+ doinitd ${S}/conf/gentoo/init.d/puppetmaster
+ doconfd ${S}/conf/gentoo/conf.d/puppetmaster
+ doinitd ${S}/conf/gentoo/init.d/puppet
+ doconfd ${S}/conf/gentoo/conf.d/puppet
+
+
+ # Initial configuration files
+ dodir /etc/puppet/manifests
+ insinto /etc/puppet
+ doins ${S}/conf/gentoo/puppet/*
+
+ # Location of log and data files
+ dodir /var/log/puppet
+ dodir /var/lib/puppet
+ keepdir /var/run/puppet
+}
+
+pkg_postinst() {
+ ewarn "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could cause puppet to hang"
+ ewarn "while installing packages."
+ ewarn
+ ewarn "Puppet uses eix to get information about currently installed packages, so please keep the eix"
+ ewarn "metadata cache updated so puppet is able to properly handle package installations."
+ ewarn
+ ewarn "Currently puppet only supports adding and removing services to the default runlevel, if you"
+ ewarn "want to add/remove a service from another runlevel you may do so using symlinking."
+}