summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-06-15 17:26:18 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-06-15 17:26:18 +0000
commitb1f35de2ad8ddabac8a68d8cc18dd541af563655 (patch)
tree04b9c892fbb03a399ecc1a32636ffd4be293a8c5 /app-admin/pwgen/pwgen-2.04.ebuild
parentstable on alpha ia64 (diff)
downloadgentoo-2-b1f35de2ad8ddabac8a68d8cc18dd541af563655.tar.gz
gentoo-2-b1f35de2ad8ddabac8a68d8cc18dd541af563655.tar.bz2
gentoo-2-b1f35de2ad8ddabac8a68d8cc18dd541af563655.zip
Version bumped to 2.04 and closing bug #96182.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-admin/pwgen/pwgen-2.04.ebuild')
-rw-r--r--app-admin/pwgen/pwgen-2.04.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/pwgen/pwgen-2.04.ebuild b/app-admin/pwgen/pwgen-2.04.ebuild
new file mode 100644
index 000000000000..073719b18f4d
--- /dev/null
+++ b/app-admin/pwgen/pwgen-2.04.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pwgen/pwgen-2.04.ebuild,v 1.1 2005/06/15 17:26:18 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Password Generator"
+HOMEPAGE="http://sourceforge.net/projects/pwgen/"
+SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ppc64 ~ppc-macos"
+IUSE="livecd"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's:$(prefix)/man/man1:$(mandir)/man1:g' Makefile.in
+}
+
+src_compile() {
+ econf --sysconfdir=/etc/pwgen || die "econf failed"
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ use livecd && exeinto /etc/init.d && newexe ${FILESDIR}/pwgen.rc pwgen
+}